Problem after update



  • Hi,
    I’ve update from 1.1.0 to 1.1.2, I seem to have a problem with the installation.

    If I reboot my ubuntu, I have to do the reinstall because I can’t go in the web interface.
    I have this :

    [SIZE=6][B]Database Schema Installer / Updater[/B][/SIZE]

    Your FOG database schema is not up to date, either because you have updated FOG or this is a new FOG installation. If this is a upgrade, we highly recommend that you backup your FOG database before updating the schema (this will allow you to return the previous installed version).
    If you would like to backup your FOG database you can do so my using MySql Administrator or by running the following command in a terminal window (Applications -> System Tools -> Terminal), this will save sqldump in your home directory.
    cd ~;mysqldump --allow-keywords -x -v fog > fogbackup.sql
    Are you sure you wish to install/update the FOG database?

    This seems to come back after a ubuntu reboot.

    Any Idea?


  • Senior Developer

    If you’re daring, are you trying out the latest SVN? I ask because with Mentaloid’s help, he created a setup to not startup certain services until FOG has a network device and mysql is running. I don’t know if this will fix mysql from starting at reboot, but you could try this version and see if it helps you out at al.

    Another issue I’ve seen and written about on my github site is about a similar issue with FOG. [url]https://github.com/mastacontrola/fogproject/issues/1[/url]

    This details one of the larger issues as well as a potential means to allow restarting mysql on reboots. i don’t know if it will work all the time, but it’s best I’ve been able to come up with.



  • … and now I eat my hat. A few days into the latest testing, this fix I employed sometimes works, sometimes doesn’t.



  • The code:
    [CODE]start on (net-device-up IFACE=eth0
    and local-filesystems
    and runlevel [2345])[/CODE]
    … does not work for me on Ubuntu 14.0.4.1 amd64 and svn 2230

    I’m using:
    [CODE] vim /etc/rc.local
    "i"
    insert new line at line 14 : service mysql restart[/CODE]



  • Thank you very much Jaymes. This trick worked for me too.

    All the best!



  • sorry for the delayed response, we were away on vacation!!

    the suggest fix for exiting the fog menu worked. Thank you!!


  • Developer

    what you’re seeing is not likely a “chain link” issue so much as an “exit” issue. try changing to a different exit type in the fog boot settings



  • I’ve tried it me too, everything seems ok!
    You guys are great!

    Thanks for the support!!!



  • James,
    Running Ubuntu 14.04.
    [I][B][COLOR=#ff0000]Adding the code mentioned above did fix my issue!![/COLOR][/B][/I]
    THANK YOU!!!

    One last question, in what appears to be my last issue, it looks like I have a chain link issue with my new Dell 9020’s. I’m able to boot to the fog menu but it does not properly boot to the HDD after the timer on the FOG menu expires.

    I saw some chain link fixes posted for previous versions of FOG (0.32) do you have any suggestions for a fix on the current 1.1.2 version?

    once again thank you for all of your help!!


  • Developer

    [quote=“drenj19, post: 31880, member: 24855”]to the bottom of the my.cnf file?[/quote]

    What version of Ubuntu did you install FOG on if you don’t mind my asking?

    No it should be at the top. The start on section:

    example
    [code]

    MySQL Service

    description "MySQL Server"
    author “Mario Limonciello superm1@ubuntu.com

    start on (net-device-up
    and local-filesystems
    and runlevel [2345])
    stop on runlevel [016]

    respawn

    env HOME=/etc/mysql
    umask 007

    pre-start script
    #Sanity checks
    [ -r $HOME/my.cnf ]
    [ -d /var/run/mysqld ] || install -m 755 -o mysql -g root -d /var/run/mysqld
    # Load AppArmor profile
    if aa-status --enabled 2>/dev/null; then
    apparmor_parser -r /etc/apparmor.d/usr.sbin.mysqld || true
    fi
    LC_ALL=C BLOCKSIZE= df --portability /var/lib/mysql/. | tail -n 1 | awk '{ exit ($4<4096) }'
    end script

    exec /usr/sbin/mysqld

    post-start script
    for i in seq 1 30 ; do
    /usr/bin/mysqladmin --defaults-file="${HOME}"/debian.cnf ping && {
    exec “${HOME}”/debian-start
    # should not reach this line
    exit 2
    }
    sleep 1
    done
    exit 1
    end script[/code]

    edit the line
    [code]
    start on (net-device-up
    and local-filesystems
    and runlevel [2345])[/code]

    to look like

    [code]
    start on (net-device-up IFACE=eth0
    and local-filesystems
    and runlevel [2345])[/code]



  • to the bottom of the my.cnf file?


  • Developer

    [quote=“drenj19, post: 31859, member: 24855”]I also do no see the line (net-device-up IFACE=ethX)", inside the mysql.conf[/quote]

    You won’t you add it.



  • just at the bottom of the config file?



  • I’d ass in my.cnf --service-startup-timeout=900 to see if that helps you out.



  • I also do no see the line (net-device-up IFACE=ethX)", inside the mysql.conf



  • I don’t see "[FONT=Helvetica][COLOR=#000000][SIZE=14px]–service-startup-timeout inside the my.cnf file… again, just to reiterate, it does appear that MySQL starts and then crashes. after that restarting MySQL allows me use the fog management website.[/SIZE][/COLOR][/FONT]

    [FONT=Helvetica][COLOR=#000000][SIZE=14px]is there a way to script the restart of the mysql service after 120 secs after boot?[/SIZE][/COLOR][/FONT]


  • Developer

    Add the start condition in /etc/init/mysql.conf to"start on (net-device-up IFACE=ethX)", where “X” is the interface you have mysql bound to, e.g. ETH0, usually the same port FOG is using.

    We used this similar command to help with start up problems in Ubuntu 12.04 for tftpd-hpa service, it might help here as well.

    This of course doesn’t solve the issue but may help alleviate the need to type the command on each reboot.



  • Sounds like MySQL isn’t waiting to connect and just fails on startup. Ubuntu does weird things in the sake of “speeding up startup”.

    Check in your my.cnf for MySQL what “[FONT=Helvetica][COLOR=#000000][SIZE=14px]–service-startup-timeout” is set to.[/SIZE][/COLOR][/FONT]



  • so… my issue is definitely related to MySQL and not the password in the ./fogsettings file.
    after a Ubuntu restart, the for website will run for a minute or so before displaying the [SIZE=6][B]Database Schema Installer / Updater again…[/B][/SIZE] .

    manually restarting MySQL temporarily fixes the issue until the next reboot… any suggestions?



  • After doing more testing I find that restarting the MySQL daemon temporarily fixes the issue until the next reboot.
    sudo service mysql stop
    sudo service mysql start


Log in to reply
 

480
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.