Mounting file system error



  • Hey all,

    So after trying to upgrade and breaking everything I tried a fresh install on Ubuntu server 12.10, managed to get nearly everything working, however, when trying to upload a image i get the following -

    [FONT=arial][COLOR=#222222]* Send method … NFS:[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]* Checking in … done[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]* Mounting fine system … mount: mounting:/home/images/dev/ on /images failed: Permission denied[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]Done[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]* Preparing to send image file to server.[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]* Checking Mounted File System …[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]#####################################################[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]# #[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]# An error has been detected #[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]# #[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]#####################################################[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]Fatal error : Failed to mount NFS volume[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]#####################################################

    Computer will reboot in 1 minute

    #####################################################[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]Not entirely sure what’s going on, I’ve tried changing the credentials it uses to root (temporarily) which doesn’t fix it. Have 777’d home/ recursively, checked that .mntcheck exists etc.[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]Any help would be gratefully received![/COLOR][/FONT]



  • Adding to what Tom said
    changing the storage node location Local

    1. If the storage node location is local make sure it is mounted in /etc/fstab
      example:
      UUID=b2584c6a-dddd-4939-9f86-f77a816fad8a /media/images2 ext4 errors=remount-ro 0 0
    2. Change the info on the web interface to reflect your new Storage Group, mine was local, so I just reused the same Ip, made sure the user, pass were set to one that matches a user on the Linux box with the same 777 permissions on the destination
      example:
      chmod -R 0777 /where/you/want/to/put/your/shit
    3. copy all the files from the original /images folder specifically /images/dev, /images/.mntcheck, /images/postdownloadscripts to the new location
      example:
      cp -rp /images/* /where/you/want/to/put/your/shit
      ##########################################################################
      This is what worked for me to get rid of the

    “Mounting File System…Failed”

    problem I encountered after moving the storage node to a larger local disk
    ##########################################################################

    1. Edit the /etc/exports file to reflect the new datastore location, don’t forget to copy the files over as mentioned above
      example:
      From:
      /images
      /images/dev
      To:
      /where/you/want/to/put/your/shit
      /where/you/want/to/put/your/shit/dev

    #save

    #restart the service

    service nfs-kernel-server restart


  • Moderator

    RCP is running, right?


  • Moderator

    The normal setup is to have images stored in /images
    So, you wouldn’t need to change the exports file to /home/images. It should be pointing to wherever they actually are.

    There is a way to change the credentials used, it’s in Storage Management, through the web GUI. But, whatever you set it to, that user must exist on the machine with the images on it, and that user must have permissions on that directory.

    Normally, people are told to set the permissions to 777 just for troubleshooting purposes.

    I noticed in the installation log that this machine is configured as a storage node. So now, you potentially have two machines to troubleshoot.

    But, because your errors say “Permission Denied”, I would focus on permissions. Like NFS, the exports file, the directory permissions, making sure all the credentials are correct…



  • Yes, we have imaged before on this machine. Originally, the images were stored locally, but we wanted to move them to an NFS share so we mounted a share and linked the share to /images.

    The images are now stored on an NFS share at /mnt/nfs/images2 which is linked to /images.

    Attached is the LOG File from /var/log/foginstall.log
    [FONT=Helvetica][SIZE=12px] [/SIZE][/FONT]

    Yes, NFS is running and this image deployment was setup as a unicast.

    The Firewall is turned off and has not been tampered with since it was working.

    I will try to mount the share via another machine using the fog credentials. Is there a way to tell FOG to use a different set of credentials to mount the /images or NFS share when imaging systems?

    [url="/_imported_xf_attachments/1/1784_foglog.pdf?:"]foglog.pdf[/url]


  • Moderator

    [quote=“abstert, post: 43823, member: 23224”]Yeah, I was trying to hide the IP, as if it mattered since it’s internal.

    The FOG version is 1.2.0. I tried the steps earlier, but there is no “/home/images” to place in the exports file.[/quote]

    Ok, so have you ever successfully imaged with this machine?
    Where are your images stored?
    Can you post your FOG installation log? It’s here: [SIZE=12px]/var/log/foginstall.log[/SIZE]
    Have you checked that NFS is running? Or, whatever it’s called in Cent OS?
    Is this just for Unicast, or Multicast?
    Do you have the firewall off?

    Another thing to try is mount the location of your images on a separate machine, using your Cent OS FOG user’s credentials, and see if that succeeds or not…



  • Yeah, I was trying to hide the IP, as if it mattered since it’s internal.

    The FOG version is 1.2.0. I tried the steps earlier, but there is no “/home/images” to place in the exports file.


  • Moderator

    [quote=“abstert, post: 43820, member: 23224”]I have a similar issue but this is when I’m downloading an image to a client machine.
    I get:

    • Mounting File System…Failed
      mount: mounting <IP ADDRESS OF FOG SERVER>:/images/ on /images failed: Permission Denied
      [ATTACH=full]1783[/ATTACH]

    This is on a CENTOS 6.5 system[/quote]

    Does it actually say that anywhere? the <IP ADDRESS OF FOG SERVER> ?? Was just wondering if you edited that out or not because the IP clearly shows in your picture.

    Have you followed Tom’s help from earlier in this thread?

    What version of FOG are you running?



  • I have a similar issue but this is when I’m downloading an image to a client machine.
    I get:

    • Mounting File System…Failed
      mount: mounting <IP ADDRESS OF FOG SERVER>:/images/ on /images failed: Permission Denied
      [ATTACH=full]1783[/ATTACH]

    This is on a CENTOS 6.5 system

    [url="/_imported_xf_attachments/1/1783_Screen Shot 2015-03-12 at 3.44.22 PM.png?:"]Screen Shot 2015-03-12 at 3.44.22 PM.png[/url]


  • Senior Developer

    That’s what I do! Or try to in most cases.



  • [quote=“Tom Elliott, post: 31594, member: 7271”]Edit the /etc/exports file.

    Make the lines that say:
    [code]/images
    /images/dev[/code]

    Change those parts to
    [code]/home/images
    /home/images/dev[/code]

    Restart the nfs server:
    [code]service nfs-kernel-server restart[/code]

    Try again.[/quote]

    Damn that was a quick reply! Trying it now.



  • Should also mention that it’s a fresh install of 1.1.2.


  • Senior Developer

    Edit the /etc/exports file.

    Make the lines that say:
    [code]/images
    /images/dev[/code]

    Change those parts to
    [code]/home/images
    /home/images/dev[/code]

    Restart the nfs server:
    [code]service nfs-kernel-server restart[/code]

    Try again.


Log in to reply
 

366
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.