Time problem



  • Since today I have a problem with time:
    HW clock and system clock are both set to localtime. But in Logviewer/Scheduler the time shown in the list is UTC.
    The same happens if I set HW clock to UTC.
    So I have to schedule to UTC time to run tasks at the desired time (UTC time is -3 hours from localtime).
    Has it something to do with 1.1.2 update I did today, or I messed something up?
    Any solution?
    Thank you



  • I added correctly [CODE]date.timezone = “Europe/Athens”[/CODE], restarted apache and pc but nothing has changed:
    Time here 11:00
    in pc:
    localtime: 11:00
    bios time: 8:00
    Log viewer/Schedulerer:
    8:00…
    I find strange:
    time here 11:00
    in pc:
    localtime: 14:00 (which is wrong)
    bios time: 11:00
    Log viewer/Schedulerer: 8:00
    I thought that Log viewer/Schedulerer: 8:00 was utc but in 2nd case it is not.
    With or without [CODE]date.timezone = “Europe/Athens”[/CODE] the above are the same.
    In the 1st case I can schedule correctly when I put scheduled tasks in bios time.
    Why does this happen? I never had time problems…
    Linux is debian 7.5 and fog 1.1.2. With xubuntu 14.04 happens exactly the same. With debian 7.5 with 1.1.1 I did not have any time problems.
    Is it something related to fog 1.1.2 or some wrong setting in my pc?

    [CODE]# cat /etc/timezone
    Europe/Athens

    hwclock --debug

    hwclock from util-linux 2.20.1
    Using /dev interface to clock.
    Last drift adjustment done at 1404124210 seconds after 1969
    Last calibration done at 1404124210 seconds after 1969
    Hardware clock is on UTC time
    Assuming hardware clock is kept in UTC time.
    Waiting for clock tick…
    …got clock tick
    Time read from Hardware Clock: 2014/06/30 08:42:35
    Hw clock time : 2014/06/30 08:42:35 = 1404117755 seconds since 1969
    Mon 30 Jun 2014 11:42:35 AM EEST -0.453762 seconds
    [/CODE]



  • This post is deleted!

  • Senior Developer

    What exactly is the line

    It should look like:
    [code]date.timezone = “Europe/Athens”[/code]

    Not
    [code];date.timezone = “Europe/Athens”[/code]

    The quotes are necessary, but they won’t hurt anything either.

    After you make the addition you also need to restart apache2/httpd:
    FOR REDHAT BASED:
    [code]service httpd restart[/code]
    FOR DEBIAN BASED:
    [code]service apache2 restart[/code]



  • Thank you.
    I don’t mind times being reported correctly but I want to schedule in localtime and not utc.

    I edited [SIZE=3][FONT=arial][COLOR=#333333]/etc/php5/apache2/php.ini[/COLOR][/FONT][/SIZE]
    [SIZE=3][FONT=arial][COLOR=#333333]and put Europe/Athens with and without “” in [/COLOR][/FONT][/SIZE][SIZE=3][FONT=arial][COLOR=#003300][CODE]date.timezone =[/CODE]. I restarted, but time in Log viewer/Scheduler still is UTC. I changed the HW clock from localtime to UTC, but the problem remains.[/COLOR][/FONT][/SIZE]


  • Developer

    only if you want the times to be reported correctly ;)



  • No, i didn’t. Should i set it?


  • Developer

    have you set the timezone in apache2?


Log in to reply
 

353
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.