Fog upgrade 1.1.1 --> 1.1.2 database error



  • Hi guys,

    Just having trouble getting fog to update to version 1.1.2.
    I’m not sure if this is a bug or something I may have done.
    but I get the following when trying to run the Database Schema Install / Updater

    [CODE]1.1.2
    Open Source Computer Cloning Solution
    Database Schema Installer / Updater

    Update/Install Failed!
    The following errors occured

    Update ID: 1 - 0

    Database Error:

    Database SQL:

    CREATE DATABASE fog

    Update ID: 1 - 1

    Database Error:

    Database SQL:

    CREATE TABLE fog.groupMembers (
    gmID int(11) NOT NULL auto_increment,
    gmHostID int(11) NOT NULL,
    gmGroupID int(11) NOT NULL,
    PRIMARY KEY (gmID),
    KEY new_index (gmHostID),
    KEY new_index1 (gmGroupID)
    ) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=latin1 ROW_FORMAT=DYNAMIC[/CODE]

    That is a small snip but it lists on and on for quite awhile.

    I’ve pasted the full error here: --> [url]http://pastebin.com/vY2FVYQh[/url]

    Cheers,



  • Can confirm I edited the .fogsettings and Config.class.php files and the database then upgraded perfect fine, just editing the .fogsettings still wasn’t working hence changing the Config too.



  • Simple logical fix, as always thanks for the continued progress guys :)



  • This post is deleted!


  • I had the same problem as RipAU; 100+ database errors when attempting v1.1.1 > v1.1.2 upgrade.

    As John Hough found, my [I].fogsettings[/I] file (located at /opt/fog/) was as follows:
    [CODE]ipaddress=“10.0.115.43”;
    interface=“eth0”;
    routeraddress=" option routers 10.0.115.254;";
    plainrouter=“10.0.115.254”;
    dnsaddress=" option domain-name-servers 10.0.115.4; “;
    dnsbootimage=“10.0.115.4”;
    password=“98180b”;
    osid=“2”;
    osname=“Debian”;
    dodhcp=“n”;
    bldhcp=“0”;
    installtype=“N”;
    snmysqluser=”"
    snmysqlpass=“98180b”;
    snmysqlhost="";
    installlang=“0”;
    donate=“0”;
    fogupdateloaded=“1”[/CODE]
    The problems were obvious, particularly [I]routeraddress, dnsaddress, snmysqluser, snmysqlpass[/I] (I never set one?) and some semicolons in the wrong place, so I amended the file to look like:
    [CODE]ipaddress=“10.0.115.43”;
    interface=“eth0”;
    routeraddress=“10.0.115.254”;
    plainrouter=“10.0.115.254”;
    dnsaddress=“10.0.115.4”;
    dnsbootimage=“10.0.115.4”;
    password="";
    osid=“2”;
    osname=“Debian”;
    dodhcp=“n”;
    bldhcp=“0”;
    installtype=“N”;
    snmysqluser=“root”
    snmysqlpass="";
    snmysqlhost=“localhost”;
    installlang=“0”;
    donate=“0”;
    fogupdateloaded=“1”[/CODE]

    I ran [I]./install.sh[/I] again and the upgrade went OK.

    As Tom Elliot said, he fixed a many installer errors, but not all. Kudos to Tom for keeping FOG development going :)



  • [quote=“darkxeno, post: 31683, member: 4011”]just fixed it I went in to the /var/www/fog/lib/fog/Config.class.php and removed the password from there and it fixed it[/quote]

    Thanks! that did it for me as well.



  • This one is done. Now I’m working on the non-booting machines issues.



  • It looks like now that it is updated, it is still going to the scheme updater package. How can I get back to my login screen?



  • Thank you for the thread! This just saved me hours of work!



  • [quote=“Rui Araújo, post: 31804, member: 24515”]Thank you so much! It solved my problem too! :D[/quote]
    no problem anything to help



  • [quote=“darkxeno, post: 31683, member: 4011”]just fixed it I went in to the /var/www/fog/lib/fog/Config.class.php and removed the password from there and it fixed it[/quote]
    Thank you so much! It solved my problem too! :D



  • just fixed it I went in to the /var/www/fog/lib/fog/Config.class.php and removed the password from there and it fixed it



  • Im have the same issue but updating my setting didnt help me at all



  • This post is deleted!


  • I had the same issue because during installation in the last message I pressed Enter without reading it. But the message was first to update database and then press enter. So I uninstalled fog and reinstalled correctly.



  • Ahhh yep, fixing up the root password and localhost fixed the issue.
    I was confused as it seemed to work perfect the way it was on previous installations.

    Thank you very much. I’ll start the upgrade on my storage nodes now as well.



  • Did some more troubleshooting based on those Apache errors, I did a diff between the DatabaseManager.class.php between the versions and noticed the changes in where it is checking for the DATABASE_TYPE. I went into the Config.class.php that is used with 1.1.2 and found a static password entry for the root user when connecting to the MySQL database. I removed the static password leaving just the “” on the line, I then loaded up the page and the database update processed without problems.


  • Testers

    This is more of a workaround than a solution

    I had the same issue with the installer, the mysql configuration in /var/www/html/fog/lib/fog/Config.class.php ended up being incorrect this led to the upgrade script in the fog GUI not detecting my current settings and trying to do a CREATE as in the first post. Putting the correct information allowed the update script to complete successfully.



  • I am experiencing the same issue, if I reinstall 1.1.1 I can get back in. While trouble shooting it I made copies of my before and after .fogsettings file in the /opt/fog directory and noticed a couple of things.

    First this is the one from the 1.1.1 installation:

    Created by the FOG Installer

    Version: 1.1.1

    Install time: Thu 26 Jun 2014 10:56:41 AM MDT

    ipaddress=“172.16.0.13”;
    interface=“bond0”;
    routeraddress="# option routers x.x.x.x;";
    plainrouter="";
    dnsaddress="# option domain-name-servers x.x.x.x; “;
    dnsbootimage=”";
    password=“b5a9cd”;
    osid=“2”;
    osname=“Debian”;
    dodhcp=“n”;
    bldhcp=“0”;
    installtype=“N”;
    snmysqluser=“root”;
    snmysqlpass="";
    snmysqlhost=“localhost”;
    installlang=“0”;
    donate=“1”;
    fogupdateloaded=“1”

    Next is the one after 1.1.2 was installed:

    Created by the FOG Installer

    Version: 1.1.1

    Install time: Thu 26 Jun 2014 11:12:18 AM MDT

    ipaddress=“172.16.0.13”;
    interface=“bond0”;
    routeraddress="# option routers x.x.x.x;";
    plainrouter="";
    dnsaddress="# option domain-name-servers x.x.x.x; “;
    dnsbootimage=”";
    password=“a41d31”;
    osid=“2”;
    osname=“Debian”;
    dodhcp=“n”;
    bldhcp=“0”;
    installtype=“N”;
    snmysqluser=“root”
    snmysqlpass=“a41d31”;
    snmysqlhost=“localhost”;
    installlang=“0”;
    donate=“1”;
    fogupdateloaded=“1”

    The installer changed the password entries and I noticed the semicolon is missing after the mysqluser line as well as the fogupdateloaded line.

    However I do not believe that this is the problem, my apache2 error log fills up with these errors with 1.1.2 installed and not with 1.1.1 installed.

    [Thu Jun 26 11:49:59.404576 2014] [:error] [pid 4933] [client 172.16.3.24:52333] PHP Warning: MySQL::sqlerror(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 180
    [Thu Jun 26 11:49:59.404833 2014] [:error] [pid 4933] [client 172.16.3.24:52333] PHP Warning: mysqli::escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 247
    [Thu Jun 26 11:49:59.404906 2014] [:error] [pid 4933] [client 172.16.3.24:52333] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 89
    [Thu Jun 26 11:49:59.404946 2014] [:error] [pid 4933] [client 172.16.3.24:52333] PHP Warning: MySQL::sqlerror(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 180


  • Developer

    [quote=“ckruijntjens, post: 31412, member: 24566”]Hello,

    I have the same issue??[/quote]

    then have you tried the same suggested solution?


 

595
Online

5.4k
Users

12.6k
Topics

118.7k
Posts