PXEBoot, DHCP failure.



  • Hi all,

    I was wondering if any of you could shed some light into a problem I am having trying to deploy Fog. I am trying to use fog in a medium sized business network to image 1 training machine setup and running WIN7x64 and distribute this image to 20 or so other same make/model computers. On our main server that hosts the domain I have created a virtual Ubuntu server machine, set the network adapater to bridged and installed Fog. During installation I opted for a normal rollout, with Fog’s DHCP service disabled, provided Fog with the IP address of our DHCP server, and set a password for MySQL.

    I had an issue with creating the static IP address profile, I edited the file and input the values, but after restarting and trying to ping a website it wouldn’t work… therefore I reverted back to acquiring an IP address through DHCP (which then does work) but assume seeing as it won’t be switched off this shouldn’t be a problem.

    Haven’t created the DNS entry yet, so I navigate on a PC to http://192.168.254.125/fog/management and that all works fine. So I try to power up the machine I want to image, pressing F12 as I do and selecting ‘Onboard NIC’ it then goes to establishing and initialising the link and returns a MAC address. It then moves on to ‘DHCP…’ and everytime no matter which computer I try it on it will fail to get anything and then just prompts for a computer restart.

    Any clues?

    Many Thanks,

    Ryan.



  • @Jaymes Driver, post: 31422, member: 3582 said:

    That part is only required to server multiple subnets, for now focus on getting one of your networks working and look into the ip Helper later. I personally don’t use the ip Helpers. My other co workers set some up to help resolve to WDS and I want to use FOG, so I use DNSmasq to override their settings. I’ve never had an issue, but I realize it’s all about the network structure and the equipment.

    Thank you, this has worked :)


  • Developer

    @rjn239, post: 31304, member: 24764 said:

    Thanks for the alternative, seems like a good work around. Only problem is after implementing and getting to the final step:

    ‘Add an IP Helper/DHCP Relay record to your router or switch so the DHCP broadcasts are sent to your normal DHCP server AND the Fog server.’

    My router is the DHCP server, therefore it doesn’t allow you to provide a DHCP relay address without insisting it turns off the DHCP services… PAIN!

    That part is only required to server multiple subnets, for now focus on getting one of your networks working and look into the ip Helper later. I personally don’t use the ip Helpers. My other co workers set some up to help resolve to WDS and I want to use FOG, so I use DNSmasq to override their settings. I’ve never had an issue, but I realize it’s all about the network structure and the equipment.



  • http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE

    It’s a simple set up and easy to remove.[/quote]

    Thanks for the alternative, seems like a good work around. Only problem is after implementing and getting to the final step:

    ‘Add an IP Helper/DHCP Relay record to your router or switch so the DHCP broadcasts are sent to your normal DHCP server AND the Fog server.’

    My router is the DHCP server, therefore it doesn’t allow you to provide a DHCP relay address without insisting it turns off the DHCP services… PAIN!


  • Developer



  • OK in an attempt to try provide you guys with as much info as possible I have tried to pull the file from the Fog Server through Windows… this works?

    Error.pngDHCP.png



  • This post is deleted!


  • Thanks for your reply! I’ve just changed the permissions as you advised, but still having the same TFTP open error?

    Error.png


  • Senior Developer

    Check your permissions on the /tftpboot folder.

    They seem to work best set as:

    chown -R fog:{webuser e.g. www-data for debian insts, apache for red hat insts)
    chmod -R 667 /tftpboot
    


  • So changing option 67 to now read undionly.kpxe and then trying to initialise a network boot still returns the same TFTP open timeout, any other possbile suggestions?

    Also I have been through the forums and noted people are saying to:

    sudo service tftpd-hpa start
    sudo service tftpd-hpa stop

    Doesn’t seem to make any difference for me.


  • Senior Developer

    Yep,

    The installer for 1.x.x tells you to use option 67 with undionly.kpxe


  • Developer

    if you are running fog 1.0+ the bootfile name is now undionly.kpxe
    that is why it is important to pay attention to the instructions in the installer



  • Just a thought, see the screenshot, shouldn’t there be a ‘pxelinux.0’ file? I only have ‘pxelinux.0.old’ by the looks of it?

    Error.png



  • @Junkhacker, post: 31181, member: 21583 said:

    did you configure your dhcp options 66 and 67?

    Thanks for the reply, I had completely forgot to do that, and when I did the DHCP problem is now resolved and it finds an IP at boot.

    Only now I get this error:

    PXE-E32: TFTP open timeout
    PXE-M0F: Exiting Intel Boot Agent.
    Selected boot device failde. Press any key to reboot the system.

    DHCP Option 066 = 192.168.254.125 (IP Address of the fog server)
    DHCP Option 067 = pxelinux.0

    Am I missing something?



  • This post is deleted!


  • This post is deleted!

  • Developer

    did you configure your dhcp options 66 and 67?


Log in to reply
 

494
Online

38926
Users

10692
Topics

101460
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.