Clone error



  • Hello

    I migrate from fog 0.32 to fog 1.1.1
    I want to clone a dell 780 witch was working on 0.32, but yets with new version I have an upload error
    [CODE]Starting to clone device (/dev/sda1) to image (/tmp/pigz1)
    Clone: open /dev/sda1 error[/CODE]

    I tried to change the option to partimage on Image Manager but it’s always partclone that lauch with error

    What can I do to solve it ?

    Thanks



  • This post is deleted!


  • I know but i still can’t backup a Windows 7 without the 100mb system partition (at the 63th sector or even at the 2048) if it’s declared as Windows 7 on image settings.

    I think FOG or maybe Partclone handle image like if the partition was always make as default of the OS on it (XP will always require to be at the 63s and Windows 7 always need to be at the 2048 with a 100mb system partition) but it’s not the case all the time.


  • Senior Developer

    The windows 7 default “best aligned” partition start sector should always be 2048.



  • I going to run few test.
    First, i use my old Windows 7 without the 100 mb system partition and starting at the 63th sector :
    With Image OS as Windows 7, i got an upload error.
    With Image OS as Windows XP, upload is working.



  • This post is deleted!


  • As there is not reply, I tried on my side to upload using debug but it doesn’t work better this way.
    I use 1949 release.
    After resizing of the partition, it pass directly to the post operation screen with the other resizing.
    There is no sign of partclone at all during the process and fog even let in the dev directory the folder named as the mac address of the computer.
    I have check log but there is nothing in it.



  • Here is a screenshot of that 2048th sector on my fresh install with the 100mb partition.
    First print display in Bytes, second print in sectors.

    [ATTACH]1053[/ATTACH]

    edit : This will help by showing that fog debug load from pxe have parted.

    [url="/_imported_xf_attachments/1/1053_Windows 7 x64 2-2014-06-24-13-30-02.png?:"]Windows 7 x64 2-2014-06-24-13-30-02.png[/url]



  • Maybe i didn’t explained well.
    Windows 7 (and all new OS maybe) use the 2048, not the 63 so, maybe put at 2048 is the solution.

    To try this, you also need to make a backup to keep your system ready for the upload but now also need to get a live CD, USB or even PXE distribution with parted.
    I used Gparted put in FOG pxe menu.

    Boot on it then run “parted” in a terminal then use “print” to display the partition.
    If it display “[SIZE=3]32,3kB” as starting sector, it’s the 63th sector.[/SIZE]
    write “rm #” where you replace # by the number of the partition to remove, in your case it should be 1.
    Then recreate a partition starting at 2048 using the all drive size with the command “mkpart primary ntfs 2048s 100%” and add boot label to with “toggle 1 boot”.
    Check your partition with “print”.
    Reboot and restore data on the new partition.

    If you did well and if i explained well too (haha), you shouldn’t even need to boot windows and break your fogprep.
    But as the first try, maybe it will help to check if windows is well loading then restore again the data that have been fogprep.

    Maybe there is easier way like a using a gparted with an interface but i prefered used command line with easy and clear data to read.



  • Thanks for you experience
    But how can I configure sector 63 and where ?

    Thanks



  • This post is deleted!


  • So you probably have the same problem than the one i had.
    If you don’t want to reinstall everything or maybe try this for nothing, you can make a backup of the current computer with a software (i used Acronis 2014 CD version) then make a “fresh” install with the 100mb partition then restore you the single partition without the MBR on the 2nd partition of the computer.
    I has worked for me.
    Yet, i didn’t tried to upload it because the computer was needed for work so only check if windows was starting well.

    Thinking again of this, i haven’t check if it’s the 100mb partition or the first partition sector that block the upload.
    I haven’t work on partitioning since few months and maybe more than a year.
    If i remember well, i was using the sector 63 for all my image, like XP, instead of 2048 like the usual windows 7 installation.
    Maybe try to this would be helpfull.



  • I have only one partition without the small one



  • You can’t backup anymore with partimage so that’s why it always go back to partclone.
    Do you have the “original” 100mb partition made by Windows during a normal installation ?
    I have been working without these 100mb with partimage and now, it look to be a problem for partclone.
    I think i had the same error when i was trying to upload an image with only one partition.



  • Hi
    I want to create a new image from client to server, so I upload


  • Senior Developer

    Are you trying to upload the image, or download the image from/to the client?



  • Yes I did many times


  • Developer

    did you cancel the task and recreate it after changing the image manager option?


Log in to reply
 

367
Online

38984
Users

10712
Topics

101689
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.