Fog Server installation on Raspberry PI - "fog setting up and starting tftp and pxe server failed"

  • Hello guys!

    Im trying to set up a fog server on a Raspberry PI as a school project.
    I am using Raspbian as operating system.

    The first thing i do is setting up a static ip adress.
    Then I download the newest fog installation package, extract it and install it.
    Im setting up the Raspberry as DHCP-Server, leaving all MYSQL-Passwords blank.

    Everything works fine until one of the last steps: “fog setting up and starting tftp and pxe server…failed”.

    When I try to boot over network, i even get an ip adress from the Raspberry, but then there is no connection to the tftp-server.

    Does anyone have an idea how to fix this problem?


  • Senior Developer

    I’ll see if I can borrow one of our school’s raspberry pi, and see if I can sort this out.

    That said, all I’d be testing is the installer and the services to get started, but I would not recommend using it to actually image systems. This is just my thoughts. The Pi is not a very powerful system. While I’m sure it will do what you want, it wouldn’t necessarily be the “best” method to do a “mobile” solution either.

  • Hello, I am trying to install the fog server 1.2.0 on my Raspberry Pi Model B+
    As I ren in to the same problem as NoCheatz but I did’t manage to solve it.
    I already did what [url][/url] Yet my problem is not solved. I have google but Have’t got a clue how to solve this issue It seems as the script is not running futhure after failing at "fog setting up and starting tftp and pxe server failed’’ it stops the script so. I got raspberry pi b+ install whit debian weezy and haf installed fog server .

    Any suggestions would be helpful.

    Can you provide your installation details?
    Yes, I can
    This is now included as a long file in 1.1.0 in location /var/log/foginstall.log

    Have you checked your apache error logs?
    No, I have not
    Can you provide information from these logs?
    Yes I can.

    Have you searched the forums for your issue yet?
    Yes, I have found just 2 posts on this matter. No solution found
    Have you checked the [URL=‘’]wiki[/URL] yet?
    Yes, I have It tells my alot about how fog works , I have’t found an article regarding my issue.

  • Senior Developer

    You may want to check the /etc/exports file and change the /images and /images/dev to match that of the extra drive. My guess is this is what was happening on your system.

  • Gotcha, not sure why I didn’t think of that.

    I turned up an Raspberry Pi as a fog server for fun here as well. The only issue I noticed when I’ve done a full fog server is even if you change the directory to store images to another disk/partition, it still tries to write to /images/dev for the initial image upload and then transfers it over. How I got around this was a symbolic link from /images/ to go to another partition/drive.

  • Im connecting a small external hard drive (120GB) to the raspberry to store the images.

  • Question for ya, how are you storing the images on the RPi, or is the host device really tiny?

  • Than you very much for this link!
    The Server was installed already, but it waited for a ipv6 adress
    (It is described like this in the tutorial).
    So i added an extra option for ipv4 in the configuration file, and the tftp-server started!
    I will try a backup job tomorrow and tell you if it worked or not.

  • Senior Developer

  • Thank you for your fast answers!

    Im a very beginner at linux (i only can do some basic stuff like extracting files or editing config files),
    so can someone explain me how i can install and configure those components to work with fog?
    Or is there a tutorial somewhere to help me installing those components?


  • Senior Developer

    You may have to install a few components of the FOG system on your own, whether by source or pre-built binaries. I don’t have a Raspberry Pi to try the installer on so I’m sorry I’m not able to be of much help.

  • Developer

    there are a couple of services that do not install correctly using the fog install script on the raspberry pi, they will need to be set up manually. if my memory serves me correctly (and it rarely does, so someone feel free to correct me) those services are the tftp server and the nfs server