TFTP PXE-T01: File Not Found



  • I just did a fresh Ubuntu 12.04 32 bit install and installed FOG 0.32 as well. When I network boot I get the message that the TFTP file is not found. Now if I go to a workstation and do a TFTP get x.x.x.x pxelinux.0 I receive the file. On my DHCP server option 66 is set to the FOG server IP and option 67 is set to pxelinux.0 Any ideas?


  • Senior Developer

    Have you taken a look at the FOG Server to ensure firewalls are disabled?
    In Ubuntu is verified with:

    sudo service ufw disable
    

    In CentOS you need to ALSO disable selinux:

    chkconfig iptables off
    service iptables stop
    sed -i 's/SELINUX=enforcing/SELINUX=disabled/' /etc/sysconfig/selinux
    sed -i 's/SELINUX=enforcing/SELINUX=disabled/' /etc/selinux/config
    reboot
    

    Have you verified that the permissions of the /tftpboot directory are correct? They should be set to:

    chown -R fog:root /tftpboot
    


  • Sorry for the million posts but I got it figured out it was like the Windows Server wasn’t saving my changes I closed out DHCP options for the millionth time and when I went back in it had old settings I changed those yet again and bam! It worked!!!



  • I hate to beg but come on guys don’t leave me hanging. Ever since I update from 0.32 I’ve had nothing but problems and now I’m just trying to go back to how it was but I can’t get it to work. It seems like it is not a FOG issue but more the Windows Server is not telling them to get that file because like I’ve said I can do it from a command line no problem at all. I’ve even restarted my DHCP server.



  • It’s weird when you watch it, it is almost like it doesn’t even try to grab a file it just instantly pops up saying that the file could not be found.



  • Stop and restarted the tftpd-hpa service just to be sure and still getting the same message. It’s weird like I said I can go on a command line and grab the file no problem.


  • Developer

    check that the tftp service is running, Ubuntu 12.04 has a known issue with this



  • @jdorst, post: 30951, member: 814 said:

    You only need to change to undionly.kpxe if you are using 1.x.x.

    Also, have you tried restarting the DHCP service on the DHCP server?

    No good on restarting DHCP server service on the DHCP server. Still giving the same error message.



  • @Mike M, post: 30949, member: 24694 said:

    Try changing pxelinux.0 to undionly.kpye

    You only need to change to undionly.kpxe if you are using 1.x.x.

    Also, have you tried restarting the DHCP service on the DHCP server?



  • Try changing pxelinux.0 to undionly.kpye


Log in to reply
 

334
Online

38729
Users

10555
Topics

99925
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.