TFTP boot fails - "the selected boot device failed" - after upgrading to FOG 1.1



  • Running Ubuntu 13.10. Upgraded from a FOG beta to 1.1. When I go to boot a laptop from the FOG server, I get:

    “TFTP.
    PXE-M0F: Exiting Intel Boot Agent
    Selected Boot Device Failed.”

    I was able to tftp into the server and get undionly.pxe. Verified the username/password are correct under the FOG System Settings > FOG Settings > TFTP Server.



  • Sorry, I didn’t mean to drop a second thread into this question on the “TFTP boot fails”. I thought they were related but I see now this is a different question entirely. When you boot do you get something like this;

    [CODE]
    Interl® Boot Agent GE v1.3.66
    Copyright © 1997-2010, Intel Corp

    Client MAC Addr: F0 DE F1 99 72 C6 GUID: 81F1D9AE AA51 CD11 B3A0 8E5CCB381DF1
    Client IP: 172.18.68.24 MASK: 255.255.252.0 DHCP IP: 10.20.1.10
    GATEWAY IP: 172.18.68.1
    TFTP
    PXE-M0F: Exiting Intel Boot Agent
    [/CODE]

    If so, what do the Client IP: MASK: and DHCP IP: say? It might be the DHCP server is out in the wrong domain or something like that.


  • Testers

    That looks consistent with what I see in mine (I added a test kernel called bzImage-test)

    [CODE]
    $ cd /var/www/html/fog/service/ipxe
    $ ls -lhrt
    -rw-r–r--. 1 fog apache 230K Jun 17 14:37 grub.exe
    -rw-r–r--. 1 fog apache 25K Jun 17 14:37 memdisk
    -rw-r–r--. 1 fog apache 5.9M Jun 17 14:37 bzImage
    -rw-r–r--. 1 fog apache 756 Jun 17 14:37 boot.php
    -rw-r–r--. 1 fog apache 44K Jun 17 14:37 bg.png
    -rw-r–r--. 1 fog apache 10M Jun 17 14:37 init.xz
    -rw-r–r--. 1 fog apache 9.1M Jun 17 14:37 init_32.xz
    -rw-r–r--. 1 fog apache 5.9M Jun 17 14:37 bzImage32
    -rw-r–r--. 1 fog apache 1.8M Jun 17 14:37 memtest.bin
    -rw-r–r--. 1 fog apache 503 Jun 17 14:37 advanced.php
    drwxr-xr-x. 2 fog fog 4.0K Jun 19 13:56 backup

    -rw-r–r--. 1 fog fog 5.9M Jun 19 13:56 bzImage-test
    [/CODE]

    Assuming the permissions on the ipxe directory are OK and that you’re not running selinux my guess would be something to do with the web frontend. You might find something in the apache logs.



  • [quote=“ianabc, post: 30865, member: 24548”]Hi Jackley, Toms response was to Chuck Sites above, there was too much going on in this thread :). Do you see anything in the ipxe directory (e.g. /var/www/html/fog/service/ipxe - you might have a slightly different web root). The Add Kernel function should drop the file you are uploading in there I think.[/quote]

    There is a bzImage there, but it’s from 9:17 AM today. I just tried to install a new kernel, it doesn’t appear to be updating. Below is the stat output for bzImage:

    [CODE]/var/www/fog/service/ipxe$ stat bzImage
    File: ‘bzImage’
    Size: 6090592 Blocks: 11896 IO Block: 4096 regular file
    Device: 801h/2049d Inode: 786936 Links: 1
    Access: (0644/-rw-r–r--) Uid: ( 1000/ fog) Gid: ( 33/www-data)
    Access: 2014-06-19 09:14:09.555283765 -0400
    Modify: 2014-06-19 09:14:09.611283767 -0400
    Change: 2014-06-19 09:14:27.151284163 -0400
    Birth: -
    [/CODE]



  • Problem solved. It was in the PXE Menu. This worked for me; Fog Configuration > PXE Boot Menu > Exit to Hard Drive Type > GRUB Style. It was set on Sansboot Style (default), and Exit Syle did the same ‘PRESS A KEY TO REBOOT’. Should ‘GRUB style’ be default I wonder?


  • Testers

    Hi Jackley, Toms response was to Chuck Sites above, there was too much going on in this thread :). Do you see anything in the ipxe directory (e.g. /var/www/html/fog/service/ipxe - you might have a slightly different web root). The Add Kernel function should drop the file you are uploading in there I think.



  • [quote=“Tom Elliott, post: 30860, member: 7271”]This sounds like it’s not exiting to the HD properly. Perchance, is your SATA Controller setup for IDE, AHCI, or RAID? I’ve heard reports (other’s please confirm if you can) that the Controller type can play into the “exit” mode options and use.[/quote]

    I believe I got this to work by updating the DHCP, thanks all. Now I’m having a new issue.

    When I go to install a new kernel, the progress hangs at “Starting Process…” with a spinning gear.


  • Senior Developer

    [quote=“Chuck Sites, post: 30799, member: 22709”]I’m having a very similar problem. PXE works, and I get to the PXE menu, but when I select ‘Boot from hard drive’, It clears the screen and prints “PRESS A KEY TO REBOOT”. Pressing any key reboots.

    It’s not a corrupt OS either. If I take the bios route (on a dell; F2-setup and F12 boot device), and select F12 and say boot from HD,
    it boots right into windows. This is new and looks like a bug in the ipxe menu.[/quote]

    This sounds like it’s not exiting to the HD properly. Perchance, is your SATA Controller setup for IDE, AHCI, or RAID? I’ve heard reports (other’s please confirm if you can) that the Controller type can play into the “exit” mode options and use.


  • Testers

    [quote=“Chuck Sites, post: 30799, member: 22709”]when I select ‘Boot from hard drive’, It clears the screen and prints “PRESS A KEY TO REBOOT”. Pressing any key reboots.[/quote]

    It sounds like you might have a different problem to the other posts in this thread, your DHCP is working if you are getting the FOG boot menu. You might try adjusting the “[FONT=Ubuntu][COLOR=#555555]Exit to Hard Drive Type”[/COLOR][/FONT] in the PXE Boot menu.



  • Depending on if you have a Windows DHCP or Linux DHCP server matters where you’d look, of course.

    [url]http://www.fogproject.org/wiki/index.php/Windows_DHCP_Server[/url]

    [url]http://www.fogproject.org/wiki/index.php/Linux_DHCP_Server[/url]

    If you don’t have the options set to send the server to fog and to get the file, it won’t load the ipxe boot and fog.



  • [quote=“Fhajad, post: 30800, member: 24675”]Do you have your DHCP server options set correctly?[/quote]

    Where can I verify these settings?



  • Where can I find the dhcp sever settings?



  • Do you have your DHCP server options set correctly?



  • I’m having a very similar problem. PXE works, and I get to the PXE menu, but when I select ‘Boot from hard drive’, It clears the screen and prints “PRESS A KEY TO REBOOT”. Pressing any key reboots.

    It’s not a corrupt OS either. If I take the bios route (on a dell; F2-setup and F12 boot device), and select F12 and say boot from HD,
    it boots right into windows. This is new and looks like a bug in the ipxe menu.



  • What should be under [FONT=Ubuntu][COLOR=#555555]FOG_PXE_IMAGE_DNSADDRESS, if anything? That field is blank. [/COLOR][/FONT]


Log in to reply
 

495
Online

39211
Users

10858
Topics

103356
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.