Udpcast...Failed! Fog upgrade 0.34 to 1.1.1



  • Hi

    I’m running Ubuntu 12 with the latest security updates.
    I’m upgrading from fog 0.34 to 1.1.1 but the updates stops with the following error.

    • Setting up and starting TFTP and PXE Servers…OK
    • Setting up and starting VSFTP Server…OK
    • Setting up sudo settings…OK
    • Setting up FOG Snapins…OK
    • Setting up and building UDPCast…Failed!

    ./configure failed!

    Script done, file is /var/log/foginstall.log

    I already tried to edit the config.sh and functions.sh according to this thread, but it didn’t work.
    [url]http://fogproject.org/forum/threads/setting-up-and-building-udpcast-failed.10798/[/url]

    When i have a loot at /root there is udpcast

    drwxr-xr-x 4 user user 4096 Jun 19 15:11 udpcast-20120424
    -rw-r–r-- 1 root root 189526 Jun 19 15:11 udpcast.tar.gz

    Any help would be appreciated. Thanks.



  • thanks for your hints. finaly i could fix the problem, i had to reinstall libc6-dev

    [FONT=Verdana][COLOR=#000000]apt-get install --reinstall libc6-dev[/COLOR][/FONT]



  • ./configure returns the following error:

    root@fog:/tmp/udpcast-20120424# ./configure
    checking for gcc… gcc
    checking whether the C compiler works… yes
    checking for C compiler default output file name… a.out
    checking for suffix of executables…
    checking whether we are cross compiling… configure: error: in /tmp/udpcast-20120424': configure: error: cannot run C compiled programs. If you meant to cross compile, use–host’.
    See `config.log’ for more details.

    i’m running ubuntu in a virtual maschine on citrix xen with virtual kernel 3.2.0-64-virtual
    i tried googling for the error but didn’t succeed.


  • Testers

    Hi MarkusK, on my system the fog install script puts udpcast into /tmp and builds in there. You could try doing this manually, it might give you a better idea of the problem from, e.g.

    [CODE]
    cd /tmp/udpcast-20120424
    make distclean
    ./configure
    make
    [/CODE]

    From what you said above it sounds like somewhere in ./configure you will see an error, that will give you a better idea of what is missing or wrong.



  • and i even tried root login and install. Same error.



  • i tried with sudo ./installfog.sh
    and sudo -s


  • Senior Developer

    Are you running with sudo or just running the installfog.sh acripts.


Log in to reply
 

362
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.