Winload.exe missing or corrupt



  • Hi All,
    Ive run through the following steps while preparing/rolling out a Windows 7 Enterprise image 32-bit.

    1. Install Win 7 on VM workstation (2 partitions, system reserved and C: drive)
    2. Enter Audit Mode
    3. Install updates + applications
    4. Configure administrator profile ready for sysprep/default user
    5. Sysprep with xml
    6. Boot to winpe + use dism to add drivers
    7. Upload image to fog
    8. Deploy to workstation.

    At step 8, the physical workstation wont boot up and gives the error winload.exe missing or corrupt. The VM workstation boots up as normal, runs through the setup process and gets back to the login screen.

    Ive tried all manner of settings and combinations on Fog 0.32.
    Single partition resizable / Multiple Partitions single disk with expand OS partition specificed in sysprep xml
    Used with fogprep and without before sysprepping
    Removing the “??” entries under MountedDevices in the registry before sysprepping
    Tried with and without the BCDEDIT options
    All as specified here:
    [url]http://www.fogproject.org/wiki/index.php?title=Create_a_windows_7_image_for_many_different_hardware[/url]
    [url]http://www.fogproject.org/wiki/index.php?title=What_do_I_have_to_do_to_an_image_before_uploading%3F[/url]

    I cannot for the life of me figure out what is causing the problem - I realise its re-assigning the system reserved partition to C: and actual windows contents to D: upon booting the imaged PC but how can I stop it doing this and mount them correctly? (system reserved should have no drive letter and D: should become C: )

    Has anyone gone through this process with 2 partitions, had this problem and then resolved it? Am I doing something in the wrong order? Does DISM need to be ran before sysprep?

    Help!
    Thanks



  • I took the WD harddisk from one of the GX745’s that worked, put it in the GX755 that has the issue, then reimaged with the same image, works fine; I then took the Seagate harddisk that was originally in the GX755 and put it in the GX745 and tried to reimage, and it works as well…go figure, am totally confused as to why FOG images the Seagate fine in the GX745, but not in the GX755…



  • repair didn’t work, chkdsk didn’t work,
    but I have noticed that during the imaging of the second partition, it cuts off at 20-21 % (it varies)… which probably means that not all data was restored from the image,



  • Hi,
    I have the same issue just today, also a multiple partition single disk setup, with 100MB for the Windows 7 diagnostic partition, 25GB for the OS (the actual C: drive) and the rest on a third partition (the D: drive) , this only seems to happen on a Dell GX 755 (bios A19); the same image works fine on all my other GX models (380, 760, 745, 520, 620…),
    running the W7 repair doesn’t work, am now running a chkdsk and it seems to be deleting a lot of stuff…


Log in to reply
 

423
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.