Multicast on Cisco switch



  • I’m having trouble getting multicast across vlans to work on our cisco network. I know this is more of a cisco question but thought I’d start here.

    When I set up a multicast session to machines on the same vlan as the fog server, I get speeds above 3GB/Min. On any other vlan the speed drops to ~5MB/Min

    I did search the forum and found this post: http://fogproject.org/forum/threads/multicast-does-not-work-to-multiple-clients-only-to-single-client.863/#post-4316
    I’ve tried changing the multicast address to the 239.x.x.x but it did not make a difference.

    ip multicast-routing is turned on
    the vlans have ip pim sparse-dense-mode enabled

    Anyone have any suggestions?



  • Hey Mark,
    The only QoS policies we have in place are for VoIP phones so I don’t think that should have any effect.

    I’m actually doing my testing on the core. I noticed the issue offsite in another building and then came back to the office to test at the source. Yep - the server and clients are both on the core switch. This switch does the routing between vlans. As soon as the clients move out of the server vlan, multicast suffers.

    I might have to look into the Iperf tests - it sounds like a neat tool. All other traffic seems okay though - I can copy files from PCs around the network and still get gigabit speeds.

    Thanks for the thoughts! At this point the issue is only slowing me down a little bit - we’re just unicasting everything at the moment so it’s not a major problem, just something I’d like to try to fix.

    Edit: forgot the IOS version, it is 12.2(17r)S4



  • Ben, do you have any QoS policies that might impact the performance?

    one think i’d check is to make sure is to make sure its working at the core and branch out. are you cloning to another port on the 6513? whats the IOS revision by chance? are your clients on that same switch as the multicast server?

    IGMP Snooping will make no bearing on this, that is only for rouge DHCP servers :)

    i use sparse mode, not dense at work, however, that does not make any difference other than the way multicast forms its structure.

    we also use
    ip pim autorp listener, which bridges protocols in routing mode, but should not affect your issue.

    one thing you can try is doing Iperf tests, you cant do multicasting from it, but its a start! good luck, multicast can be a pain to diagnose!


  • Developer

    Look into other settings that you may have enabled, Other than initial switch set up, these are the only options I changed… In my environment. I don’t pretend or claim to be a cisco guru by any means. Hell, I accidentally got the things to work. When I find the document I used to set up my switches I will share it so you can compare the settings you have enabled against mine, I set my switches up with CLI and used CNA to make adjustments.



  • We manage our switches directly through the CLI and I don’t have the CNA program to look at. Portfast is enabled on all the access ports and IGMP Snooping is enabled globally.


  • Developer

    I used the Cisco CNA program to manage my switches, I would take a look at the following settings, this is how I was able to accomplish mulitcast, please note, the switches I used were Catalyst 2960. I also prefer to unicast over multicast.

    Log into your managed switch with the administrative username and password.

    Click Configure on the left hand side. Choose Port Settings from the list.

    Select all ports to be used for PXE boot. Click Modify. Enable Port Fast. Save. Close open windows.

    With Configure still selected, choose IGMP Snooping. Click the “Multicast Router Ports” tab.

    Click Create, enter the number of the vlan you wish to apply changes to, select all ports to enable multicast on (Select All click Add) click the apply button, settings may take a few minutes to take affect.



  • It is a Catalyst 6513


  • Developer

    http://fogproject.org/forum/threads/multicast-does-not-work-to-multiple-clients-only-to-single-client.863/#post-4316
    I’ve tried changing the multicast address to the 239.x.x.x but it did not make a difference.

    ip multicast-routing is turned on
    the vlans have ip pim sparse-dense-mode enabled

    Anyone have any suggestions?[/quote]

    What switch model is this? Catalyst? 2560?


Log in to reply
 

486
Online

38926
Users

10692
Topics

101460
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.