Client not booting



  • Hi All
    I have install Fog 1.1.0 on Ubuntu desktop 14 and the install went well and I was able to log in.

    I run ISC-DHCP on FreeBSD and set the following options in DHCPD.CONF according to what I read

    host tfptclient {
    hardware ethernet 00:24:43:C3:A4:DC;
    next-server 192.168.0.19;
    fixed-address 192.168.0.210;
    }

    I also set option bootfile-name “pxeboot.0”; in the Global section.
    and restarted the service.

    However, the client will not boot. It’s a Dell GX 280 by the way. On the client screen I see No entry found in database for device.

    Any ideas on what’s causing this?

    Thanks for any help.


  • Testers

    It sounds like the problem is with the DHCP service rather than Fog. Your Fog install could be fine, but if there is a problem with DHCP your clients won’t even try to talk to fog.

    One thing to try might be sniffing out some of the DHCP traffic on your network to confirm that it looks it should. Wireshark should help there. My hunch from what you say above is that your Citrix setup might have a DHCP service somewhere which is handing out DHCP leases in competition with your FreeBSD box. If that is the case, and your client gets it’s lease from that other DHCP server then it wont work.



  • I checked and the Citrix Servers are not running the Citrix PVS PXE service.



  • I am attaching the fog install file just in case you may notice something I don’t.


  • Senior Developer



  • I have corrected the filename to undionly.kpxe but I am still getting the same error: "No entry found in database for device"
    Yes I have checked the wiki and google but only saw where some else asked the same thing but didn’t see a response. Link Below.

    [url]http://fogproject.org/forum/threads/pxe-booting-no-entry-found-in-database-for-device.4019/[/url]

    As you suggested, I checked the fog install logs and the install completed without error. The apache logs error.log showed no errors either.
    As I mentioned above, I have install Fog 1.1.0 on Ubuntu desktop 14. Actually I have now upgraded it to 1.1.1


  • Senior Developer

    I don’t know what’s wrong, or if this is fixed now, but just correction to pxeboot.0. pxelinux.0 was the usual boot filename. At least for 0.32 and below. In 1.x.x its recommended to use undionly.kpxe.


  • Testers

    Oops, there shouldn’t be a colon at filename
    [CODE]host tfptclient {
    hardware ethernet 00:24:43:C3:A4:DC;
    next-server 192.168.0.19;
    filename “undionly.kpxe”;
    fixed-address 192.168.0.210;
    }[/CODE]


  • Testers

    How far PXE boot does it get?, do you see the iPXE stuff? Also, I think the filename you need in option 67 is “undionly.kpxe” not “pxeboot.0”. Fog 0.32 used “pxeboot.0” but I don’t think fog > 1.0 does so your stanza might look like

    [CODE]
    host tfptclient {
    hardware ethernet 00:24:43:C3:A4:DC;
    next-server 192.168.0.19;
    filename: “undionly.kpxe”;
    fixed-address 192.168.0.210;
    }
    [/CODE]

    I got caught out by the name change as well.


Log in to reply
 

383
Online

38979
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.