Tftp Pxe Problem after upgrade form 0.32 to 1.1.0



  • Hi,
    I’m having a problem since my upgrade to 1.1.0. I’m actully on ubuntu server 14.04 but I had the same thing with 12.04.

    [ATTACH]982[/ATTACH]

    Here is the result for /fof/service/ipxe/boot.php :

    #!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    colour --rgb 0xff6600 2
    cpair --foreground 7 --background 2 2
    console --picture [url]http://10.6.2.102/fog/service/ipxe/bg.png[/url] --left 100 --right 80
    :MENU
    menu
    colour --rgb 0xff0000 0
    cpair --foreground 0 3
    item --gap Host is NOT registered!
    item --gap – -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    item fog.sysinfo Client System Information (Compatibility)
    choose --default fog.local --timeout 60000 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    :fog.memtest
    kernel memdisk iso raw
    initrd memtest.bin
    boot || goto MENU
    :fog.reginput
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=10.6.0.12 keymap= web=10.6.2.102/fog/ consoleblank=0 loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=10.6.0.12 keymap= web=10.6.2.102/fog/ consoleblank=0 loglevel=4 mode=autoreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.sysinfo
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=10.6.0.12 keymap= web=10.6.2.102/fog/ consoleblank=0 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    autoboot

    I’ve double check for the 066 and 067, everything seems to be ok.

    Can you help me please!

    [url="/_imported_xf_attachments/0/982_IMG_20140612_083144.jpg?:"]IMG_20140612_083144.jpg[/url]


  • Senior Developer

    clear your browser cache



  • found my problem, not I see the FOG Menu!!!
    It was a static entry we had that we had forget to change.

    In the fog webUI, I am not able to search for my host that I already have.
    I can list them all but not search for one specific. It’s saying :“Error searching, please try again…”

    Any idea?


  • Senior Developer

    What is your option 67 set to?

    It should be [b]undionly.kpxe[/b]


Log in to reply
 

365
Online

38982
Users

10712
Topics

101679
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.