/bin/fog.download error 409 too many arguments



  • I have an image I uploaded a few weeks ago with FOG version 0.32. I upgraded to version 1.1.0 today and attempted to download it onto one of my devices. The device boots up, runs through its process, then gives the statement:

    /bin/fog.download error 409 too many arguments.

    It only gives me about a half-second (if that) to see the error before it reboots. There doesn’t seem to be a file named /bin/fog.download on my server, so my guess is that it is a file in the bzImage. This error prevents me from downloading any image to a computer. I haven’t tried to see if it prevents me from uploading an image.

    Again, it worked for the prior version, but not for this version, so it could also be in my settings somewhere. Can I ask for assistance in getting my image to download?



  • I had tried 3.14.2 earlier, and it wasn’t working.

    I then switched to 3.14.5, and it didn’t work either.

    I switched back to 3.14.2, and it started working. (Perhaps only with the “Legacy” switch set to on)


  • Developer

    [quote=“rigelan, post: 29431, member: 24517”]I restarted the server, changed the client kernel, and it suddenly started working. So I guess I don’t need anything more. thanks.[/quote]

    Which kernel did you choose?



  • I restarted the server, changed the client kernel, and it suddenly started working. So I guess I don’t need anything more. thanks.



  • I did reset the task and the client computer, I just didn’t mention it in the prior message. I did it again just to be sure - there seems to be no change.


  • Senior Developer

    Reboot the client system when you create a new tasking otherwise it won’t know about the legacy stuff.

    So recreate the tasking, reboot the client machine.



  • Variable dump

    [url="/_imported_xf_attachments/0/911_P060514_1313.jpg?:"]P060514_1313.jpg[/url]



  • Clearing the cache helps. :-)

    I checked the FOG LEGACY FLAG IN GUI

    I made sure all settings for the image were correct.

    I entered ‘fog’ in the debug, and there appears to be no change. It goes through the process just like the screenshot before.


  • Senior Developer

    Is this a windows 7 or Windows Vista Image?

    My guess as to the “links” not functioning properly is your browser cache needs to be cleaned out.

    After cache is cleaned out of that browser (or use a different browser) login to the FOG Web GUI.

    Navigate to FOG Configuration (? icon) -> FOG Settings -> General Settings and check the check box for FOG_LEGACY_FLAG_IN_GUI and save the information.

    Then go to Image Management Page, list or search for the “VistaBusiness” Image as depicted above.

    Make sure it’s got the same settings as your original image (e.g. Multipart or Single Disk) Set the OS of the image to Vista (I’m guessing) Then set the “Imaging Type” to Partimage.

    Then try redeploying the task.



  • Bigger image

    [url="/_imported_xf_attachments/0/909_P060514_1251.jpg?:"]P060514_1251.jpg[/url]



  • I was unable to get to it through the method you mentioned. For some reason the links on the left side under the “host menu” were not functioning properly. Instead I got to it through the task management interface.

    It didn’t use the error 409 this time. I wonder what the difference is?

    It basically just went through the checkup system, tried to download the image, after it had failed to download the image, assumed it was successful and then moved on.

    [url="/_imported_xf_attachments/0/908_P060514_1236.jpg?:"]P060514_1236.jpg[/url]


  • Senior Developer

    Can you give us a screen shot of the error?

    You can start the “download” task again under debug.

    Go to Host Management Page. List or search for your host.

    Click on your host as if you were going to edit it.

    Choose Basic Tasks.

    Choose Advanced Options.

    Scroll down and select “Download - Debug”

    Submit the task.

    Boot your system.

    Once at the Terminal window type:
    [code]fog[/code]

    Your system should fail, but it will not reboot the system on you.


Log in to reply
 

398
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.