Could not start: download operation not supported"



  • [I][SIZE=12px]hi i´m getting the error “could not start: download operation not supported” but this only happens in one domain, in the others we have the same server with no problems,the switches are equals on both domains(cisco), can anybody help me please?[/SIZE][/I]
    [I][SIZE=12px]best regards[/SIZE][/I]

    [I][SIZE=12px]Bruno[/SIZE][/I]

    [url="/_imported_xf_attachments/0/907_fog.png?:"]fog.png[/url]


  • Senior Developer

    If you’re running FOG 0.32, why are you trying to point at undionly files?



  • Ubuntu 12.04.4
    Fog .32
    as far as the logs go I’m pretty new to Linux, how do I open the log file, I see it is there along with about 15 other error logs.

    The error i’m getting is "could not start download: operation not supported [url]http://ipxe.org/3c092003[/url]

    If I pause the system periodically it will work. I tried some of the updates from other posts, but have not seemed to help the situation.


  • Senior Developer

    [quote=“David Schneider, post: 35666, member: 23828”]Has there been a resolution to this at all? I am currently having the issue, I had no issues with these laptops previously HP 840 laptops. The problem started intermittently, now I can’t really get any of them to work.[/quote]

    I guess I don’t understand what issue you’re having. You’re systems aren’t booting to the FOG Menu? Are you getting any error messages that we may be able to work with from the ipxe screen?



  • Has there been a resolution to this at all? I am currently having the issue, I had no issues with these laptops previously HP 840 laptops. The problem started intermittently, now I can’t really get any of them to work.



  • I was able to make it work again back re installing Fog. Now the problem I’m getting is that after it boots from the network, it seems as everything goes fine until it gets to [[I]configuring (net0 70:5a:…[/I].)].
    After that it reboots without going into the fog menu.

    I’m trying to register and image an Acer Aspire One 532h with Atheros NIC. Previously I was able to image these laptops before upgrading Fog from 0.32 to 1.2.0.

    Thanks

    New Error Log

    [Mon Jul 28 12:53:18 2014] [notice] Apache/2.2.17 (Unix) DAV/2 PHP/5.3.8 configured – resuming normal operations
    [Mon Jul 28 12:54:43 2014] [error] [client 10.##.0.###] File does not exist: /var/www/html/fog/management/css/images/ui-bg_flat_75_ffffff_40x100.png, referer: [url]http://10.##.0.###/fog/management/index.php?node=about&sub=settings[/url]
    [Mon Jul 28 12:54:43 2014] [error] [client 10.##.0.###] File does not exist: /var/www/html/fog/management/css/images/ui-bg_glass_75_e6e6e6_1x400.png, referer: [url]http://10.##.0.###/fog/management/index.php?node=about&sub=settings[/url]
    [Mon Jul 28 12:54:43 2014] [error] [client 10.##.#.##] File does not exist: /var/www/html/fog/management/css/images/ui-bg_highlight-soft_75_cccccc_1x100.png, referer: [url]http://10.##.0.###/fog/management/index.php?node=about&sub=settings[/url]
    [Mon Jul 28 13:13:37 2014] [error] [client 10.##.0.##] PHP Warning: array_filter() expects parameter 1 to be array, null given in /var/www/html/fog/lib/pages/GroupManagementPage.class.php on line 252, referer: [url]http://10.##.0.###/fog/management/index.php?node=group&sub=list[/url]
    [Mon Jul 28 13:16:54 2014] [error] [client 10.##.0.##] File does not exist: /var/www/html/favicon.ico
    [Mon Jul 28 13:17:05 2014] [error] [client 10.##.0.##] File does not exist: /var/www/html/fog/management/css/images/ui-bg_flat_75_ffffff_40x100.png, referer: [url]http://10.##.0.###/fog/management/index.php?node=about&sub=settings[/url]
    [Mon Jul 28 13:17:05 2014] [error] [client 10.##.0.###] File does not exist: /var/www/html/fog/management/css/images/ui-bg_glass_75_e6e6e6_1x400.png, referer: [url]http://10.##.0.###/fog/management/index.php?node=about&sub=settings[/url]
    [Mon Jul 28 13:17:05 2014] [error] [client 10.##.0.###] File does not exist: /var/www/html/fog/management/css/images/ui-bg_highlight-soft_75_cccccc_1x100.png, referer: [url]http://10.##.0.###/fog/management/index.php?node=about&sub=settings[/url]
    [Mon Jul 28 13:23:31 2014] [error] [client 10.##.0.###] File does not exist: /var/www/html/fog/management/css/images/ui-bg_glass_75_dadada_1x400.png, referer: [url]http://10.##.0.###/fog/management/index.php?node=about&sub=settings[/url]



  • [quote=“Tom Elliott, post: 34215, member: 7271”]Turn off SELINUX:[/quote]

    Thanks for your prompted response,

    I believe is already disable?

    This file controls the state of SELinux on the system.

    SELINUX= can take one of these three values:

    #enforcing - SELinux security policy is enforced.
    #permissive - SELinux prints warnings instead of enforcing.
    #disabled - SELinux is fully disabled.
    SELINUX=permissive

    SELINUXTYPE= type of policy in use. Possible values are:

    #targeted - Only targeted network daemons are protected.
    #strict - Full SELinux protection.
    SELINUXTYPE=targeted

    Thanks


  • Senior Developer

    Turn off SELINUX:
    [quote][Mon Jul 28 10:55:30 2014] [notice] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0[/quote]



  • Hello,

    Fedora14 - Fog 1.2.0

    After updating undionly.kpxe I’m unable to register or image host. I update the indionly.kpxe because the Acers 532h are not imaging or registering. When I boot from network, DHCP loads but it gets stuck there.

    This is what I’m seeing on the screen

    CLIENT MAC ADDR: #### GUID: ######
    CLIENT IP: #### MASK: #####
    GATEWAY IP: #######

    TFTP seems to not be loading

    Here is the error log:

    [Mon Jul 28 10:54:37 2014] [notice] caught SIGTERM, shutting down
    [Mon Jul 28 10:55:30 2014] [notice] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
    [Mon Jul 28 10:55:30 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Mon Jul 28 10:55:31 2014] [notice] Digest: generating secret for digest authentication …
    [Mon Jul 28 10:55:31 2014] [notice] Digest: done
    [Mon Jul 28 10:55:31 2014] [notice] Apache/2.2.17 (Unix) DAV/2 PHP/5.3.8 configured – resuming normal operations
    [Mon Jul 28 10:55:31 2014] [warn] ./mod_dnssd.c: No services found to register
    [Mon Jul 28 11:11:50 2014] [error] [client 10.##.0.###] File does not exist: /var/www/html/favicon.ico
    [Mon Jul 28 11:13:53 2014] [error] [client 10.##.0.###] File does not exist: /var/www/html/fog/management/css/images/ui-bg_glass_75_e6e6e6_1x400.png, referer: [url]http://10.##.0.###/fog/management/css/jquery-ui.css[/url]
    [Mon Jul 28 11:13:53 2014] [error] [client 10.##.0.###] File does not exist: /var/www/html/fog/management/css/images/ui-bg_flat_75_ffffff_40x100.png, referer: [url]http://10.##.0.###/fog/management/css/jquery-ui.css[/url]
    [Mon Jul 28 11:13:53 2014] [error] [client 10.##.0.###] File does not exist: /var/www/html/fog/management/css/images/ui-bg_highlight-soft_75_cccccc_1x100.png, referer: [url]http://10.##.0.###/fog/management/css/jquery-ui.css[/url]
    [Mon Jul 28 11:24:00 2014] [error] [client 10.##.1.24] File does not exist: /var/www/html/fog/management/css/images/ui-bg_flat_75_ffffff_40x100.png, referer: [url]http://10.##.0.###/fog/management/index.php?node=about&sub=settings[/url]
    [Mon Jul 28 11:24:00 2014] [error] [client 10.##.#.##] File does not exist: /var/www/html/fog/management/css/images/ui-bg_glass_75_e6e6e6_1x400.png, referer: [url]http://10.##.0.110/fog/management/index.php?node=about&sub=settings[/url]
    [Mon Jul 28 11:24:00 2014] [error] [client 10.##.#.##] File does not exist: /var/www/html/fog/management/css/images/ui-bg_highlight-soft_75_cccccc_1x100.png, referer: [url]http://10.##.0.###/fog/management/index.php?node=about&sub=settings[/url]

    Thanks



  • Do you have another server/box, who deliver DHCP other than your Fog server ? i have the problem, stop the other one, and work fine now.



  • hi,
    i upgraded as you told me but still the same error.

    best regards



  • For the difference between the picture and the text in red ,is because I copied the text from another threat, the picture is my fog server.

    Best regards



  • Hi,
    Thanks for your fast response, now I can only test it tomorrow,I will keep you updated.

    Congrats for your work.

    Best regards


  • Senior Developer

    How is the picture on a different version of iPXE than the “output” you’ve bolded in all red?


  • Senior Developer

    [quote=“bveiga, post: 29389, member: 24091”]hi,i can only boot to pie menu with this solution:
    [SIZE=4][COLOR=#ff0000]f I pause at the point where it shows:[/COLOR][/SIZE][B][SIZE=4][COLOR=#ff0000] iPXE 1.0.0+(d28b) – Open Source Network Boot Firmware – Features: NFS HTTP HTTPS iSCSI DNS TFTP AoE bzImage ELF NBOOT PXE PXEXT Menu Configuring (net0 [I]my MAC address[/I])… [/COLOR][/SIZE][/B][SIZE=4][COLOR=#ff0000]then escape; I see the ‘FOG PXE menu’ as expected…[/COLOR][/SIZE]

    [B]the same server on another domain works ok, could this be some kind of timeout that i can extend to more time?[/B]

    [B]best regards[/B][/quote]

    Update your ipxe files to a more recent version please:

    [code]wget -O /tftpboot/undionly.kpxe https://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp/undionly.kpxe[/code]



  • and there is no problem with the firewalls.

    best regards and tanx for any help.

    bruno



  • hi,i can only boot to pie menu with this solution:
    [SIZE=4][COLOR=#ff0000]f I pause at the point where it shows:[/COLOR][/SIZE][B][SIZE=4][COLOR=#ff0000] iPXE 1.0.0+(d28b) – Open Source Network Boot Firmware – Features: NFS HTTP HTTPS iSCSI DNS TFTP AoE bzImage ELF NBOOT PXE PXEXT Menu Configuring (net0 [I]my MAC address[/I])… [/COLOR][/SIZE][/B][SIZE=4][COLOR=#ff0000]then escape; I see the ‘FOG PXE menu’ as expected…[/COLOR][/SIZE]

    [B]the same server on another domain works ok, could this be some kind of timeout that i can extend to more time?[/B]

    [B]best regards[/B]


  • Senior Developer

    Is this “domain” managed by its own firewall and dhcp setup? Is the firewall allowed to communicate with your fog server?


Log in to reply
 

390
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.