PXE issue after fresh install



  • Hi there,

    I’m currently testing FOG on a VMware environment.
    I did a fresh install of Ubuntu Server 12.04 LTS with only OpenSSH Server.
    Then I installed FOG 1.0.1 by following the instructions found on the FOG Project Wiki.
    During the installation, I answered “No” to the DHCP service question because I already have a DHCP server on my network.

    The installation worked fine and I got no error.

    As required, I added the options 66 & 67 on my DHCP Server which is a Lancom router.

    Still, I can’t boot on PXE. I get the following error :

    [QUOTE]TFTP.
    PXE-T04: Illegal TFTP operation
    PXE-E36: Error received from TFTP server
    PXE-M0F: Exiting Intel PXE ROM.[/QUOTE]

    Everything got fine until I tried to boot on PXE so I’m telling me I missed some settings but I can’t find what…

    I really hope you could help me because I’m on the subject since 3 days and it makes me crazy.

    Thanks you :)



  • I have finaly found out what went wrong !

    I don’t know if there is lot of people using Lancom router but here is the solution :

    On Lancom’s router, there is settings for PXE server’s declaration. So no need to set the options 66 & 67.

    Just go onto “IPv4” menu then “BOOTP”. Clic on “Boot images…” button and add your FOG server by typing his IP address et boot file (undionly.kpxe). (example on the attached file)

    After that, you have to add the station and associate it with your FOG server.
    In the same menu as above, clic on “Stations…” and add your computer by typing his MAC address, IP address, station name and PXE server previously declared.

    Thank you again for your help and your time :)

    [url="/_imported_xf_attachments/0/922_ss_fog02.jpg?:"]ss_fog02.jpg[/url]



  • I have some news.

    I installed FOG server with DHCP service included.
    I connected it on an isolated network with another station to test PXE boot.
    And… it works like a charm !

    So I conclude that is the DHCP settings on the router that is not good.

    But I have strictly followed the instructions on the wiki.

    Still investigating… If anyone knows well the Lancom products, I’m interested.

    Anyway, thank you for every leads you gave me. I’ll keep you in touch. :)



  • Hi,
    Here is a screenshot of my VM starting on PXE.
    Same thing with a physical station.

    On my router, following options are declared :
    66 : 10.80.0.26 which is my FOG server IP
    67 : undionly.kpxe

    If the server works fine, I start to think the problem come from my router. But I don’t know why yet.

    I’ll try to reinstall FOG server with DHCP service included and put it on an isolate network to figure it out.

    [url="/_imported_xf_attachments/0/915_ss_fog01.jpg?:"]ss_fog01.jpg[/url]


  • Developer

    [quote=“Vincel, post: 29343, member: 24508”]I checked the ufw and it’s already disabled.

    I just made a try and ping works from my station and the FOG server.
    But I found out that ping from server to my station didn’t work : Windows firewall was active.
    I turned it off then tftp command worked like a charm. I finaly can download undionly.kpxe on my Windows station.
    So that’s problem is solved.

    However, i can’t still boot on PXE… :([/quote]

    Please explain. If you can use the command to get the undionly.kpxe file, there is nothing in the way of retrieving the file. Could you provide a screenshot to better help us understand your issue?



  • I checked the ufw and it’s already disabled.

    I just made a try and ping works from my station and the FOG server.
    But I found out that ping from server to my station didn’t work : Windows firewall was active.
    I turned it off then tftp command worked like a charm. I finaly can download undionly.kpxe on my Windows station.
    So that’s problem is solved.

    However, i can’t still boot on PXE… :(


  • Developer

    [quote=“Vincel, post: 29328, member: 24508”]I’m not sure to understand.
    Where is located the undionly.kkpxe that you tell me to copy ?

    My /tftpboot directory contains these files :
    tftpboot (directory) - boot.txt - ipxe.krn - pxelinux.0.old - vesamenu.c32 - default.ipxe - memdisk - snponly.efi - undionly.kpxe[/quote]

    Discard his information for now and attempt the recommended troubleshooting steps that Tom and I have suggested.

    Solving an Undionly problem will NOT solve your ability to receive the file which is where your current issue exists.

    Thanks for the Add on there Tom I always forget about that firewall because it’s one of the first things I kill.



  • [quote=“Baite, post: 29321, member: 24308”]Well, I got that messages too… tried several of the PXE, KPXE, KKPXE files as my undionly.kpxe file, and I’m happy at the moment with the undionly.kkpxe.
    You need to go to your /tftpboot directory, rename undionly.kpxe to undionly.kpxe.ORIGINAL (or any other name that let’s you know that was the original file). Then, copy undionly.kkpxe to undionly.kpxe (that is, create a new undionly.kpxe equal to the undionly.kkpxe).
    Now try to boot gain.[/quote]

    I’m not sure to understand.
    Where is located the undionly.kkpxe that you tell me to copy ?

    My /tftpboot directory contains these files :
    tftpboot (directory) - boot.txt - ipxe.krn - pxelinux.0.old - vesamenu.c32 - default.ipxe - memdisk - snponly.efi - undionly.kpxe


  • Senior Developer

    [quote=“Jaymes Driver, post: 29326, member: 3582”]I’m interested as to why you can’t get the boot file. What happens if you ping the server?

    While Baite has a good suggestion to try a new undionly file, that won’t help with the reasons why your windows machine can’t grab the undi file.

    I would verify that you can ping the machine from the windows host that you want to grab undionly.kpxe from. It’s good that the command completes on the server, that means the tftp server is working correctly, however there may be switch settings that are preventing you from communicating with the FOG server. If it is possible, grab a small router or something that can serve dhcp and try it on an isolated network (only fog and the test machine) and see if you can grab the undionly.kpxe file.[/quote]

    To add on to Jaymes’ post here, I’d also check that firewall is disabled:
    [code]sudo ufw disable[/code]


  • Developer

    [quote=“Vincel, post: 29310, member: 24508”]Yes option 67 is set to undionly.kpxe.

    I made the following tests :

    • On my Windows workstation :
      tftp x.x.x.x get undionly.kpxe
      I got a timeout

    • On the FOG server :
      tftp -v localhost -c get undionly.kpxe
      Received 96672 bytes in 0.1 seconds…
      Same thing with his IP address instead “localhost”

    I don’t know if it means something but it seems like the tftp doesn’t accept connections from another stations than him.[/quote]

    I’m interested as to why you can’t get the boot file. What happens if you ping the server?

    While Baite has a good suggestion to try a new undionly file, that won’t help with the reasons why your windows machine can’t grab the undi file.

    I would verify that you can ping the machine from the windows host that you want to grab undionly.kpxe from. It’s good that the command completes on the server, that means the tftp server is working correctly, however there may be switch settings that are preventing you from communicating with the FOG server. If it is possible, grab a small router or something that can serve dhcp and try it on an isolated network (only fog and the test machine) and see if you can grab the undionly.kpxe file.



  • Well, I got that messages too… tried several of the PXE, KPXE, KKPXE files as my undionly.kpxe file, and I’m happy at the moment with the undionly.kkpxe.
    You need to go to your /tftpboot directory, rename undionly.kpxe to undionly.kpxe.ORIGINAL (or any other name that let’s you know that was the original file). Then, copy undionly.kkpxe to undionly.kpxe (that is, create a new undionly.kpxe equal to the undionly.kkpxe).
    Now try to boot gain.



  • Yes option 67 is set to undionly.kpxe.

    I made the following tests :

    • On my Windows workstation :
      tftp x.x.x.x get undionly.kpxe
      I got a timeout

    • On the FOG server :
      tftp -v localhost -c get undionly.kpxe
      Received 96672 bytes in 0.1 seconds…
      Same thing with his IP address instead “localhost”

    I don’t know if it means something but it seems like the tftp doesn’t accept connections from another stations than him.


  • Senior Developer

    [quote=“Vincel, post: 29297, member: 24508”]Hi there,

    I’m currently testing FOG on a VMware environment.
    I did a fresh install of Ubuntu Server 12.04 LTS with only OpenSSH Server.
    Then I installed FOG 1.0.1 by following the instructions found on the FOG Project Wiki.
    During the installation, I answered “No” to the DHCP service question because I already have a DHCP server on my network.

    The installation worked fine and I got no error.

    As required, I added the options 66 & 67 on my DHCP Server which is a Lancom router.

    Still, I can’t boot on PXE. I get the following error :

    Everything got fine until I tried to boot on PXE so I’m telling me I missed some settings but I can’t find what…

    I really hope you could help me because I’m on the subject since 3 days and it makes me crazy.

    Thanks you :)[/quote]

    What did you set for “option 67”? It should be set to undionly.kpxe.


Log in to reply
 

393
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.