Tasks do not start after upgrade to 1.0.1



  • Hi

    I upgraded our Fog server to version 1.0.1. PXE boot did not work, I noticed that the tftpboot directory seemed to be missing files. The upgrade process seemed to have created a backup tftpboot.prev directory. So I restored the tftpboot to the prvious state. Now PXE-boot works fine, but tasks are not started. Tested on several computers. I have reverted to version 0.32 until I find a solution. Anyone has an idea?

    Thanks,

    Koen


  • Developer

    [quote=“Koen, post: 29688, member: 4127”]Hi Tom

    Sorry, I overlooked completely that option 67 had to get a different value, my fault.
    May be the install script can emphasize that this has to be changed in case of an update?

    All the best and thanks,

    Koen[/quote]

    It um… it does.

    [code]
    echo " DHCP will NOT be setup but you must setup your";
    echo " current DHCP server to use FOG for PXE services.";
    echo ;
    echo " On a Linux DHCP server you must set:";
    echo " next-server";
    echo ;
    echo " On a Windows DHCP server you must set:";
    echo " option 066 & 067";
    echo;
    echo " Option 066 is the IP of the FOG Server: (e.g. ${ipaddres}";
    echo " Option 067 is the undionly.kpxe file: (e.g. undionly.kpxe)";
    [/code]

    This is a blatant rip from the installfog.sh script that you run to install FOG, for some reason many members fail to read the instructions presented to them.



  • Hi Tom

    Sorry, I overlooked completely that option 67 had to get a different value, my fault.
    May be the install script can emphasize that this has to be changed in case of an update?

    All the best and thanks,

    Koen


  • Senior Developer

    DID YOU READ THE OUTPUT ON THE SCREEN?

    It tells you you need to change the Option 67 from pxelinux.0 to undionly.kpxe


Log in to reply
 

353
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.