Bit comfused with new FOG 1.0.1



  • Hello All,

    We have for few years now FOG 0.32 in production, over the years we populated our default pxe menu
    with many utility’s and custom ISO’s,
    We would like to migrate to new server , but don’t really know how to.
    Few days ago we installed fresh new Fog 1.0.1 and hardware server with Ubuntu 14.04LTS , now i discovered many settings where changed
    The default pxe menu file not exist anymore , i don’t really know where to put my iso’s and utility’s , also where is the of the bzimage etc…
    Can someone kindly instruct me for those basic features how to , really appreciate.
    Please advice
    Thanks



  • I was having enough issues getting Fog to run, I didn’t want to try using 14.04. Now that Fog is working as it should maybe I will try the newer version. As for hardware I am using VMware 5.1 on a HP DL380G6. Each Fog VM gets 2vCPU and 8GB of RAM. I will post the results when I get the chance to try 14.04.


  • Senior Developer

    Mark,

    I agree that 14.04 has been having issues, though I’m starting to think it’s due to other information that we’re not getting the full picture of. I say this because I am running a FOG Server using 14.04 and not seeing ANY of the issues others have been experiencing. It seems to me that’s likely environmental to the hardware 14.04 is running on than the FOG system itself.

    Most specifically, from my knowledge it appears likely due to RAM issues with how innodb is being handled on their systems. I don’t have all the information, but my specific setup is a VM, minimal install of 14.04LTS without a GUI. The VM has only 1GB of RAM and 1 vCPU.

    It doesn’t happen to everybody, but it is common enough, to me, to state it’s either hardware or Ubuntu related. Based on the fact that it’s working for most, and only having problems occasionally here, I’m leaning more to the hardware is the problem.



  • Just a note, There has been a lot of chatter on the forum about Ubuntu 14.04LTS and issues with FOG. For me it was not worth the risk and I am using 13.10.



  • http://www.fogproject.org/wiki/index.php/Advanced_Boot_Menu_Configuration_options
    to transition from 0.32 to 1.0+ i recommend this
    http://www.fogproject.org/wiki/index.php/Manual_Migration_Upgrade_from_0.32_to1.0
    upgrading from 0.32 to 1.0+ is supported, but a fresh install is recommended instead[/quote]
    Thanks:)


  • Developer

    bzImage is located in the /service/ipxe directory of your web server. it is now downloaded over http much faster then before
    we no longer use pxelinux.0 and use ipxe. this will require changing settings on your dhcp server
    to create boot menu options, i recommend this
    http://www.fogproject.org/wiki/index.php/Advanced_Boot_Menu_Configuration_options
    to transition from 0.32 to 1.0+ i recommend this
    http://www.fogproject.org/wiki/index.php/Manual_Migration_Upgrade_from_0.32_to1.0
    upgrading from 0.32 to 1.0+ is supported, but a fresh install is recommended instead


Log in to reply
 

393
Online

38918
Users

10688
Topics

101399
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.