PXE Boot Problems after upgrade to 1.0.1



  • Everything was working fine with 0.32.
    Now I have PXE boot problems:
    TFTP.
    PXE-T01: File not found
    PXE-E3B: TFTP Error - File not found
    PXE-M0F: Exiting PXE ROM.

    I made a clean installation, but the problem still exists. Any help please?
    Thank you


  • Developer

    [quote=“Tom Elliott, post: 28975, member: 7271”]No, but it’s good to have so people aren’t staring at code thinking the problem is missing text.

    In programming, typically it’s syntactically incorrect to have dhcp-boot=,[/quote]

    In some systems when using DNSMASQ you have to leave that field blank, like novell. If you supply the FOG host server name, the file will fail to resolve. I should have left a place holder in the documentation that explained that the blank is for the host name but I didn’t know it was going to drive you insane lol


  • Senior Developer

    No, but it’s good to have so people aren’t staring at code thinking the problem is missing text.

    In programming, typically it’s syntactically incorrect to have dhcp-boot=,



  • Thank you Tom. Everything is fine now, will I gain something by assigning a hostname? (I can’t find any advantage with my limited knowledge)


  • Senior Developer

    Glad you figured this out.

    If you want, you can assign a hostname as well, by assigning the line as:
    [code]dhcp-boot=undionly.kpxe,fogserver,192.168.1.5[/code]

    I run dd-wrt but the methodology in assigning “option 67” is the exact same.



  • I replaced in [CODE]dhcp-boot=pxelinux.0,192.168.1.5[/CODE] pxelinux.0 with undionly.kpxe in Tomato router in DNSMASQ service field and now everything is OK! Thank you!!



  • I had the same problem. Fixed it replacing undionly.kpxe with the one found in undionly.kpxe.INTEL
    (rename undionly.kpxe to undionly.kpxe.ORIGINAL and then copy undionly.kpxe.INTEL to undionly.kpxe)

    I also changed option 67 filename in my DHCP server.


  • Developer

    [quote=“hariskar, post: 28850, member: 24448”]No, I did not change anything. Which file should I change? Fog is on lubuntu. (newbie here)
    I use my Tomato router for dhcp service.
    Thank you for instant reply![/quote]

    You will edit the settings in Tomato, if available, if not you can use a DNSMASQ service to dole out dhcp information during pxe boot and to help resolve your boot file, for now, look at the settings in Tomato and see if you can’t find a setting for next-server (option 066), which will need to be set up as your FOG server ip address, and also look for the boot file name (option 067) which will need to be pointed at the undionly.kpxe file.



  • No, I did not change anything. Which file should I change? Fog is on lubuntu. (newbie here)
    I use my Tomato router for dhcp service.
    Thank you for instant reply!


  • Developer

    [quote=“hariskar, post: 28848, member: 24448”]Everything was working fine with 0.32.
    Now I have PXE boot problems:
    TFTP.
    PXE-T01: File not found
    PXE-E3B: TFTP Error - File not found
    PXE-M0F: Exiting PXE ROM.

    I made a clean installation, but the problem still exists. Any help please?
    Thank you[/quote]

    Did you change option 067 to the current bootfile as instructed by the installer? Latest versions of FOG use the iPXE system and undionly.kpxe to serve the boot menu and options as opposed to the 0.32 version of pxe which used the pxelinux.0 file.

    Sorry it was early morning and I made type-o, I have fixed it!!!


Log in to reply
 

467
Online

39.4k
Users

11.1k
Topics

105.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.