Upgrading to 1.01, database not found error



  • I followed the wiki instructions to upgrade my .32 install to version 1.01. Everything seemed to work fine. I had no errors. When I try to log in the fog I get an unable to connect to database error. The install did not change MySQL:
    [COLOR=#000000][FONT=Arial][SIZE=15px]Building dependency tree…[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px]Reading state information…[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px]mysql-server is already the newest version.[/SIZE][/FONT][/COLOR]

    configuring services shows no issues:
    [COLOR=#000000][FONT=Arial][SIZE=15px] Configuring services.[/SIZE][/FONT][/COLOR]

    [COLOR=#000000][FONT=Arial][SIZE=15px] * Setting up fog user…Exists[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Setting up and starting MySql…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Backing up user reports…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Setting up and starting Apache Web Server…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Restoring user reports…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Configuring Fresh Clam…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Setting up storage…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Setting up and starting NFS Server…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Setting up and starting DHCP Server…Skipped[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Setting up and starting TFTP and PXE Servers…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Setting up and starting VSFTP Server…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Setting up sudo settings…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Setting up FOG Snapins…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Setting up and building UDPCast…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Installing init scripts…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Setting up FOG Services…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Starting FOG Multicast Management Server…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Starting FOG Image Replicator Server…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Starting FOG Task Scheduler Server…OK[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] * Setting up FOG Utils…OK[/SIZE][/FONT][/COLOR]

    Yet when I go to the web interface I get the database unable to connect error.

    What do I look at first?[COLOR=#000000][FONT=Arial][SIZE=15px][/SIZE][/FONT][/COLOR]



  • [quote=“Junkhacker, post: 28517, member: 21583”]there was a line in the install script telling you that you would need to edit the config.php file if you had a password
    you had to hit enter to proceed past that message[/quote]

    here is the line:

    [COLOR=#000000][FONT=Arial][SIZE=15px] [/SIZE][/FONT][/COLOR][COLOR=#000000][FONT=Arial][SIZE=15px]We are about to install MySQL Server on[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] [/SIZE][/FONT][/COLOR][COLOR=#000000][FONT=Arial][SIZE=15px]this server, if MySQL isn’t installed already[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] [/SIZE][/FONT][/COLOR][COLOR=#000000][FONT=Arial][SIZE=15px]you will be prompted for a root password. If[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] [/SIZE][/FONT][/COLOR][COLOR=#000000][FONT=Arial][SIZE=15px]you don’t leave it blank you will need to change[/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px] [/SIZE][/FONT][/COLOR][COLOR=#000000][FONT=Arial][SIZE=15px]it in the config.php file located at:[/SIZE][/FONT][/COLOR]

    [COLOR=#000000][FONT=Arial][SIZE=15px] [/SIZE][/FONT][/COLOR][COLOR=#000000][FONT=Arial][SIZE=15px]/var/www/fog/commons/config.php[/SIZE][/FONT][/COLOR]

    [COLOR=#000000][FONT=Arial][SIZE=15px] [/SIZE][/FONT][/COLOR][COLOR=#000000][FONT=Arial][SIZE=15px]Press enter to acknowledge this message.[/SIZE][/FONT][/COLOR]

    It talks about if MySQL isn’t install. It was already installed. Therefore It did NOT apply to me. Maybe you should read the line before criticizing me. Or you should write the line in the script so that it says change the config.php file even is you already have MySQL installed.

    Also a line in the script says:
    [COLOR=#000000][FONT=Arial][SIZE=15px] Please see our wiki for more information at [url]http://www.fogproject.org/wiki[/url][/SIZE][/FONT][/COLOR]
    [COLOR=#000000][FONT=Arial][SIZE=15px][/SIZE][/FONT][/COLOR]
    That is why I suggested it should be in the wiki, not the script.

    [COLOR=#000000][FONT=Arial][SIZE=15px][/SIZE][/FONT][/COLOR]


  • Developer

    there was a line in the install script telling you that you would need to edit the config.php file if you had a password
    you had to hit enter to proceed past that message



  • That did it. You may want to add that to the upgrade wiki page.

    Mark


  • Senior Developer

    Does your database have a password for the root user on mysql?

    Edit the commons/config.php file and enter your appropriate information.


Log in to reply
 

368
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.