Plugins Page Not Loading after Reverting back to 1.0.1



  • Hello! Been around these forums for awhile to get help with our new Fog install, and decided to finally register, say hello, and report an issue I’m having at the moment.

    Yesterday I upgraded our Fog server to 1.1.0 from 1.0.1. It was working fine previous to this.
    It broke.
    Nothing would PXE boot, it appeared as though the DHCP timeout “retry” was not working. I couldn’t confirm, because I couldn’t see the error before it booted to Windows.
    Soooo… I figured it might be buggy and reinstalled 1.0.1. I did this without removing 1.1.0.
    Now, I am able to image, register hosts, etc.
    HOWEVER…when I go to the “Plugin Management” page, and click any links (Installed Plugins, Activate plugins) it just sits there on “Waiting.” Nothing loads. What is worse, is that after clicking one of these links, nothing else on the page will load, either.

    Am I going to have to uninstall the entire thing and go again, or is there something off the top of your head that would fix this issue?

    Thanks, all! Great work!

    [url="/_imported_xf_attachments/0/842_fog.png?:"]fog.png[/url]



  • I’ve now created and deployed a few images using 13.10 with 1.1.0. It is working very well. Thank you, everyone–for your help!

    Now, I need to start a new thread about another problem… :)



  • [quote=“Junkhacker, post: 28515, member: 21583”]btw, the pxe files used for 1.0.1 and 1.1.0 are identical in functionality, they just use slightly different code to do it. if one works for you and another doesn’t, there is no need to do any kind of “downgrade,” just swap the file for the one that works. that said, i recommend you try the undionly.kpxe file currently in the svn trunk release if you are having issues.[/quote]

    I am doing the boot using the undionly. I’ve been using that since updating to 1.0.1, and that gets me a lot more hits than I was getting with the pxelinux method. I’m still doing some testing with the 13.10 and 1.1.0. So far it seems to be working quite well. I just have a few little issues that I’m trying to work out, which are most likely my fault.
    I’m going to work on this throughout the day, and hopefully be able to close out this thread a bit later.


  • Developer

    btw, the pxe files used for 1.0.1 and 1.1.0 are identical in functionality, they just use slightly different code to do it. if one works for you and another doesn’t, there is no need to do any kind of “downgrade,” just swap the file for the one that works. that said, i recommend you try the undionly.kpxe file currently in the svn trunk release if you are having issues.



  • [quote=“Junkhacker, post: 28502, member: 21583”]unfortunately, any failure in pxe booting typically means no way of logging anything to file or even to screen. often, the best you can hope for is hitting the “pause/break” key at the right moment.[/quote]

    That’s what I figured. Unfortunately, I haven’t a quick enough “draw” when it comes to that.


  • Developer

    unfortunately, any failure in pxe booting typically means no way of logging anything to file or even to screen. often, the best you can hope for is hitting the “pause/break” key at the right moment.



  • Darn.[quote=“Tom Elliott, post: 28471, member: 7271”]If you want, when you upgraded to svn trunk (1.1.0) I’ve moved the plugins location from management/plugins to lib/plugins.

    What this meant, is I had to forcibly make sure the systems updated to …/lib/plugins in the FOG_PLUGINSYS_DIR of FOG Configuration->FOG Settings->Plugin System. When you retrograded to 1.0.1, it did not make this dir change back for you. To have recovered, you could’ve just changed the field to point at ./plugins Just so you know I wasn’t leaving you in the dust or anything.[/quote]

    Darn. Well, that’s okay. The more times I install linux, the more understanding I “get” of it, so that’s more than fine. If I hadn’t been lazy and stupid, I should have thought to look and see if that directory was still there. Now at least I know what to look for.

    I’m going to try the 13.10 with 1.1.0 and see what happens. We have a pretty wide mix of machines — (HP 2540P, 2570P, 8470P, Z400, 6005, 6005 small, and are about to get in some Dell E5540’s.) so, if 1.1.0 goes back to throwing whatever error I can’t see, at least I’ll know what to do when I downgrade to 1.0.1.

    Since I’m not overly versed on PXE and the process—is there a log somewhere that I can check to see what is going on when these things are booting? I would guess there’s nothing in the Apache logs. I would like to at least grab a PXE error code or something that I can send your way, in case this issue comes up again somewhere.

    It’s most likely Operator error…

    Thanks guys, have a great day. i’ll let you know how this works out.


  • Senior Developer

    [quote=“Jamie Rozek, post: 28469, member: 24394”]I didn’t have any problems running under 12.04 previously. It wasn’t until I upgraded to 1.1.0 that I had PXE boot issues. I’m not even positive it is TFTP at this point, because it displays the error quicker than I can read it.
    Another developer suggested 13.04 or 13.10 with the latest release, so I’m going to try that to see if it resolves the issues. I’ve completely uninstalled Fog at this point, and working on the OS upgrade.[/quote]

    If you want, when you upgraded to svn trunk (1.1.0) I’ve moved the plugins location from management/plugins to lib/plugins.

    What this meant, is I had to forcibly make sure the systems updated to …/lib/plugins in the FOG_PLUGINSYS_DIR of FOG Configuration->FOG Settings->Plugin System. When you retrograded to 1.0.1, it did not make this dir change back for you. To have recovered, you could’ve just changed the field to point at ./plugins Just so you know I wasn’t leaving you in the dust or anything.



  • I didn’t have any problems running under 12.04 previously. It wasn’t until I upgraded to 1.1.0 that I had PXE boot issues. I’m not even positive it is TFTP at this point, because it displays the error quicker than I can read it.
    Another developer suggested 13.04 or 13.10 with the latest release, so I’m going to try that to see if it resolves the issues. I’ve completely uninstalled Fog at this point, and working on the OS upgrade.


  • Developer

    the tftp issues with 12.04 are easily worked around with a startup script that makes the tftp service start after a delay on startup.
    that said, i run a 12.04 ubuntu server, and have not had to make that modification.



  • I’m going to try to re-install my server using Ubuntu 13.10 along with Fog 1.1.0. I’m currently running it on 12.04, which from browsing the forums appears to have some issues with TFTP.
    I’ll report back when I’ve done this.



  • I’m sorry to report that after reinstalling 1.1.0 – it is back to doing the same thing. It begins the PXE boot process, but the errors out and boots to the operating system.
    It does so quickly, and I am unable to get the error code. However, previously it was throwing DHCP errors under the old version, which after looping through a few times, it would load.



  • [quote=“Jamie Rozek, post: 28451, member: 24394”]Tom, thank you for the quick response.
    I see that 1.0.1 has revision 1761. Is that considered 1.1.0 or is there another directory for it? I cannot for the life of me remember where I got that from yesterday![/quote]

    Sorry to waste your time, Tom…I found it!



  • Tom, thank you for the quick response.
    I see that 1.0.1 has revision 1761. Is that considered 1.1.0 or is there another directory for it? I cannot for the life of me remember where I got that from yesterday!


  • Senior Developer

    I’d say try “re-upgrading” to 1.1.0. SVN 1759 is now out and it’s most likely the changes between how the files are done in 1.0.1 to 1.1.0.

    Try re-upgrading. For a little bit there I had issues with the init’s which is most likely why you were having issues imaging but they should be fixed now.


Log in to reply
 

425
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.