Xenclient with fog 0.32 on ubuntu 12.04



  • [SIZE=14px][FONT=arial][COLOR=#1b1c0a]Hello [/COLOR][/FONT][/SIZE]
    [SIZE=14px][FONT=arial][COLOR=#1b1c0a]have problem with fog 0.32 on ubuntu 12.04 …[/COLOR][/FONT][/SIZE]
    [SIZE=14px][FONT=arial][COLOR=#1b1c0a] [/COLOR][/FONT][/SIZE]
    [SIZE=14px][FONT=arial][COLOR=#1b1c0a]I have followed this procedure …[/COLOR][/FONT][/SIZE]
    [SIZE=14px][FONT=arial][COLOR=#1b1c0a][URL=‘http://support.citrix.com/article/CTX134493’][U][COLOR=#666633]http://support.citri…ticle/CTX134493[/COLOR][/U][/URL][/COLOR][/FONT][/SIZE]
    [FONT=arial][COLOR=#1b1c0a][SIZE=14px]LABEL NxTop Installnxtopengine[/SIZE][/COLOR][/FONT]
    [FONT=arial][COLOR=#1b1c0a][SIZE=14px]kernel mboot.c32[/SIZE][/COLOR][/FONT]
    [FONT=arial][COLOR=#1b1c0a][SIZE=14px]append nxtopengine/xen.gz nxtopengine/vmlinuz boot=casper[/SIZE][/COLOR][/FONT]
    [FONT=arial][COLOR=#1b1c0a][SIZE=14px] webboot=[url]http://192.168.10.127/tftpboot/nxtopengine/nxtopengine.iso[/url][/SIZE][/COLOR][/FONT]
    [FONT=arial][COLOR=#1b1c0a][SIZE=14px] nxtopengine/initrd.img[/SIZE][/COLOR][/FONT]
    [FONT=arial][COLOR=#1b1c0a][SIZE=14px]TEXT HELP[/SIZE][/COLOR][/FONT]
    [FONT=arial][COLOR=#1b1c0a][SIZE=14px] davidTCX[/SIZE][/COLOR][/FONT]
    [FONT=arial][COLOR=#1b1c0a][SIZE=14px] ENDTEXT[/SIZE][/COLOR][/FONT]
    [SIZE=14px][FONT=arial][COLOR=#1b1c0a] [/COLOR][/FONT][/SIZE]
    [SIZE=14px][FONT=arial][COLOR=#1b1c0a]files mboot.c32 and others have from extract iso image …[/COLOR][/FONT][/SIZE]
    [SIZE=14px][FONT=arial][COLOR=#1b1c0a] [/COLOR][/FONT][/SIZE]
    [SIZE=14px][FONT=arial][COLOR=#1b1c0a]fog server is running corectly but with xenclient no …[/COLOR][/FONT][/SIZE]
    [SIZE=14px][FONT=arial][COLOR=#1b1c0a] [/COLOR][/FONT][/SIZE]
    [SIZE=14px][FONT=arial][COLOR=#1b1c0a]any ideas ? or screenshots with locations files ?[/COLOR][/FONT][/SIZE]
    [SIZE=14px][FONT=arial][COLOR=#1b1c0a] [/COLOR][/FONT][/SIZE]
    [SIZE=14px][FONT=arial][COLOR=#1b1c0a]on this video is good instruction but i dont have memdisk file …[/COLOR][/FONT][/SIZE]
    [FONT=arial][COLOR=#1b1c0a][SIZE=14px][media=youtube]aa4zbeYVnxs[/media][/SIZE][/COLOR][/FONT]

    [FONT=arial][COLOR=#1b1c0a][SIZE=14px]please help[/SIZE][/COLOR][/FONT]

    [FONT=arial][COLOR=#1b1c0a][SIZE=14px]David[/SIZE][/COLOR][/FONT]

    [FONT=arial][COLOR=#1b1c0a][SIZE=14px][/SIZE][/COLOR][/FONT]

    [url="/_imported_xf_attachments/0/839_fog.jpg?:"]fog.jpg[/url]


  • Senior Developer

    I’m not going to assist with this further.

    Why you ask yourself expectantly?

    You’re requesting we download files, but hosting through not necessarily good sources. This leads me to think you’re attempting to gain access to systems.

    I’m not saying this is WHAT you are actually trying to do, but I’m not going to download files from those links.

    Next reason,

    You’re making requests and saying, it’s not working. And the only “information” you can give is “you give it a try”?

    MMMMMMMMM sounds sketchy to me.

    If you want help, provide information in a more detailed nature such as “This error is happening.” Or upload screenshots of the problems your having.

    MOD’s, if you can Please remove the links from the posts (or David you can) as they are known “bad” sites.



  • [COLOR=#1f497d][FONT=Calibri][url]http://support.citrix.com/servlet/KbServlet/download/37161-102-709454/XenClient Enterprise Engine Installation Guide Version 5.1.0.pdf[/url][/FONT][/COLOR]

    [COLOR=#1f497d][FONT=Calibri]Orignal instruction from citrix for fog … page 16 and more …[/FONT][/COLOR]



  • This post is deleted!

  • Senior Developer

    Try this link: it’s built from 6.02 syslinux:
    [url]https://mastacontrola.com/fogboot/kernel/memdisk[/url]



  • Can you do this week … ?


  • Senior Developer

    I have not rebuilt a memdisk kernel for this yet, and I’m sorry.



  • Hi boys …
    On this link is a instrucion to install xenserver from citrix with wds

    [url]http://www.syslinux.org/wiki/index.php/WDSLINUX[/url]

    It is also necessary to have these files as the XenClient …
    My files is maybe bad …



  • When i send you xenclient iso image do you test in your fog ? I’ll Lead if my fog is 100 % corect .

    Thanks


  • Senior Developer

    [quote=“David Majcher, post: 28605, member: 24389”]Tom when i download and set another memdisk file the boot is corect start to install screen but when i set install VM machines restart and HV machine stoped in next boot …
    Please send my your memdisk file on my email [EMAIL]majcher@tcx.sk[/EMAIL]

    Thanks[/quote]

    I can attach my memdisk file, but I don’t think it’s going to make a difference. Since you’re using PXE boot I think the constraints are in how the memdisk is built. I’ll build a brand new memdisk from the latest kernel source that should have VM support as well. I think this is where your problem lies at the moment.



  • Tom when i download and set another memdisk file the boot is corect start to install screen but when i set install VM machines restart and HV machine stoped in next boot …
    Please send my your memdisk file on my email [email]majcher@tcx.sk[/email]

    Thanks



  • ISO = 850 MB
    testing on 3 machines
    1, VM Hyper V - 1024 MB ram (enlarge to 2048 MB)
    2, VM VMware - 1024 MB ram (enlarge to 2048 MB)
    3, HW Dell Laptop 4096 MB ram

    Screenshot is for VMware …
    at all the same end…


  • Senior Developer

    How big is the ISO file? How much memory does your system have available? Is there more memory available than the size of the ISO?



  • Tom when i set :
    [FONT=Consolas]LABEL fog wiki
    MENU MASTER PASSWD password
    kernel memdisk
    append iso initrd=fog/nxtopengine/nxtopengine.iso raw[/FONT]
    [FONT=Consolas]install stop on this (picture)[/FONT]
    [FONT=Consolas]and when i set [/FONT]
    [FONT=Consolas]LABEL fog wiki
    MENU MASTER PASSWD password
    kernel fog/nxtopengine/vmlinuz
    append initrd=fog/nxtopengine/initrd.img[/FONT]
    [FONT=Consolas]get into[/FONT][FONT=Tahoma] to the initramfs command line …[/FONT]
    [FONT=Consolas] [/FONT]

    [url="/_imported_xf_attachments/0/854_MEMDISK.jpg?:"]MEMDISK.jpg[/url]


  • Senior Developer

    [quote=“David Majcher, post: 28488, member: 24389”]Thanks help boot (picture1)
    but not in a good end
    [code]LABEL fog wiki
    MENU MASTER PASSWD password
    kernel fog/nxtopengine/vmlinuz
    append iso initrd=fog/nxtopengine/[SIZE=5][COLOR=#ff0000]initrd.img[/COLOR][/SIZE] raw[/code]

    helped but it stops at this screen(picture2) …

    [code]LABEL fog wiki
    MENU MASTER PASSWD password
    kernel fog/nxtopengine/vmlinuz
    append iso initrd=fog/nxtopengine/[COLOR=#ff0000][SIZE=5]nxtopengine.iso[/SIZE][/COLOR] raw[/code]

    when i write on initrd position iso image name than boot stop on ready (picture3)

    I have no more ideas …[/quote]

    You should have a file called memdisk located in:
    /tftpboot/memdisk

    If not, you can download any one.

    vmlinuz is a kernel and would need an initrd to load to.

    Because the iso is NOT an initrd, this is why you’re getting the initramfs command line.

    You’ll likely need to change the entires to either:
    [code]LABEL fog wiki
    MENU MASTER PASSWD password
    kernel fog/nxtopengine/vmlinuz
    append initrd=fog/nxtopengine/initrd.img[/code]

    OR

    [code]LABEL fog wiki
    MENU MASTER PASSWD password
    kernel memdisk
    append iso initrd=fog/nxtopengine/nxtopengine.iso raw[/code]



  • Thanks help boot (picture1)
    but not in a good end

    LABEL fog wiki
    MENU MASTER PASSWD password
    kernel fog/nxtopengine/vmlinuz
    append iso initrd=fog/nxtopengine/[SIZE=5][COLOR=#ff0000]initrd.img[/COLOR][/SIZE] raw

    helped but it stops at this screen(picture2) …

    LABEL fog wiki
    MENU MASTER PASSWD password
    kernel fog/nxtopengine/vmlinuz
    append iso initrd=fog/nxtopengine/[COLOR=#ff0000][SIZE=5]nxtopengine.iso[/SIZE][/COLOR] raw

    when i write on initrd position iso image name than boot stop on ready (picture3)

    I have no more ideas …

    [url="/_imported_xf_attachments/0/851_boot.jpg?:"]boot.jpg[/url][url="/_imported_xf_attachments/0/852_end.jpg?:"]end.jpg[/url][url="/_imported_xf_attachments/0/853_iso.jpg?:"]iso.jpg[/url]


  • Developer

    I imagine someone will be able to help I know others in the past have been successful in booting citrix stuff directly from the pxe boot menu, I hope one of them will stop by, in the mean time, I would look at how your menu call is different from the information in [url]http://fogproject.org/wiki/index.php?title=Include_any_ISO_in_the_FOG_Bootmenu[/url]

    This should help you to better understand how things need to be laid out so that it can be displayed an accessed properly.

    I’m glad your FOG server is working properly, hopefully someone who has actually added menu items in 0.32 can chime in.

    P.s. you can use the memdisk file from one of your other pxe boots that fog uses ;)

    The video guide you posted should suffice, I would use the wiki for reference as well.


Log in to reply
 

369
Online

38983
Users

10712
Topics

101680
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.