Not a partclone image



  • I am attempting to deploy my first image! :) I took an image of a computer running Zorin Linux 8. I then deployed that very image back to the same machine successfully. I then put a different box on the bench and tried to deploy the same image to it.

    Registered the Host - success
    Placed Host in Group - success
    Assigned Image to Host - success
    Schedule Task to Deploy - success
    Booted Client into iPXE - success
    Deploy Image - fail - “Not a partclone image”

    Any thoughts?


  • Developer

    will it work if you try an Image Type of RAW?



  • Downloaded the latest Subversion. Seems to be the one I was one. 1.0.1

    No difference in results.



  • Oh Sorry.
    Operating System: Linux - (50)
    Image Type: Multiple Partition Image - Single Disk (Not Resizable) - (2)


  • Developer

    i meant the options in the Image Management page



  • For which image? The Ubuntu I am using is
    Ubuntu 14.04 LTS Desktop.
    Zorin is version 8
    TinyCore 3.0.21-tinycore


  • Developer

    what operating system and image type are you using in your image?


  • Senior Developer

    If you can, please try the latest trunk (SVN) of fog and see if the updated init.xz’s will help make a successful image.



  • I only install Ubuntu on this to make an image from it. Ultimately I want to make it so I can Boot TinyCore Linux from FOG with GUI Support to act as a Zero Client for VMware. I have a working version of TinyCore with VMware-View Loaded. It pops up and covers the screen beautifully. No one can do anything with the OS just use View-Client. Well I am reading and it seems for the GUI to be included in the core I am loading I need to remaster it. So I was playing with a current version of TinyCore (it includes more keyboard and network drivers then I have in my current core) and had it install to the local hard drive. This dumped the Partitions Ubuntu made. TinyCore didn’t install like it should have so I said hey perfect time to test and see in the deploying process really will work.

    And here I am. This has been a lot harder to get this working then it should be. We have an old tech here who wants to load my current version of TinyCore on a bunch of really cheap USB drives and get USB Extension cables and hang them on the inside of the machines. This means we would have cables going into our boxes to run the OS and I can’t stand that idea. There has to be a better way to deploy this on a larger scale. That is when I came across FOG.

    Currently this old Tech is using CloneZilla by slaving HDD on his machine to image new machines and I want to get away from that as well.


  • Senior Developer

    That’s correct, but what are you changing when you’re “Playing with the TinyCore” files?



  • It doesn’t seem to matter what I set the image to. Partclone for Partimage same results. JunkHacker says all the images uploaded are Partclone so I shouldn’t have to change anything since these are fresh images on 1.0.1


  • Senior Developer

    So what do you mean “Played around with some TimyCore” on it.



  • So I created a new image of my second test box after I installed Ubuntu Desktop 14.04 LTS 32bit version on it. Again image created successfully. Played around with some TinyCore on it and removed the partitions. Went to reimage and Fog reported yet again that the image it had just taken was not a “partclone” however the screen flashed black and then back up and it proceeded to deploy the image for 2 other partitions? When I went to boot from the local drive I get Grub Rescue Mode which is more then I got before I attempted to reimage.


  • Senior Developer

    Is the image setup as Partimage or Partclone?



  • Just recaptured the image. Everything said it completed correctly. I made sure my computer is in the right group and with the right image selected. I scheduled the task and rebooted. The client machine never loads the cloning screen (Blue Background Red Status Bar)


  • Developer

    all new images uploaded are partclone. partimage is download only, and is included for legacy reasons.



  • Fog 1.0.1 fresh install a week ago on Ubuntu Server 14.04

    Uploaded the image a few days later. Is there a way to tell it to be one or the other during the imaging process? Which one is better?

    I am going to recapture the image and then try again.

    I checked the GUI Flag and updated the image to a PartImage from PartClone and vice versa. The Client Boots but restarts before the Cloning Screen.


  • Developer

    Are you sure the first deployment worked? Like you actually watched it deploy the image to that machine and complete?

    When did you upload the image? Was it uploaded on an older version of FOG? IF it’s a partImage image instead of partClone you need to enable the legacy flag under fog settings and then change the drop down that shows up under the image.


Log in to reply
 

364
Online

38976
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.