Blank page after creating new Image



  • Hi,
    I just created a new image and after clicking the “Add” I was presented with a blank page and no error. Now when I click on “List All Images” I also get a blank page. When I click on “New Search” and start type in the search box I get the error “Search failed: Internal Server Error”. HELP!



  • Thank you Tom for looking into it. I’ll update as soon as I can figure out why the database schema does not update … :( … see separate post here:

    http://fogproject.org/forum/threads/fog-error-access-web.10812/#post-30283


  • Senior Developer

    @bjohnson84, post: 30086, member: 1083 said:

    Has anyone found a solution to this. I know axel12 talked about if images don’t have a storage node assigned it can be a problem, but not sure how to fix that if it’s the case. Not being able to edit images has me dead in the water.

    I have seen and fixed the problem with this.

    Update to latest SVN, while multicast still has some issues, this particular one is already fixed.



  • Has anyone found a solution to this. I know axel12 talked about if images don’t have a storage node assigned it can be a problem, but not sure how to fix that if it’s the case. Not being able to edit images has me dead in the water.



  • Upon further testing this is what it seems to me:

    On the “List all images” page -> you will get an error (see error log in above posts) if [B]any of the images belong to a storage group without a storage node[/B]

    On the individual “image details” page -> you get an error if the image belongs to a storage group [B]which has NO master node in it[/B]

    This has been replicated deterministically. This is important become some schools (like mine) live on two separate sites - and I would like to all image stuff in one location, and replicate [B]once[/B] to the other location (after which clone locally) … this error makes it very time-consuming to babysit node settings and image settings to make sure that whatever Image i am working with is part of a storage group with at least the main node in it.

    Is it possible to trust the user and only check for presence of only the storage node (not master server) - so if there is a cloning mistake, at least its local, and I’m not pulling the image across a VPN? Or better yet - do not check for presence of any nodes - and simply complain on deployment that the image has no acceptable nodes to pull from (which was the behavior of fog .32)

    Thank you for your time and effort,

    PHP 5.5.9-1ubuntu4 (cli) (built: Apr 9 2014 17:08:27)
    Copyright © 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright © 1998-2014 Zend Technologies
    with Zend OPcache v7.0.3, Copyright © 1999-2014, by Zend Technologies



  • Getting the same error - using fog from svn build 1807 … here is what i also noticed. when the main fog and a node are in the same group (id:1) you can access all images as long as they are also in the same storage group. as soon as you assign EITHER an image to a different group OR a node to a different storage group, suddenly you cannot access NEITHER the node details NOR view the image list.

    Here are a bunch of errors:

    http://localhost/fog/management/index.php?node=images

    [Thu Jun 12 11:57:08.863074 2014] [:error] [pid 4556] [client 127.0.0.1:41449] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/lib/pages/ImageManagementPage.class.php on line 355



  • Oh, and I did re-run the install
    /bin/./installfog.sh to see if that would fix it.
    no change

    These are the two entries in /var/log/apach2/error file
    The first is when I click list images, the second is when I try to search images

    http://192.168.1.1/fog/management/index.php?node=images

    http://192.168.1.1/fog/management/index.php?node=images&sub=search



  • Hello:
    what was the ultimate resolution to this? I seem to have the exact same problem now and it seemed to happen after I messed with trying to move my storage location.
    I did try to change the memory size. Mine was like Brett’s above. I went from 128m to 256m and it didn’t help.
    My php -v reports:
    php 5.5.9-1ubuntu4
    built april 9 2014
    Zend engine v 2.5.0


  • Senior Developer

    What php version are you running?

    php -v
    


  • Hi pmonstad, thanks for your reply! In my /etc/php5/apache2/php.ini “file memory_limit” was set to 128M so I increased it to 256M and restarted apache but still having the same issue.
    Thanks Brett.



  • [I]I had the same issue. I solved it by editing php.ini. Increase the value of the variable memory_limit = 32M (I set it to 32M, default on my server was 16M). Then restart your apache server.[/I]


Log in to reply
 

394
Online

38713
Users

10542
Topics

99804
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.