Changing Name works, Joining AD is not but was prior to upgrade


  • Testers

    ok so I have been using Fog since .028 I love it and so glad we now have the newest version.
    Took the leap today with the exception of a very few things the biggest one i have issue with is the AD joining. my key is encrypted and everything appears to be set. little hiccups with the upgrade but all seem resolved for now till I learn how to modify the PXE boot menu’s again lol…

    Again as most have commented on already, the images deploy and (Thanks for making that faster and better) reboot and change name then Nothing.

    never reboots again to change to the domain.

    I have looked everywhere I can think to make sure I have the encrypted key and all credentials correct.

    Somethings I have tried but dont know if its secondary to this or just coincidental.
    I upgraded and had issue with booting so tried to verify mysql… was not able to use the command " mysql -u root -p -hXXX.XXX.XXX.XXX fog

    asks for password there isnt any and I verified this from the config file from version .032- password for SQL was blank. I get "ERROR 1045 (28000): Access denied for user ‘root’@‘172.31.177.201’ (using password: NO)
    "
    Is this a problem with mysql? I tried adding a user name to the login such as fog and still not connecting… could this be the reason.


  • Testers

    @Tom Elliott, post: 28119, member: 7271 said:

    What about this:

    >update hosts set hostADUser='Administrator' where hostADUser like '%roxborough%Administrator%';
    >```
     
    BINGO!  
    mysql> update hosts set hostADUser='Administrator' where hostADUser like '%roxborough%Administrator%';
    Query OK, 179 rows affected (0.01 sec)
    Rows matched: 179  Changed: 179  Warnings: 0

  • Developer

    i recommend that you install phpmyadmin, which will allow you to edit the database from a webgui, if you want to edit the database and are unfamiliar with editing mysql databases from command line


  • Senior Developer

    What about this:

    update hosts set hostADUser='Administrator' where hostADUser like '%roxborough%Administrator%';
    

  • Testers

    @Raff, post: 28080, member: 298 said:

    it’s probably case sensitive, modify the query with the correct case, check an existing host for the case your using

    Is there any older config files I can look at that would house this information as I think I have already modified the current configuration so the previous case sensitivity is lost. Im trying to reference what it used to be but cant find the FOG configuration file that had this information from any backup’s



  • it’s probably case sensitive, modify the query with the correct case, check an existing host for the case your using


  • Testers

    Ok so I am attempting to do this two ways… Directly from the FOG server Via Command Line and from a windows PC here is the error i see from the Fog Server:
    roxborough@roxmintfog:~$ mysql -u root -p fog
    Enter password:
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A

    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 9275
    Server version: 5.5.37-0ubuntu0.12.04.1 (Ubuntu)

    Copyright © 2000, 2014, Oracle and/or its affiliates. All rights reserved.

    Oracle is a registered trademark of Oracle Corporation and/or its
    affiliates. Other names may be trademarks of their respective
    owners.

    Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

    mysql> update hosts set hostADUser=‘Administrator’ where hostADUser=‘roxborough\Administrator’;
    Query OK, 0 rows affected (0.00 sec)
    Rows matched: 0 Changed: 0 Warnings: 0

    mysql> update hosts set hostADUser=‘Administrator’ where hostADUser=‘roxborough\Administrator’;
    Query OK, 0 rows affected (0.00 sec)
    Rows matched: 0 Changed: 0 Warnings: 0

    mysql>
    and in Windows I tried using SQLyog for win and it keeps adding my domain ID to the end of the logon users credentials so it denies access to the fog server/DB.



  • I use SQLyog community edition to make a connection to the database.

    Recommend you make a backup first.

    The SQL query you need to execute is:
    update hosts set hostADUser=‘Administrator’ where hostADUser=‘roxborough\Administrator’;


  • Testers

    @Raff, post: 28071, member: 298 said:

    You could do an SQL query to the database directly and change only the ones that have the setting roxborough\Administrator

    RAFF,
    Im not that familiar with SQL modification is there a simple way to either use a GUI to search it or a step by step command to edit the SQL database… I have always wanted to reset the numbering as well for images we have deleted and the newest images just keep adding on increasing in number.



  • You could do an SQL query to the database directly and change only the ones that have the setting roxborough\Administrator


  • Testers

    @Raff, post: 28068, member: 298 said:

    Your welcome Bill, If you have hundreds of hosts in your database with that setting, create a temporary group and mass change the AD setting.

    Small issue with that I have over 500 deployed systems. some images are not allowed access to the domain CEO’s, CFO’s and so on. so I must go through all of my hosts and check each one individually… but I have no issue doing this… as long as I know it works.!



  • Your welcome Bill, If you have hundreds of hosts in your database with that setting, create a temporary group and mass change the AD setting.


  • Testers

    Let me Say!!! Thank you to the community! I now have AD joining functional again… the simple aspect of removing the roxborough\ in the host setting was the KEY!!! ty…

    Key Factor:
    “you have not done it for that individual host in Host Management. Its is still probably using Domain\Administrator.”

    Ok so recap- After updating to 1.0.1 from .032
    AD joining may break the fix for me was to verify the following settings :

    FOG_AD_DEFAULT_DOMAINNAME My Domain.com This setting never changes
    FOG_AD_DEFAULT_OU (Blank) Using default OU Computers1 This setting never changes
    FOG_AD_DEFAULT_USER [U][U]Administrator[/U][/U] (as per updated version only User name required) [B][U][U]REMOVE the DOMAIN\ Just leave the User name ONLY[/U][/U][/B]
    FOG_AD_DEFAULT_PASSWORD (Encrypted with fogcrypt) This setting never changes

    Under HOST options check the AD setting and make sure it does not have “[U][B]Domain\USER”[/B][/U] It Must match as above (User Name only)

    after this I was able to have the PC join the Domain with the Fog service



  • Bill,

    Looking through the posts again, you have probably changed the global AD settings to use [B]Domain Username: Administrator[/B] but you have not done it for that individual host in Host Management. Its is still probably using Domain\Administrator.



  • Before you change the account, If the host already exists in AD try deleting it, then restart fog service on client.



  • That error 2202 is returned directly from Active Directory, and from what I can tell after some searching, it’s saying “invalid username or group”. I’m not sure why it doesn’t like Administrator, but I would probably try a different user next. I would recommend using an account with less permissions anyway due to security concerns.


  • Testers

    This is the log right after the restart of the fog service.

    5/23/2014 8:43 AM FOG Service Engine Version: 3
    5/23/2014 8:43 AM Starting all sub processes
    5/23/2014 8:43 AM 14 modules loaded
    5/23/2014 8:43 AM * Starting FOG.AutoLogOut
    5/23/2014 8:43 AM * Starting FOG.SnapinClient
    5/23/2014 8:43 AM * Starting FOG.DirCleaner
    5/23/2014 8:43 AM * Starting FOG.DisplayManager
    5/23/2014 8:43 AM * Starting FOG.GreenFog
    5/23/2014 8:43 AM * Starting FOG.GUIWatcher
    5/23/2014 8:43 AM FOG::GUIWatcher Starting GUI Watcher…
    5/23/2014 8:43 AM FOG::DisplayManager Starting display manager process…
    5/23/2014 8:43 AM FOG::GreenFog Sleeping for 39 seconds.
    5/23/2014 8:43 AM FOG::AutoLogOut Starting process…
    5/23/2014 8:43 AM FOG::ClientUpdater Sleeping for 494 seconds.
    5/23/2014 8:43 AM * Starting FOG.HostRegister
    5/23/2014 8:43 AM * Starting FOG.MODDebug
    5/23/2014 8:43 AM FOG::MODDebug Start Called
    5/23/2014 8:43 AM FOG::MODDebug Sleeping for 100 Seconds
    5/23/2014 8:43 AM FOG::PrinterManager Starting interprocess communication process…
    5/23/2014 8:43 AM * Starting FOG.SnapinClient
    5/23/2014 8:43 AM FOG::HostnameChanger Starting hostname change process…
    5/23/2014 8:43 AM FOG::HostnameChanger Yielding to other subservices for 9 seconds.
    5/23/2014 8:43 AM FOG::PrinterManager interprocess comm startup: OK
    5/23/2014 8:43 AM * Starting FOG.TaskReboot
    5/23/2014 8:43 AM * Starting FOG.UserCleanup
    5/23/2014 8:43 AM FOG::TaskReboot Taskreboot in lazy mode.
    5/23/2014 8:43 AM FOG::TaskReboot Starting Task Reboot…
    5/23/2014 8:43 AM * Starting FOG.UserTracker
    5/23/2014 8:43 AM FOG::UserCleanup Sleeping for 13 seconds.
    5/23/2014 8:43 AM FOG::UserTracker Starting user tracking process…
    5/23/2014 8:43 AM FOG::SnapinClient Starting snapin client process…
    5/23/2014 8:43 AM FOG::SnapinClient Sleeping for 479 seconds.
    5/23/2014 8:43 AM FOG::DisplayManager Attempting to connect to fog server…
    5/23/2014 8:43 AM FOG::UserTracker Attempting to connect to fog server…
    5/23/2014 8:43 AM FOG::HostnameChanger Attempting to connect to fog server…
    5/23/2014 8:43 AM FOG::PrinterManager Sevice is disabled.
    5/23/2014 8:43 AM FOG::PrinterManager Module is active…
    5/23/2014 8:43 AM FOG::PrinterManager Starting printer manager…
    5/23/2014 8:43 AM FOG::PrinterManager Yielding to other services for 30 seconds.
    5/23/2014 8:43 AM FOG::AutoLogOut Module is disabled globally on the FOG Server.
    5/23/2014 8:43 AM FOG::UserCleanup Starting user cleanup process…
    5/23/2014 8:43 AM FOG::UserCleanup Attempting to connect to fog server…
    5/23/2014 8:43 AM FOG::UserCleanup Module is disabled globally on the FOG Server, exiting.
    5/23/2014 8:43 AM FOG::UserTracker Module is active…
    5/23/2014 8:43 AM FOG::DisplayManager Module is disabled globally on the FOG Server.
    5/23/2014 8:43 AM FOG::HostnameChanger Module is active…
    5/23/2014 8:43 AM FOG::HostnameChanger AD mode requested, confirming settings.
    5/23/2014 8:43 AM FOG::HostnameChanger Hostname is up to date
    5/23/2014 8:43 AM FOG::HostnameChanger Attempting to join domain if not already a member…
    5/23/2014 8:43 AM FOG::HostnameChanger Domain Error! (‘Unknown Error’ Code: 2202)



  • fog.log deletes itself when it gets to 10kb in size (quickly). Try stopping the FOG service, deleting fog.log, then starting the service. Check fog.log about a minute afterwards and you should see the error messages relating to the HostnameChanger.

    I know to get it working for me, I had to change the global settings (to remove the domain from the username field) but that didn’t automatically change it for all my existing hosts. I added all my hosts to a group, and changed it through the group as well.


  • Testers

    Tom,
    Appreciate all of your hard work in keeping this software going and please pass along my sincerest thanks to the rest of the Dev’s and support staff… Excellent software… I also appreciate you taking the time to assist me with this issue… the low budget facility I work for heavily rely on this software since i introduced it several years ago… we have had our ups and downs trying to get windows deployments :) however I have always been able to research a solution to almost any problems that have come up except for this.

    what ever assistance you can provide Just let me know what exact files you need and Ill get them to you.
    thanks


  • Testers

    Sorry Tom, Had to actually modify my post and supply the proper info… lol… hit submit to fast.


Log in to reply
 

467
Online

38923
Users

10690
Topics

101416
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.