Latest Development FOG


  • Testers

    [quote=“Tom Elliott, post: 42435, member: 7271”]I have released 3018 but I’m certainly not all of the bugs of been worked out yet as I work towards fixing the performance issues other things are breaking which should be relatively simple to fix I just want to give you all a heads up that I’m not trying to make your job harder I’m really trying to make it easier and I need to first start with getting this performance stuff figured out[/quote]
    Im good as the imaging is still working just find, i can manually rename and join it to the domain. no issues just wanted to let you know what I have found.
    Thanks for the hard work Tom.


  • Senior Developer

    I have released 3018 but I’m certainly not all of the bugs of been worked out yet as I work towards fixing the performance issues other things are breaking which should be relatively simple to fix I just want to give you all a heads up that I’m not trying to make your job harder I’m really trying to make it easier and I need to first start with getting this performance stuff figured out


  • Testers

    Ok FYI, tried to revert to the older version and its still broken. I do see you have a 3018 SVN. Ill try that and hope that its been looked at :)
    As always Tom, Always appreciate your hard work, wish I has the skills you do in coding this program.


  • Testers

    Tom, Im familiar, I was hoping to provide you with a little feed back on the issue so you might be able to identify this as a bug / Problem to fix in your next release :P


  • Senior Developer

    Specifically I try to keep things as functional as I can, but currently I’m trying to iron out some pretty major performance issues. This relates to database calls and such.

    Because of this, these few releases may be unstable. I’d recommend, for the time being, reverting back to 2996 (right before my major delve into the performance stuff happened.)

    To upgrade back to an older rev, in the folder where you downloaded the trunk you’ll run:

    [code]svn up -r <rev# here>[/code]

    Then run the installfog.sh like normal.


  • Developer

    reminder: the svn trunk is the developer’s work in progress, not a stable release


  • Testers

    Sorry think you might need to have a little info. :(
    Ubuntu 14.10 X64 (updated as of 2/17/15
    Fog 3017 SVN.

    Here is a partial from the log.>
    fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 265
    [Thu Feb 19 09:36:24.661608 2015] [:error] [pid 3905] [client 172.31.178.38:61066] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 265
    [Thu Feb 19 09:36:24.661619 2015] [:error] [pid 3905] [client 172.31.178.38:61066] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 265
    [Thu Feb 19 09:36:24.661841 2015] [:error] [pid 3905] [client 172.31.178.38:61066] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 265
    [Thu Feb 19 09:36:24.661851 2015] [:error] [pid 3905] [client 172.31.178.38:61066] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 265
    [Thu Feb 19 09:36:24.662074 2015] [:error] [pid 3905] [client 172.31.178.38:61066] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 265
    [Thu Feb 19 09:36:24.662085 2015] [:error] [pid 3905] [client 172.31.178.38:61066] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 265
    [Thu Feb 19 09:37:01.204257 2015] [:error] [pid 4333] [client 172.31.179.43:1373] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47

    [Thu Feb 19 09:52:01.679127 2015] [:error] [pid 5091] [client 172.31.179.43:1489] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 09:52:31.536605 2015] [core:notice] [pid 2165] AH00051: child pid 5105 exit signal Segmentation fault (11), possible coredump in /etc/apache2
    [Thu Feb 19 09:53:01.705707 2015] [:error] [pid 5108] [client 172.31.179.43:1493] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 09:54:01.740935 2015] [:error] [pid 5202] [client 172.31.179.43:1497] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 09:55:01.772545 2015] [:error] [pid 5107] [client 172.31.179.43:1500] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 09:56:01.831853 2015] [:error] [pid 5303] [client 172.31.179.43:1504] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 09:57:01.858103 2015] [:error] [pid 5359] [client 172.31.179.43:1508] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 09:58:01.920265 2015] [:error] [pid 5459] [client 172.31.179.43:1511] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 09:59:01.947542 2015] [:error] [pid 5446] [client 172.31.179.43:1515] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 10:00:01.970845 2015] [:error] [pid 5486] [client 172.31.179.43:1518] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 10:01:02.009458 2015] [:error] [pid 5601] [client 172.31.179.43:1521] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 10:02:02.041843 2015] [:error] [pid 5642] [client 172.31.179.43:1531] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 10:03:02.067615 2015] [:error] [pid 5592] [client 172.31.179.43:1534] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 10:04:02.095440 2015] [:error] [pid 5648] [client 172.31.179.43:1538] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 10:05:02.154820 2015] [:error] [pid 5646] [client 172.31.179.43:1556] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 10:06:02.526863 2015] [:error] [pid 5845] [client 172.31.179.43:1560] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 10:07:02.563279 2015] [:error] [pid 5909] [client 172.31.179.43:1564] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 10:08:02.588941 2015] [:error] [pid 5851] [client 172.31.179.43:1567] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47
    [Thu Feb 19 10:08:17.798297 2015] [core:notice] [pid 2165] AH00051: child pid 5902 exit signal Segmentation fault (11), possible coredump in /etc/apache2
    [Thu Feb 19 10:09:02.620312 2015] [:error] [pid 5956] [client 172.31.179.43:1571] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/service/servicemodule-active.php on line 47

    [url="/_imported_xf_attachments/1/1696_error.txt?:"]error.txt[/url]


  • Testers

    Do we have any updates to this or am I the only one who is suffering here :P
    I rebooted our server and still not able to change service settings options.


  • Testers

    ok maybe its just me but I have updated to the latest SVN 3017 and I can no longer select all of the services or an individual one for that matter to activate services on the remote device. it checks the box I click update and then its blank again. change does not stay.
    Ideas?



  • Hi Tom :rolleyes:, I know u hear this a million times, but much appreciated. For all the hard work and time u put into this project week in, and week out.


  • Senior Developer

    SVN 2996 released.

    I know I’ve worked on a lot of stuff this weekend. Believe me it’s not been fun for me.

    I’m trying to figure out performance issues. I mean 2k + hosts or items on a db is really not that strenuous of an activity for either PHP or SQL, but I’m starting (I think) to narrow in on it.

    I’ve removed the ability (for now) to set the host image from the group menu as it takes an extremely long time to load. I will figure out how to re-add it, but for now it’s one of the biggest performance hits especially if you have a group with all your hosts.

    Hopefully you’ll all notice the improvements. Especially those of you with lots and lots of rows.



  • Sud,

    Tom took care of me and fixed it. Fix should be in 2981 release that was just pushed.
    Thanks for your help anyways.
    Ray Z



  • You could roll back to an earlier known-good SVN in the meantime.



  • Tom,

    What’s the 411 bro? I have a bunch of stuff that needs to get imaged.



  • Tom,

    No just a single storage unit on the server. Im running 2980 right now with no luck.


  • Senior Developer

    Ray,

    Do you have multiple storage nodes?

    Are you updated at least to 2979 for all (2974 - 2978 had unforseen issues)



  • Just loaded 2980 … sill same issues.



  • Same here . This is what im still getting .

    I have a bunch of machines to image to. The server is about to get a baseball bat through It lol !

    [url="/_imported_xf_attachments/1/1653_20150205_133550.jpg?:"]20150205_133550.jpg[/url]



  • We have our own DHCP server that is separate from FOG. I’m using undionly.kkpxe.



  • James what are you using for DHCP and are you using undionly.kpxe ?


Log in to reply
 

370
Online

6.2k
Users

13.5k
Topics

127.5k
Posts