Latest Development FOG


  • This can actually be updated with the new default.ipxe script, I don’t have access to it ATM, though…

    Simply hand out that 32-bit ipxe.efi bootfile via DHCP and that should do the trick.


  • [quote=“Ray Zuchowski, post: 39508, member: 24449”]Tom,

    Just tried imaging one of the Dell Venu Pro 11 5130 and tried all the .efi files and none of them work. Any suggestions ?[/quote]

    Go here: [url]https://rom-o-matic.eu/[/url]

    Click Advanced, at the bottom choose “EFI PXE Bootstrap 32-bit (.efi)”

    These are the options I always check:

    [SIZE=12px][FONT=Arial][COLOR=#000000]CPUID_SETTINGS[/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Arial][COLOR=#000000]DOWNLOAD_PROTO_NFS[/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Arial][COLOR=#000000]IMAGE_PNG[/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Arial][COLOR=#000000]PARAM_CMD[/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Arial][COLOR=#000000]CONSOLE_CMD[/COLOR][/FONT][/SIZE]

    Finally, plop this script in the iPXE script box (remember to change the last line to match your FOG server’s IP or hostname:
    (the colour and cpair lines are optional, I use these for my menu colors. Simply remove them if desired.)

    #!ipxe

    colour --basic 2 7
    cpair --foreground 7 --background 9 1
    cpair --foreground 0 --background 9 2
    dhcp
    set arch i386 ||
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain [URL=‘http://x.x.x.x/fog/service/ipxe/boot.php##params’][COLOR=#737373]http://x.x.x.x/fog/service/ipxe/boot.php##params[/COLOR][/URL]

    Note: With the 32-bit tablets I UEFI PXE boot with, I have to manually set the arch to i386 in this script because they are technically 64-bit capable and FOG detects this and gives them bzImage/init.xz, but they only work with bzImage32/init_32.xz.

  • Senior Developer

    I don’t know.

    I don’t have any pure UEFI systems, so I don’t know what to do. I’m sorry. I’m a failure 😞


  • The bios on the computers are set in UEFI they cant be set to legacy. All I did to make it work was switch the boofiles on the dhcp server, am I suppose to do something else ?

  • Senior Developer

    I don’t know how it’s trying to boot. If you’re in uefi mode but legacy net boot I don’t think the efi files will work.


  • Tom,

    Just tried imaging one of the Dell Venu Pro 11 5130 and tried all the .efi files and none of them work. Any suggestions ?

  • Senior Developer

    It currently does nothing. Nothing at all. it’s purpose was going to be simply for knowing (kind of) what file you were using. It actually had no impact to what’s actually being setup on the system.


  • Tom,

    I want to start trying to image my Dell Venu Pro 11 Tablets they are the 5130 model and only support UEFI. In Fog under settings, do I have to change under TFTP Server the FOG_DHCP_BOOFILENAME as well to the ipxe.efi or is that setting only if you are using FOG for DHCP server? Im using my Windows Server as the DHCP client.

  • Senior Developer

    SVN 2726 released.

    With this comes many fixes particularly in the Report’s arena. @Ray, @Robin, and @UpACreek, I’m sorry. I didn’t think it was something I did as I was unable to replicate the issue. However, with three people reporting the same problem, I went on a limb and found the cause was my clearing the buffer of data before it could actually write the data to the selected component. My system was fine because I don’t know. But removing this clearing the ob buffer seems to have corrected the downloading of files.

    It also brings more, appropriately, fixes to the Hosts and Users report in that it will do it’s own filtering for names and hosts rather than expecting the relevant host to do all it’s own filtering. While the fundamental principles would still work, altering based on the host field was actually breaking the login history of the host management (where it displays Login vs. Logout times).

    Many many other improvements in no longer using ajax files separately (just call the related class) and no longer needing the phpimages folder. You may notice things are much faster.

  • Senior Developer


  • Confirmed, reports are OK now using SVN 2725. I was seeing the same problem as Ray when I tested earlier.

    Cheers
    Robin

  • Senior Developer

    Reports should be fixed now. This includes huge databases and saving.


  • No I cant save the file at all.

  • Senior Developer

    Right,

    Regardless, this is not an issue with the exporting of items. It’s how your browsers are attempting to save the data and/or how your browsers are trying to open the file.

    Are you able to at least save the file?


  • Tom,

    I just tried exporting on the latest svn and tried it on 2 different computers with all 3 browsers and I am still getting that error.

    Mozilla, Chrome, and IE 11.

  • Senior Developer

    I don’t know what that word means. What is this thing you call “sleep”? 🙂


  • Excellent work Tom, I can see that I will personally find this very useful.

    Just one question - do you ever sleep ? 😉

  • Senior Developer

    [quote=“Ray Zuchowski, post: 39356, member: 24449”]11[/quote]

    Ray, the message you’re seeing is specific to your environment. This is not some issue with FOG, which is why we’re trying to help you by reporting the issue by simply stating browser. While it’s not necessarily only browser, it could be as simple as the fact you’re requesting to open the file directly and MS Office can’t do it on a “part” file?

  • Senior Developer

    SVN 2707 released.

    With this comes improvements in building the Reports, especially in dealing with large table sets as you may have seen in another forum.

    Also comes some simpler mechanisms in jquery/javascript. I may work towards a complete rewrite down the road, but for now I’m just cleaning them up and adding functionality where I think it’s kind of been needed.

    For example, on the task management page, it keeps updating the number of active tasks (as expected) but it does so on any page dealing with the Tasks including places where you may not want this to happen (search to name one instance I can imagine). This is now corrected for. I’m able to pull in get variables (the stuff in the url) so I can test if we’re on a page we want updates or not.


  • 11

256
Online

8.1k
Users

15.0k
Topics

141.4k
Posts