Host won't boot in PXE



  • I’m new to FOG, just installed it today. Correct me if I’m wrong, but my understanding is that I need to boot the computer I wish to use as a host in PXE, register it for client use, then log in to my server and create an image and a host, and assign that image to the host, then log in to my server on another computer and begin to upload the image. I have a couple problems.

    1. The computer I am using as a test host will not boot into PXE. I have enabled 66 and 67 on the DHCP server, FOG is not running as a DHCP server, I have upgraded the BIOS, and I have PXE set as the first boot option. When I try booting, it returns nothing for TFTP and hangs on DHCP for a while. It then exits PXE and boots Windows.
    2. When attempting to upload my image, it hangs in queue and goes nowhere, but I think that’s due to number 1.

    Thanks in advance for any help you can provide!



  • @Bronzli, post: 28203, member: 24373 said:

    Hello,
    I’ve just upgrade my fog server to 1.0.1 and have problème to boot the host under pxe!!!
    few informations :
    ubuntu 12.04 ; fog 1.0.1
    service tftpd-hpa running
    my fog config.php :

    I run Fog under the same version of Ubuntu as you and in the past I have had PXE boot issues. I don’t remember exactly what all the symptoms were, but over time I have come up with this two line script and I just run this every time, first thing, after I reboot the Fog server… since I started this practice…never had any problems again:

    sudo this file

    start isc-dhcp-server
    restart tftpd-hpa


  • Senior Developer

    @Bronzli, post: 28203, member: 24373 said:

    Hello,
    I’ve just upgrade my fog server to 1.0.1 and have problème to boot the host under pxe!!!
    few informations :
    ubuntu 12.04 ; fog 1.0.1
    service tftpd-hpa running
    my fog config.php :
    define( “UDPSENDERPATH”, “/usr/local/sbin/udp-sender” );
    define( “MULTICASTLOGPATH”, “/opt/fog/log/multicast.log” );
    define( “MULTICASTDEVICEOUTPUT”, “/dev/tty2” );
    define( “MULTICASTSLEEPTIME”, 10 );
    define( “MULTICASTINTERFACE”, “eth2” );
    define( “UDPSENDER_MAXWAIT”, null );
    define( “LOGMAXSIZE”, “1000000” );

    define( “REPLICATORLOGPATH”, “/opt/fog/log/fogreplicator.log” );
    define( “REPLICATORDEVICEOUTPUT”, “/dev/tty3” );
    define( “REPLICATORSLEEPTIME”, 600 );
    define( “REPLICATORIFCONFIG”, “/sbin/ifconfig” );

    define( “SCHEDULERLOGPATH”, “/opt/fog/log/fogscheduler.log” );
    define( “SCHEDULERDEVICEOUTPUT”, “/dev/tty4” );
    define( “SCHEDULERSLEEPTIME”, 60 );

    define(‘TFTP_HOST’, “172.16.192.5”);
    define(‘TFTP_FTP_USERNAME’, “fog”);
    define(‘TFTP_FTP_PASSWORD’, “password”);
    define(‘TFTP_PXE_KERNEL_DIR’, ‘/var/www/fog/service/ipxe/’);
    define(‘PXE_KERNEL’, ‘bzImage’);
    define(‘PXE_KERNEL_RAMDISK’,127000);
    define(‘USE_SLOPPY_NAME_LOOKUPS’,true);
    define(‘MEMTEST_KERNEL’, ‘memtest.bin’);
    define(‘PXE_IMAGE’, ‘init.xz’);
    define(‘PXE_IMAGE_DNSADDRESS’, “”);
    define(‘STORAGE_HOST’, “172.16.192.5”);
    define(‘STORAGE_FTP_USERNAME’, “fog”);
    define(‘STORAGE_FTP_PASSWORD’, “password”);
    define(‘STORAGE_DATADIR’, ‘/images/’);
    define(‘STORAGE_DATADIR_UPLOAD’, ‘/images/dev/’);
    define(‘STORAGE_BANDWIDTHPATH’, ‘/fog/status/bandwidth.php’);
    define(‘UPLOADRESIZEPCT’,5);
    define(‘WEB_HOST’, “172.16.192.5”);
    define(‘WOL_HOST’, “172.16.192.5”);
    define(‘WOL_PATH’, ‘/fog/wol/wol.php’);
    define(‘WOL_INTERFACE’, “eth2”);
    define(‘SNAPINDIR’, “/opt/fog/snapins/”);
    define(‘QUEUESIZE’, ‘10’);
    define(‘CHECKIN_TIMEOUT’,600);
    define(‘USER_MINPASSLENGTH’,4);
    define(‘USER_VALIDPASSCHARS’, ‘1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklmnopqrstuvwxyz_()^!#-’);
    define(‘NFS_ETH_MONITOR’, “eth2”);
    define(‘UDPCAST_INTERFACE’, “eth2”);
    define(‘UDPCAST_STARTINGPORT’, 63100 );
    define(‘FOG_MULTICAST_MAX_SESSIONS’,64);
    define(‘FOG_JPGRAPH_VERSION’, ‘2.3’);
    define(‘FOG_REPORT_DIR’, ‘./reports/’);
    define(‘FOG_UPLOADIGNOREPAGEHIBER’,true);
    define(‘FOG_DONATE_MINING’, “0”);
    ?>
    My tftpd-hpa file :

    /etc/default/tftpd-hpa

    FOG Modified version

    TFTP_USERNAME=“fog"
    TFTP_DIRECTORY=”/tftpboot"
    TFTP_ADDRESS=“172.16.192.5:69"
    TFTP_OPTIONS=”-s"

    My tftpboot directory:
    ~fog:/tftpboot$ ls -la
    total 860
    drwxr-xr-x 3 fog root 4096 mai 26 15:54 .
    drwxr-xr-x 26 root root 4096 mai 26 15:54 …
    -rw-r–r-- 1 fog root 840 mai 26 15:54 boot.txt
    -rw-r–r-- 1 root root 167 mai 26 15:54 default.ipxe
    -rw-r–r-- 1 fog root 391231 mai 26 15:54 ipxe.krn
    -rw-r–r-- 1 fog root 25340 mai 26 15:54 memdisk
    -rw-r–r-- 1 fog root 16794 mai 26 15:54 pxelinux.0.old
    -rw-r–r-- 1 fog root 165088 mai 26 15:54 snponly.efi
    drwxr-xr-x 2 fog root 4096 mai 26 15:54 tftpboot
    -rw-r–r-- 1 fog root 95522 mai 26 15:54 undionly.kpxe
    -rw-r–r-- 1 fog root 147728 mai 26 15:54 vesamenu.c32

    And an extract of my dhcpd3.conf: (ubuntu server) :
    next-server 172.16.192.5;
    filename “undionly.kpxe”;

    The message error :
    PXE-T01 : File not Found
    PXE-E3B : TFTP error - File Not Found

    Thank you for your help…

    Check that your tftp server isn’t being blocked by firewall:

    sudo ufw disable
    


  • Hello,
    I’ve just upgrade my fog server to 1.0.1 and have problème to boot the host under pxe!!!
    few informations :
    ubuntu 12.04 ; fog 1.0.1
    service tftpd-hpa running
    my fog config.php :
    define( “UDPSENDERPATH”, “/usr/local/sbin/udp-sender” );
    define( “MULTICASTLOGPATH”, “/opt/fog/log/multicast.log” );
    define( “MULTICASTDEVICEOUTPUT”, “/dev/tty2” );
    define( “MULTICASTSLEEPTIME”, 10 );
    define( “MULTICASTINTERFACE”, “eth2” );
    define( “UDPSENDER_MAXWAIT”, null );
    define( “LOGMAXSIZE”, “1000000” );

    define( “REPLICATORLOGPATH”, “/opt/fog/log/fogreplicator.log” );
    define( “REPLICATORDEVICEOUTPUT”, “/dev/tty3” );
    define( “REPLICATORSLEEPTIME”, 600 );
    define( “REPLICATORIFCONFIG”, “/sbin/ifconfig” );

    define( “SCHEDULERLOGPATH”, “/opt/fog/log/fogscheduler.log” );
    define( “SCHEDULERDEVICEOUTPUT”, “/dev/tty4” );
    define( “SCHEDULERSLEEPTIME”, 60 );

    define(‘TFTP_HOST’, “172.16.192.5”);
    define(‘TFTP_FTP_USERNAME’, “fog”);
    define(‘TFTP_FTP_PASSWORD’, “password”);
    define(‘TFTP_PXE_KERNEL_DIR’, ‘/var/www/fog/service/ipxe/’);
    define(‘PXE_KERNEL’, ‘bzImage’);
    define(‘PXE_KERNEL_RAMDISK’,127000);
    define(‘USE_SLOPPY_NAME_LOOKUPS’,true);
    define(‘MEMTEST_KERNEL’, ‘memtest.bin’);
    define(‘PXE_IMAGE’, ‘init.xz’);
    define(‘PXE_IMAGE_DNSADDRESS’, “”);
    define(‘STORAGE_HOST’, “172.16.192.5”);
    define(‘STORAGE_FTP_USERNAME’, “fog”);
    define(‘STORAGE_FTP_PASSWORD’, “password”);
    define(‘STORAGE_DATADIR’, ‘/images/’);
    define(‘STORAGE_DATADIR_UPLOAD’, ‘/images/dev/’);
    define(‘STORAGE_BANDWIDTHPATH’, ‘/fog/status/bandwidth.php’);
    define(‘UPLOADRESIZEPCT’,5);
    define(‘WEB_HOST’, “172.16.192.5”);
    define(‘WOL_HOST’, “172.16.192.5”);
    define(‘WOL_PATH’, ‘/fog/wol/wol.php’);
    define(‘WOL_INTERFACE’, “eth2”);
    define(‘SNAPINDIR’, “/opt/fog/snapins/”);
    define(‘QUEUESIZE’, ‘10’);
    define(‘CHECKIN_TIMEOUT’,600);
    define(‘USER_MINPASSLENGTH’,4);
    define(‘USER_VALIDPASSCHARS’, ‘1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklmnopqrstuvwxyz_()^!#-’);
    define(‘NFS_ETH_MONITOR’, “eth2”);
    define(‘UDPCAST_INTERFACE’, “eth2”);
    define(‘UDPCAST_STARTINGPORT’, 63100 );
    define(‘FOG_MULTICAST_MAX_SESSIONS’,64);
    define(‘FOG_JPGRAPH_VERSION’, ‘2.3’);
    define(‘FOG_REPORT_DIR’, ‘./reports/’);
    define(‘FOG_UPLOADIGNOREPAGEHIBER’,true);
    define(‘FOG_DONATE_MINING’, “0”);
    ?>
    My tftpd-hpa file :

    /etc/default/tftpd-hpa

    FOG Modified version

    TFTP_USERNAME=“fog"
    TFTP_DIRECTORY=”/tftpboot"
    TFTP_ADDRESS=“172.16.192.5:69"
    TFTP_OPTIONS=”-s"

    My tftpboot directory:
    ~fog:/tftpboot$ ls -la
    total 860
    drwxr-xr-x 3 fog root 4096 mai 26 15:54 .
    drwxr-xr-x 26 root root 4096 mai 26 15:54 …
    -rw-r–r-- 1 fog root 840 mai 26 15:54 boot.txt
    -rw-r–r-- 1 root root 167 mai 26 15:54 default.ipxe
    -rw-r–r-- 1 fog root 391231 mai 26 15:54 ipxe.krn
    -rw-r–r-- 1 fog root 25340 mai 26 15:54 memdisk
    -rw-r–r-- 1 fog root 16794 mai 26 15:54 pxelinux.0.old
    -rw-r–r-- 1 fog root 165088 mai 26 15:54 snponly.efi
    drwxr-xr-x 2 fog root 4096 mai 26 15:54 tftpboot
    -rw-r–r-- 1 fog root 95522 mai 26 15:54 undionly.kpxe
    -rw-r–r-- 1 fog root 147728 mai 26 15:54 vesamenu.c32

    And an extract of my dhcpd3.conf: (ubuntu server) :
    next-server 172.16.192.5;
    filename “undionly.kpxe”;

    The message error :
    PXE-T01 : File not Found
    PXE-E3B : TFTP error - File Not Found

    Thank you for your help…


  • Senior Developer

    On the fog server, try running the command:

    sudo service tftpd-hpa restart
    

    Have you disabled the firewall on your fog server:

    sudo ufw stop
    sudo ufw disable
    


  • I just updated the password on the management front end, and I’ll see where that takes me. It seems every computer I try to boot into I get a different PXE error…


  • Developer

    is your tftp service running on the server?



  • I am getting an IP returned from DHCP, but not from TFTP. It will run DHCP for a while, then TFTP for a short period of time and returns PXE-M0F and then boots Windows. I ran the command
    [CENTER]tftp 172.16.0.35 get unidonly.kpxe[/CENTER]
    [LEFT]and it returns “Timeout occurred Connect request failed” I don’t know where to go now, short of re-installing FOG in hopes that I didn’t miss something.[/LEFT]



  • http://fogproject.org/wiki/index.php/FAQHere is my Apache log. I think the important thing here is about half way down (line 16):
    "

    • %(#000000]ls)[
    • ls: cannot access /images/testestest: No such file or directory]
    • %(#000000]ls)[
    • ls: cannot access /images/testimg2: No such file or directory]
    • %(#000000]ls)[
    • ls: cannot access /images/testestest: No such file or directory]
    • %(#000000]ls)[
    • ls: cannot access /images/testimg2: No such file or directory]
    • %(#000000]ls)[
    • ls: cannot access /images/testestest: No such file or directory]
    • %(#000000]ls)[
    • ls: cannot access /images/testimg2: No such file or directory]

    "


  • Developer

    Blatantly copied from Tom’s signature:

    Basics: Please provide:
    FOG Version (e.g. FOG 0.32, FOG 0.33, FOG 0.01)
    OS Version (e.g. CentOS 6.5, Ubuntu 12.04, Redhat 6.5)

    Have you checked your apache error logs? Can you provide information from these logs?
    Debian based Location (normally)
    /var/log/apache2/error.log
    Redhat based Location (normally)
    /var/log/httpd/error_log

    Have you searched the forums for your issue yet?
    Have you checked the wiki yet?
    Kernel Issues: http://fogproject.org/wiki/index.php/FAQ


Log in to reply
 

325
Online

38727
Users

10554
Topics

99920
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.