PXE3B: TFTP error - flie not found



  • This is my first time installing FOG. I have a Lenovo 3000 GS530 laptop being used as my server running Ubuntu 14.04 with FOG 1.0.1 installed. I have another Lenovo 3000 GS530being used as a Client. I have enabled options 66 and 67 on the DHCP server.

    I get an error every time the Client boots that reads the following:

    PXE1 - file not found
    PXE3B - tftp error - file not found

    Then the computer boots to windows. What is going on? Help please.



  • Nevermind, went and found it in another thread. I’ll move my responses there.



  • Do you have any instructions on how to include that?


  • Senior Developer

    [quote=“Bob Martens, post: 27811, member: 24323”]Well, what you gave me fixed that issue, but now I have machines that will get stuck initializing PXE at boot. When I switch it back to our old server (on the DHCP server that is) then they work just fine.

    I’ll keep investigating.[/quote]

    THere is a known issue with some systems, and we’re trying track down the culprit and/or figure out what will fix it.

    If you’re having problems with this, you can try the included undionly.kpxe.INTEL from the svn repo’s.



  • Well, what you gave me fixed that issue, but now I have machines that will get stuck initializing PXE at boot. When I switch it back to our old server (on the DHCP server that is) then they work just fine.

    I’ll keep investigating.



  • That might explain it. I’ll try it tomorrow and report back. Thanks!


  • Senior Developer

    FOG 0.33 and up use undionly.kpxe
    FOG 0.32 and below used pxelinux.0



  • What is the file name without me making any changes?


  • Senior Developer

    [quote=“Bob Martens, post: 27755, member: 24323”]I’m getting this same issue. Can someone describe or give me some more guidance on the 66/67 thing? Thanks![/quote]

    Options 66 and Option 67 are specific for Windows DHCP really, but the intent is more or less the same.

    Option 66 is the IP Address of the FOG Server (or wherever you’re trying to boot from)

    Option 67 is the filename on the FOG Server (or whatever the file is)

    On linux dhcp server the Option 67 is really just the point to the file also known as next-server.

    Hopefully this helps.



  • I’m getting this same issue. Can someone describe or give me some more guidance on the 66/67 thing? Thanks!



  • thats my bad i forgot i manually set my subnet and now its working i set it on the global setting and for got when i first rolled out fog that it was on manually set there its booting now now to test and see if my imaging still works



  • [quote=“Junkhacker, post: 27742, member: 21583”]if it is set to undionly.kxpe, that’s your problem. it should be undionly.kpxe[/quote]
    Sorry it is set to undionly.kpxe that was a typeo with the kxpe


  • Developer

    if it is set to undionly.kxpe, that’s your problem. it should be undionly.kpxe



  • I’m getting the same issue and i have my dhcp set to undionly.kxpe



  • It was. 67 should have been to a different file undionly.kxpe not pxelinux.0


  • Developer

    this sounds to me like either the DHCP options 66 or 67 are set incorrectly, or the tftp service on the fog server is not running.
    your options should be set to your fog server’s ip, and undionly.kpxe


Log in to reply
 

437
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.