Change TFTP Password



  • I have installed Fog 1.0.1 on Ubuntu 14.04 Server. Everything is working fine however once client machines finished it’s Imaging Process (making an image) I started getting an error about the FOGFTP Login Error. it was trying to logon to the correct machine (IP Address) with the correct User Name (fog) but the wrong password (RANDOMPASS) I changed the Password in the /var/www/fog/commons/config.php and the WedGUI > Fog Settings. Restarted the process and again it came back with this error at the end of the process. I restarted the TFTP service and still no change. I have to change the local user “fog” password on the server for it to work. I would like to have my (More Complicated) password rather then the six character one created.

    Any Thoughts?



  • I missed the Banner in my haste. The Password was being delivered from the Storage Node. I didn’t think to look there. Makes sense on a large scale operation. Thank you for the help Junkhacker. By the way your avatar looks so angry. Makes me read all your responses like your angry and grumbling or scolding people… brilliant.


  • Developer

    the imaging process does not use the tftp service. the tftp service provides the pxe boot configuration, and that is all. you need to check the ftp service. that password stored in /commons/config.php is not used anymore in 1.0+ versions of fog, and is right under a banner stating as much. if you changed the password in the webgui, you also need to change the password of the fog user. yes, the password in the webgui must match the password set for the user “fog” for both the [FONT=arial][COLOR=#262626]FOG_TFTP_FTP_PASSWORD in fog settings, and [/COLOR][/FONT][FONT=arial][COLOR=#262626]The Storage Management -> NODE -> fog password.[/COLOR][/FONT]
    [SIZE=2]is the system [/SIZE]currently[SIZE=2] working for you[/SIZE]


Log in to reply
 

433
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.