Upgrade to 1.0.1 Laptops will not pull image



  • I have upgraded to version 1.0.1 from .32, Running Ubuntu 12.04 Everything came up fine. I went into the images and added the OS parameters. I have tried pushing the image out to a laptop and it does not work. It boots to ipxe says configuring network and then boots to windows. I do not see an error message on the client. The task in fog is still queued and waiting. If I cancel the task I can get the laptop to boot into the ipxe menu and select quick image and enter my credentials. It then creates the job and if I reboot it will act again like it is going to image and then it just boots to windows after saying “configuring network”


  • Developer

    unfortunately, the easiest way to do that would probably be directly in the database. fog database, hosts table, hostKernel column, i think
    (i use phpMyAdmin for these kinds of tasks, but someone better at command line stuff could probably tell you how to do it with a single command)



  • OK figured it out. I had specified a specific kernel on these laptops. with a path of /fog/kernel/kernelname,

    On the old system it was looking in the tftp folder with the change to the var/www folder it was looking there for it. So next question easy way to clear that out on my devices. I tried doing a group change but it won’t make a change without entering a parameter.



  • Yes everything looks correct there. I can’t figure out where it is getting pointed at that directory. It does not exist on my .32 www folder either. looks like anytime it goes to load the kernel it gets this message.


  • Developer

    the setting in the fog web gui under fog configuration>fog settings>settings>tftp server
    "FOG_TFTP_PXE_KERNEL_DIR" for ubuntu 12.04 should be “/var/www/fog/service/ipxe/” and
    "FOG_TFTP_PXE_KERNEL" should be "bzImage"
    have you checked these?



  • OK so looking in my apache2 log, I see an error, "File does not exist: /var/www/fog/kernel


Log in to reply
 

477
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.