Problem with PXE booting using DNSMASQ



  • Good afternoon folks,

    I’ve trying to setup a fog 1.0.1 server on our network, but seem to be having a few problems with the PXE boot (specifically around DHCP options).

    If I boot using the DHCP server build into the FOG box, everything works correctly, however if I try to use our company DHCP server, coupled with the DNSMASQ proxy, I can’t seem to get anywhere - it comes up with cannot start download: operation not supported

    I’ve attached my DHCPd config file which works, and my LTSP.conf file for DNSMASQ which doesn’t work. Can anyone please point me in the right direction whilst I’ve still got hair left to pull out.

    DHCP config
    [CODE]

    DHCP Server Configuration file.

    see /usr/share/doc/dhcp*/dhcpd.conf.sample

    This file was created by FOG

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 10.0.0.15;

    subnet 10.0.0.0 netmask 255.255.255.0 {
    option subnet-mask 255.255.255.0;
    range dynamic-bootp 10.0.0.10 10.0.0.254;
    default-lease-time 21600;
    max-lease-time 43200;
    option domain-name-servers 127.0.0.1;
    option routers 10.0.0.1;
    filename “undionly.kpxe”;
    }
    [/CODE]

    LTSP DNSMASQ config
    [CODE]# Don’t function as a DNS server:
    port=0

    Log lots of extra information about DHCP transactions.

    log-dhcp

    Set the root directory for files available via FTP.

    tftp-root=/tftpboot

    The boot filename, Server name, Server Ip Address

    #dhcp-boot=undionly.kpxe,10.0.0.15
    dhcp-boot=undionly.kpxe

    Disable re-use of the DHCP servername and filename fields as extra

    option space. That’s to avoid confusing some old or broken DHCP clients.

    dhcp-no-override

    PXE menu. The first part is the text displayed to the user. The second is the timeout, in seconds.

    pxe-prompt=“Press F8 for boot menu”, 3

    The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,

    Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI

    This option is first and will be the default if there is no input from the user.

    pxe-service=X86PC, “Boot from network”, undionly

    This range(s) is for the public interface, where dnsmasq functions

    as a proxy DHCP server providing boot information but no IP leases.

    Any ip in the subnet will do, so you may just put your server NIC ip here.

    Since dnsmasq is not providing true DHCP services, you do not want it

    handing out IP addresses. Just put your servers IP address for the interface

    that is connected to the network on which the FOG clients exist.

    If this setting is incorrect, the dnsmasq may not start, rendering

    your proxyDHCP ineffective.

    dhcp-range=10.0.0.1,proxy
    [/CODE]

    Thanks in advance everyone!


  • Developer

    Did you install the DHCP form the install script? If so, rebuild your server NOT using fog as the DHCP server. I can only assume that some settings are clashing.

    If you want to have FOG dole DHCP that is fine but you won’t need DHCP.

    If you want to use DNASMASQ to leave your DHCP setup alone and pxe boot via proxy dhcp, don’t install the dhcp, the two will clash settings.

    We would be willing to help you to troubleshoot your issues, but you need top choose a path and stick to it. I would start by commenting out the line
    "pxe-service=X86PC, “Boot from network”, undionly" some networks don’t need to be told to boot, and some do.

    Are you not able to edit your DHCP settings to include your FOG server and Boot file name?


Log in to reply
 

409
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.