Hostname CHanger not working since moving to 1.0.1



  • I have changed the user name from domain\username just to username, used FOGCrypt for the password. It is not working now since the upgrade…I’m sure i missed something that needed changed but can’t find it. The client is installed and hostname changer is enabled on both ends.



  • Dear FOG-Community,
    Dear Tom,

    I have a big Problem with FOGService/FOGTray. We configured it depending on Service winmgmt and Spooler. Rolled out a testimage without syspreping it and it worked. Even as it didnt started automatically. After Syspreping the FOGService/FOGTray doesnt work anymore. No Hostnamechanger, no Printer attachment, no greenfog and i dont know why…

    What did Sysprep do to the Services? Why does it worked before sysprep?

    Hope you can help me.

    Update:
    All Services work except the HostNameChanger.
    Log says: Index out of Array at FOG.HostNameChanger.changeHostName()

    Greetings

    Andy



  • [quote=“Junkhacker, post: 27815, member: 21583”]that’s what i wanted. that response looks exactly like what i would expect for a computer that does not have the “Join Domain after image task” option checked in “Active Directory” section of "Host Management"
    can you verify that is set, and the information is filled out correctly?[/quote]

    I have disabled that because i cannot let them go on the domain yet with the wrong hostname. Currently we are not putting these new machines on the domain for awhile anyways. I just need the actual hostname changed regardless of the domain setting.

    EDIT: Also if i do set the domain it usually does add to the domain but never changes the hostname either. Usually it will add to the domain as the correct hostname even though the local machine is not set to that.


  • Developer

    that’s what i wanted. that response looks exactly like what i would expect for a computer that does not have the “Join Domain after image task” option checked in “Active Directory” section of "Host Management"
    can you verify that is set, and the information is filled out correctly?



  • [quote=“Junkhacker, post: 27793, member: 21583”]try going to [url]http://<server[/url] IP>/fog/service/hostname.php?mac=<mac address of computer> and tell me what you see[/quote]
    #!ok=GXN-14119 #AD=0 #ADDom= #ADOU= #ADUser=\ #ADPass=#!er: Join domain disabled on this host.

    This is the response from the mac address of the machine i am imaging with my master image, not the master machine which i base the image off of… I figured that is the one you meant, let me know if i was wrong.


  • Developer

    try going to [url]http://<server[/url] IP>/fog/service/hostname.php?mac=<mac address of computer> and tell me what you see



  • I have not added this image to the domain and even after de-activating the firewall on the base image the resulting machine still cannot change its hostname.


  • Developer

    FYI avast has a false positive on FOG Client. You will needed to make an exception for “Program Files” and in All Users “Startup” in windows.

    Windows 7 Avast! Exceptions:
    C:\Program Files\FOG*
    C:\Program Files (x86)\FOG*
    C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup\FOGTray.exe

    Windows 7 Firewall Settings: (run as administrator–>cmd)
    ::Allow Fog Client Thru Firewall
    netsh advfirewall firewall add rule name=“Fog Client” dir=in action=allow program="C:\Program Files\FOG\FOGService.exe"
    netsh advfirewall firewall add rule name=“Fog Service” dir=in action=allow program="C:\Program Files\FOG\FOGServiceConfig.exe"
    netsh advfirewall firewall add rule name=“Fog Tray” dir=in action=allow program=“C:\Program Files\FOG\FOGTray.exe”

    Not sure on the Windows 8 though.



  • Not 100% sure, but I am assuming AVAST was the culprit. If I get some more time I will retry to upload an image with AVAST installed prior to upload and then deploy to be certain, but for now that is my assumption.


  • Developer

    So was it relating to Windows Firewall, Avast, or Windows domain?



  • Old Image: I joined the domain added some domain applications, took off the domain and then uploaded my image. This did not allow me to have FOG automatically join the domain.

    New Image: I rebuilt the image never putting it on the domain, and leaving off Avast and other domain controlled applications, and now the image deploys perfect, changes the host name and connects to the domain automatically.

    Thank you for the updates in 1.01!
    We are off and running and making some images for the summer.



  • [quote=“Junkhacker, post: 27579, member: 21583”]check your fog.log in the c:\ of the client, is it connecting to the server? are there any errors?[/quote]

    That log shows exactly what i would expect it to if the hostname changer had worked… it even says “Hostname is up to date”… yet the hostname is still the same as the base image’s.


  • Developer

    check your fog.log in the c:\ of the client, is it connecting to the server? are there any errors?



  • I have recently done a clean windows 8.1 install and image and the hostname changer is not doing anything. completely stock FOG (latest trunk as of this morning) and stock FOG client, etc. Any news on this issue?

    EDIT: No active directory usage here either.



  • Good thought but no I do not have a custom compiled HostnameChange.dll.

    I’m thinking it has something to do with the way the image was made. I had it on the domain, installed the fog client, took it off the domain and then uploaded it, so I may have caused the issue. I am going to build a fresh 64bit windows 8 image and see if this solves the issue.


  • Developer

    you’ve been using fog for 5 years, right? do you have a custom compiled [FONT=sans-serif][COLOR=#000000]HostnameChange.dll on your images? will this match the passkey used in fogcrypt?[/COLOR][/FONT]



  • Welp, I FOG’d a second image, Windows 8 32bit and deployed it without changing any settings and it automatically joined the domain. So I am going to delete the 64bit host from FOG, perform full host inventory it and redeploy and see what happens. I will keep you posted. There may be something going on with that particular Windows 8 x64bit image.



  • Yes. That screen shot was from the actual host settings in FOG. It is also the default in the FOG active directory section as well.


  • Developer

    One more piece of info needed is the Active Directory settings on that host.

    Host Management --> (the host having issues) --> [URL=‘http://rasdfog.dyndns.org/fog/management/index.php?node=host&sub=edit&id=1#host-active-directory’]Active Directory[/URL]

    IS that info checked and filled out?

    Edit: (facepalm)



  • Yeah, I am really hoping that it might be a Monday detail, but I do think I have both of those correct. Thank you though, it might be that simple with something else I missed.
    [LEFT] [/LEFT]
    [LEFT]Here is the UI config.[/LEFT]
    [LEFT] [/LEFT]
    [CENTER][IMG]http://vanlueschool.org/pictures/snip.png[/IMG][/CENTER]
    [CENTER][IMG]http://vanlueschool.org/pictures/snip2.png[/IMG][/CENTER]


Log in to reply
 

410
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.