'PXE-E32: TFTP Open Timeout' back after 1.0.1 install on Ubuntu 12.04



  • Hi Folks,

    Back in v0.32 is where I first encountered this error and by following the steps below I resolved the issue. Now it’s back after a clean install of v1.01 and I’m not sure why. Here’s what I’ve done so far:

    I followed this [URL=‘http://fogproject.org/wiki/index.php/Unable_to_connect_to_TFTP’]wiki[/URL] and made sure all the passwords in my config.php file matched that of my fog web ui login password. I also applied the same password to the FOG_TFTP_FTP_PASSWORD field in Fog System Settings.

    I’m aware of the tftpd-hpa bug in Ubuntu 12.04 but I confirmed my rc.local file still includes the following line (per this [URL=‘http://fogproject.org/forum/threads/tftp-stops-on-reboot-after-install.488/’]thread[/URL]):

    [CODE]/bin/sleep 30 && /etc/init.d/htftpd-hpa restart[/CODE]

    [U]Luckily manually stopping and starting tftpd-hpa from a terminal prompt DOES fix the problem.[/U] I’d just rather not have to do it manually every time I reboot the server and find it peculiar that what worked for v0.32 isn’t working now that I’m on v1.01.

    Anyone have any suggestions to fix this minor annoyance?

    Thanks in advance for the replies.



  • [quote=“Iulian Constantinescui, post: 27800, member: 24331”]Solved,

    If you do a cleanup install or an upgrade you must change the config/settings in your linux/windows DHCP server.
    On windows DHCP server make sure you put the 66 and 67 option.[/quote]

    My option 66 and 67 settings were correct, otherwise the client wouldn’t have been able to talk to the fog server at all. What solved (and I use that term loosely) the problem was a clean install of Ubuntu 14.04. All is working beautifully now and I don’t need an rc.local edit either.

    Thanks again to everyone that chimed in.



  • Solved,

    If you do a cleanup install or an upgrade you must change the config/settings in your linux/windows DHCP server.
    On windows DHCP server make sure you put the 66 and 67 option.


  • Senior Developer

    [quote=“Magnus_CA, post: 27250, member: 22139”]No, I caught the error. My syntax is correct.[/quote]

    Okay, well, why it’s not working I don’t know. It’s unlikely to be an issue with FOG. I’d be surprised, as you describe, that if you were to reinstall FOG 0.32, if all of a sudden everything just started working. Another option, though small as it may be, may be to look into the /etc/init.d/tftpd-hpa file and see if something seems screwed up.



  • [quote=“Tom Elliott, post: 27249, member: 7271”][code]/bin/sleep 30 && /etc/init.d/htftpd-hpa restart[/code] Is that what’s really in your rc.local?

    Try:
    [code]/bin/sleep 30 && /etc/init.d/tftpd-hpa restart[/code][/quote]

    No, I caught the error. My syntax is correct.


  • Senior Developer

    [code]/bin/sleep 30 && /etc/init.d/htftpd-hpa restart[/code] Is that what’s really in your rc.local?

    Try:
    [code]/bin/sleep 30 && /etc/init.d/tftpd-hpa restart[/code]



  • Tom,

    Thanks for the reply. That command does work for me to get the TFTP server going. And there is a known bug with TFTP in 12.04…I’m just not sure why the rc.local hack worked with 0.32 isn’t working with 1.0.1.


  • Senior Developer

    upstart commands within rc.local are beyond me.


  • Senior Developer

    try:
    [code]sudo restart tftpd-hpa[/code]

    Ubuntu uses upstart, if that’s not working running:
    [code]sudo service tftpd-hpa restart[/code] should do the trick.



  • Again, if I manually stop and start the TFTP service I’m able to access undionly.kxpe, whether it be via PXE boot or windows command line.

    If I decide to go through the trouble to re-install Ubuntu (a very windows-esque fix, lol) do you recommend 14.04?


  • Developer

    [quote=“Magnus_CA, post: 27228, member: 22139”]Thanks Jaymes.

    [SIZE=13px][FONT=Tahoma][COLOR=#141414]I’m not sure if this is progress but now I’m getting a ‘PXE-E11: ARP TIMEOUT’ error after applying your change to the tftpd-hpa.conf file.[/COLOR][/FONT][/SIZE][/quote][SIZE=13px][FONT=Tahoma][COLOR=#141414][/COLOR][/FONT][/SIZE]

    Run a test command from a windows machine, if it is windows 7 you need to enable the TFTP client option in the Add or Remove programs or features.

    where x.x.x.x is the ip address of your server:
    [code]
    tftp x.x.x.x get unidonly.kpxe[/code]

    If the command completes successfully, then TFTP is running.

    If you continue to experience tftp issues, I recommend a full rebuild, that TFTP service shouldn’t be having issues, it is a core component included for linux installation and I am not aware of any recent bugs that cause it to stop on it’s own.



  • Thanks Jaymes.

    I’m not sure if this is progress but now I’m getting a ‘PXE-E11: ARP TIMEOUT’ error after applying your change to the tftpd-hpa.conf file.


  • Developer

    Change the line
    [code]start on runlevel [2345][/code]

    in /etc/init/tftpd-hpa.conf to

    [code]start on (local-filesystems and net-device-up IFACE!=lo)[/code]


Log in to reply
 

425
Online

38969
Users

10712
Topics

101664
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.