TFTP PXE boot timing issue Could not start download: Operation not supported

  • Installed the latest FOG 1.0.1 on Ubuntu 14.02 LTS using all the defaults advised. When we PXE boot to inventory a computer, we get an error: [B]Could[/B][B] not start download: Operation not [/B][B]supported[/B]

    If I pause at the point where it shows:[B] iPXE 1.0.0+(d28b) – Open Source Network Boot Firmware – Features: NFS HTTP HTTPS iSCSI DNS TFTP AoE bzImage ELF NBOOT PXE PXEXT Menu Configuring (net0 [I]my MAC address[/I])… [/B]then escape; I see the ‘FOG PXE menu’ as expected…

    This implies a timing issue. We have experienced this on several platforms, and despite not seeing anyone on here complaining of this, wonder if there might be a bug, or a TFTP setting that needs to be changed?

    Any help appreciated as this has caused as a considerable amount of wasted time. We didn’t have this problem on previous versions of FOG. Those version worked ‘out of the box’ with minimal changes.

    Many thanks in advance.

  • We continue to face hurdles, but 12.04 with FOG 0.32, grub (not grub2) seem to work with DL360e Gen8, although we now have to figure out how to avoid eth0 disappearing after cloning.

  • Interestingly, we tried to use our setup to image a VM and we get the same error as the OP.

    Due to time constraints, we are going to retrograde to 0.32 (on another server hosting[COLOR=black]FOG[/COLOR]), but format the node to be cloned with Ext3… and hope that works OK!

    Nevertheless, thank you for your effort in this.

  • Sadly, ipxe.kpxe or ipxe.kkpxe haven’t fixed the issue, so I’m relying on my ‘pause’ method for the moment. Using ipxe.kkpxe renamed to undionly.kpxe caused a red screen of death with an illegal upload message.

  • Senior Developer

  • Just an update to explain that this hasn’t fixed the issue, and I still have the same error. This wasn’t an issue with 0.32 and the same hardware.


  • Developer

    thank you for your bug report. we now believe we have a fix.

  • Thanks for posting Tom.

  • Senior Developer

    I’m going to be taking a look at the source code for how it goes into configuring and seeing if I can make a pause of about 3 seconds to hopefully “fix” the timing issue being reported. We know it’s a timing issue, but I’m not in charge of the ipxe source code. If this delay fixes it, maybe I can post it to somebody who’s willing to commit the change into the official source.

  • Thanks for that, but we are using the FOG server as the DHCP, but this isn’t our problem; if I pause the screen for a moment, it all works OK.

  • This fixed my problem: Option 67 should be pointing at: undionly.kpxe

  • Yes, this is so frustrating. 0.32 was easy, but this has cost me many hours now, and I only found it by chance. I tried to pause the screen to see the error, and when I escaped I saw the PXE menu.

    I think I’m going to have to use an alternative solution, my Linux skills are clearly not up to scratch. Life is too short. 😞

  • I am having the same problem. Ever since I updated to 1.0.1 I have not been able to boot. I get the error e3b.

  • This post is deleted!