Fog Storage Node "Failed to connect to database server" durring replication



  • I’m trying to setup a fog storage node for the first time. Using fog .32. I have two ubuntu machines running. One is the main fog server the other is the storage node. I followed the [URL=‘http://youtu.be/X72WthDGwsw’]this youtube video[/URL]. When I run [I]“watch tail fogreplicator.log”[/I] from the MAIN FOG server I see the following over and over:[I] “Failed to connect to database server, will try again in next iteration.”[/I]



  • [quote=“ID10Tea, post: 3548, member: 1040”]I have the same problem when I try to open FOGImageReplicator I get an error. " The folder contents could not be displayed. You do not have the permissions necessary to view the contents of “FOGImageReplicator”"[/quote]
    Where in the file should I put this information?
    Thanks


  • Moderator

    [quote=“darthanubis, post: 5212, member: 1659”]I see and can edit the file, but no one mentions where in the file the text is located or what it looks like to be edited?[/quote]

    FOG version 0.32, edit the /opt/fog/service/etc/config.php on the [B]STORAGE[/B] node. The mysql username and password will be the ones displayed in the WebUI of the [B]NORMAL/MAIN[/B] fog server under Other Information, Fog Settings, Fog Storage Nodes. Usually “fogstorage” and “fs####” where #### is a random number between 0000 and 9999.

    Once you update the /opt/fog/service/etc/config.php on the storage node, restart the scheduler service:
    [CODE]sudo /etc/init.d/FOGScheduler restart[/CODE]

    tail the log file and see if the error is resolved.



  • I see and can edit the file, but no one mentions where in the file the text is located or what it looks like to be edited?



  • Same here. You are probably about where I was about 1yr ago. Open up terminal and place sudo in front of the file name.
    sudo [I]filelocation/filename[/I]

    Alternatively you can enable the root account which is not recommended, but I do anyways.
    Open up terminal and type:
    [I]sudo passwd root[/I]

    You can disable it after getting everything configured.[I]
    sudo passwd -l root[/I]



  • I’m a Ubuntu noob… How do I open it as the root user?



  • Even if you open it as the root user?



  • [quote=“ajcke, post: 3549, member: 97”]Did you try editing the file as in post #3? When I was setting all this up I was trying to with Ubuntu Hyper-V VMs which did not work very well. I only had one stand alone box available so I do not have any storagenodes setup currently.[/quote]
    I can’t get to it to edit. When I try to open it I get the error above. I am running servers wirth Ubuntu 10.4 no VMs.



  • Did you try editing the file as in post #3? When I was setting all this up I was trying to with Ubuntu Hyper-V VMs which did not work very well. I only had one stand alone box available so I do not have any storagenodes setup currently.



  • I have the same problem when I try to open FOGImageReplicator I get an error. " The folder contents could not be displayed. You do not have the permissions necessary to view the contents of “FOGImageReplicator”"



  • All right. I got it to work. I had to edit the opt/fog/service/FOGImageReplicator file. There were no database credentials in this file. This file doesn’t want the fog database credentials it wants FOG_STORAGENODE_MYSQLUSER and password. Entering these credentials works!



  • [ATTACH=full]39[/ATTACH]
    I setup a new Ubuntu machine today and installed FOG as a storage node and got the same result. Is there an issue with my database? Is there a file somewhere that needs edited/checked? Screen shot attached.

    [url="/_imported_xf_attachments/0/39_storagenode replication error.jpg?:"]storagenode replication error.jpg[/url]


Log in to reply
 

400
Online

38937
Users

10696
Topics

101490
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.