Fog 1.0.0 and capone plugin



  • I was using fog 0.32. It was running on ubuntu server 12.04 LTS. I went ahead and uninstalled fog according to this article:
    [url=“http://www.fogproject.org/wiki/index.php/Uninstall_FOG”]www.fogproject.org/wiki/index.php/Uninstall_FOG[/url]

    I then installed the newest version of fog using the install script and had root priveleges. I had been using capone, so I went to Activate and Install Capone. Those steps went fine, but now when i click on the Capone plugin, it doesnt take me anywhere. It does change the link, but im still on the same page:

    [url]http://srfog/fog/management/index.php?node=plugin&sub=installed&run=aad276684955eb3421d3edd3e79cd0dc&installed=aad276684955eb3421d3edd3e79cd0dc[/url]

    srfog is the name of my server. I tried using the FQDN but that didnt help. Rebooting the server didnt help. Clearing the cache on my browser (apple safari, chrome, and windows chrome and internet explorer) didnt help

    I have attached a screenshot of what my browser window looks like to this post.

    I did take a look at the apache logs and saw the following:

    tail /var/log/apache2/error.log
    [Tue May 13 09:07:23 2014] [error] [client 10.103.50.98] PHP Fatal error: Call to a member function debug() on a non-object in /var/www/fog/lib/db/MySQL.class.php on line 50, referer: [url]http://srfog/fog/commons/schemaupdater/index.php?redir=1[/url]
    [Tue May 13 09:07:26 2014] [error] [client 10.103.50.98] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/lib/pages/DashboardPage.class.php on line 30, referer: [url]http://srfog/fog/commons/schemaupdater/index.php?redir=1[/url]
    [Tue May 13 09:53:47 2014] [error] [client 10.103.50.98] PHP Fatal error: Call to a member function mainMenu() on a non-object in /var/www/fog/management/index.php on line 72, referer: [url]http://srfog/fog/management/index.php?node=home[/url]
    [Tue May 13 09:54:26 2014] [error] [client 10.103.50.51] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/lib/pages/DashboardPage.class.php on line 30
    [Tue May 13 09:54:26 2014] [error] [client 10.103.50.51] File does not exist: /var/www/favicon.ico
    [Tue May 13 10:12:39 2014] [notice] caught SIGTERM, shutting down
    [Tue May 13 10:12:53 2014] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.11 with Suhosin-Patch configured – resuming normal operations
    [Tue May 13 10:13:53 2014] [error] [client 10.103.50.98] File does not exist: /var/www/fog/managemen
    [Tue May 13 10:20:36 2014] [error] [client 10.103.50.98] PHP Fatal error: Call to a member function mainMenu() on a non-object in /var/www/fog/management/index.php on line 72
    [Tue May 13 10:20:39 2014] [error] [client 10.103.50.98] File does not exist: /var/www/favicon.ico, referer: [url]http://srfog/fog/management/index.php?node=plugin&sub=installed&run=aad276684955eb3421d3edd3e79cd0dc&installed=aad276684955eb3421d3edd3e79cd0dc[/url]
    Does this make sense to anyone? My versions of apache and php are:
    Server Version: Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.11 with
    I reinstalled using sudo apt-get install -f apache2 and rebooted, that did not seem to help.
    Im working on it over here, im hoping i dont have to blow away the entire server (which isnt a big deal on my end), but if anyone has seen this before and knows the answer that would be awesome.

    [url="/_imported_xf_attachments/0/764_fogcapone.PNG?:"]fogcapone.PNG[/url]


  • Developer

    Glad to know it worked, all I can think is that something was left hanging around from the previous install.



  • also wanted to note that it looks much cleaner. and it works right from setting the options on the webpage. no need to manually edit the /tftpboot/pxelinux.cfg/default file anymore!!!

    This release looks great. Thank you for all the work you and the rest of the developers did on it.



  • ok i installed the latest revision, but i was still getting the webpage where it wouldnt load the bottom part.

    I reinstalled the OS (ubuntu 12.04 LTS), and installed fog 1.0.1. i instaklled and activated capone and the web page comes up correctly!



  • you are great jbsclm!

    ya that page does not load correctly for me with latest version 1.0.0.0.

    I will try to do the latest svn (ill check the wiki for how to do that). If i cant get it to go ill wipe the server and see if i still cant load the page.

    Yes i enabled the plugin and installed.

    Ill report back my findings in this thread


  • Developer

    yes, see below.

    The settings are also available in the fog settings->plugin capone section.
    Just a thought, I assume you enabled the plugin system in the settings page,although I can’t see how you would have got as far as you did without it.

    [ATTACH=full]765[/ATTACH]

    [url="/_imported_xf_attachments/0/765_Ubuntu Fog.png?:"]Ubuntu Fog.png[/url]



  • thank you so much for checking that out. If i cant make the stakble 1.0.0.0 install work i will get the latest svn.

    I did want to ask, does that particular capone web page come up for you? the one where you can select the DMI values?
    [url]http://srfog/fog/management/index.php?node=plugin&sub=installed&run=aad276684955eb3421d3edd3e79cd0dc&installed=aad276684955eb3421d3edd3e79cd0dc[/url]


  • Developer

    I’ve just installed the latest svn, r1683, from scratch on ubuntu 12.04, and can confirm that although I haven’t tried a deploy, the web pages come up OK.
    r1683 is available at
    [url]http://svn.code.sf.net/p/freeghost/code/trunk[/url]

    rgds


  • Developer

    I take it you are using 1.0.0, I’ll upgrade my test system to that and get back to you. Capone certainly worked at an earlier svn.


Log in to reply
 

809
Online

38969
Users

10712
Topics

101666
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.