Updating to FOG 1.0.0 from 0.33b



  • Hi Guys! It’s been quite a while since I posted anything… I’ve been SUPER busy with other work upgrades!

    Anyway, I finally got around to updating my FOG install. I went through my normal update procedures through svn update, and everything seemed normal. I ran “sudo ./installfog.sh”, and all was running fine until I got to:

    “* Setting up and starting Apache Web Server…Failed!”

    I checked “/var/log/apache2/error.log” and this is all that it says:


    [Tue May 13 10:18:56 2014] [notice] caught SIGTERM, shutting down
    [Tue May 13 10:19:09 2014] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.11 with Suhosin-Patch configured – resuming normal operations
    [Tue May 13 10:19:48 2014] [notice] caught SIGTERM, shutting down


    I haven’t seen anything on the forums describing this issue… has anyone else experienced this?



  • That did the trick!

    Thanks Jaymes!


  • Developer

    try this
    [code]
    sudo apt-get --purge remove php5 php5-common php5-cli php5-gd[/code]

    then
    [code]
    sudo apt-get install php5 php5-common php5-cli php5-gd[/code]



  • I’ll try that shortly…
    I also tried to start the apache 2 service manually, and this is what I get:


    administrator@FOG:/opt/svn_fog/fog_0.33b/bin$ sudo service apache2 start

    • Starting web server apache2
      apache2: Syntax error on line 210 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: cannot open shared object file: No such file or directory
      Action ‘start’ failed.

    I then looked in “/usr/lib/apache2/modules/” directory, and I see a similar file called “libphp5filter.so”…


  • Developer

    when you get the sigterm shutdown command is apache still serving on port 80?

    [code]
    sudo netstat -nlp | grep 80[/code]

    Do you restart the apache service when you see these errors? Does apache restart correctly without errors?


Log in to reply
 

427
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.