After Ver 1.0.0 update Blank Screen



  • Hi Fog Users,

    FOG is running on, CentOS release 5.10
    [FONT=arial][COLOR=#393939]Linux 2.6.18-371.6.1.el5 on i686[/COLOR][/FONT]

    After I upgraded to V 1.0.0 I have a blank screen when I browse to [url]http://<myhost>/fog/management/index.php[/url]

    Also I see an error in httpd logs,
    PHP Parse error: syntax error, unexpected T_FUNCTION, expecting ‘)’ in /var/www/html/fog/commons/init.php on line 33

    Anybody have any ideas how to fix this?
    Thanks,
    Rick



  • Thanks for the info, using that I found this and updated php on the Fedora 10 box that was getting the white screen.
    I then ran the installer script, which finished correctly now and then I was able to update the fog DB just fine.

    [url]http://www.sohailriaz.com/how-to-update-php-on-servers-centosfedorarhel/[/url]

    thanks for the help Tom


  • Senior Developer

    [quote=“ttricktt, post: 27616, member: 720”][SIZE=3][FONT=arial]I down-graded from version 1.0.0 back to version 32, the reason I was upgrading is because FOG bzimage doesn’t boot newer Lenovo B350 all in one computers. I was hoping newer bzimage might work with the newer computers.[/FONT][/SIZE]
    [FONT=arial][SIZE=3]I’ve been using FOG to image desktops at our school for about 5 years. It would be nice to upgrade to a newer OS, but currently I don’t have an extra server with storage.[/SIZE][/FONT]
    [FONT=arial][SIZE=3]P.S. I did include an error log in the first post,[/SIZE][/FONT]
    [SIZE=3][FONT=arial]PHP Parse error: syntax error, unexpected T_FUNCTION, expecting ‘)’ in /var/www/html/fog/commons/init.php on line 33[/FONT][/SIZE]

    Thanks, Rick[/quote]

    If you’re able, please update, but when you see the FOGMulticastManager issue, open a browser to the FOG Webpage at [url]http://<FOGSERVERIP>/fog/management[/url] and apply the schema update. Then reinstall. All should install properly.


  • Senior Developer

    [quote=“neodawg, post: 27454, member: 87”][code][root@fog ~]# php --version
    PHP 5.2.9 (cli) (built: Apr 17 2009 03:29:12)
    Copyright © 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright © 1998-2009 Zend Technologies
    [/code]

    EDIT:
    was just test updating a Fedora 14 server and got the same thing:
    [code]

    • Starting FOG Multicast Management Server…Failed!
      [root@fogwin bin]# uname -r
      2.6.35.14-106.fc14.x86_64
      [root@fogwin bin]# php -version
      PHP 5.3.8 (cli) (built: Sep 28 2011 17:34:42)
      Copyright © 1997-2011 The PHP Group
      Zend Engine v2.3.0, Copyright © 1998-2011 Zend Technologies
      [/code]

    I dont get a white screen, and am able to upgrade the database and it appears to work fine so far. Just thought I would share[/quote]

    I’ve since learned what the issue with FOGMulticastManager Failed issue is. I don’t know what a suitable fix is, but a workaround that may help serve the purposes is to:

    When you get the error 5.3 php version or higher is now needed and I’ll update that within the schema, open a browser and apply the schema. Then re-perform the install. Nothing will be lost, but it will ensure all your files are all updated and the FOG Service files will startup properly.



  • [quote=“Tom Elliott, post: 27372, member: 7271”]Whats in the error logs?

    And you’re running Fedora 10 and another on CentOS 5.10? I too like to live dangerously.[/quote]

    [SIZE=3][FONT=arial]I down-graded from version 1.0.0 back to version 32, the reason I was upgrading is because FOG bzimage doesn’t boot newer Lenovo B350 all in one computers. I was hoping newer bzimage might work with the newer computers.[/FONT][/SIZE]
    [FONT=arial][SIZE=3]I’ve been using FOG to image desktops at our school for about 5 years. It would be nice to upgrade to a newer OS, but currently I don’t have an extra server with storage.[/SIZE][/FONT]
    [FONT=arial][SIZE=3]P.S. I did include an error log in the first post,[/SIZE][/FONT]
    [SIZE=3][FONT=arial]PHP Parse error: syntax error, unexpected T_FUNCTION, expecting ‘)’ in /var/www/html/fog/commons/init.php on line 33[/FONT][/SIZE]

    Thanks, Rick



  • [quote=“Tom Elliott, post: 27412, member: 7271”]What version of PHP do you have?[/quote]

    [code][root@fog ~]# php --version
    PHP 5.2.9 (cli) (built: Apr 17 2009 03:29:12)
    Copyright © 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright © 1998-2009 Zend Technologies
    [/code]

    EDIT:
    was just test updating a Fedora 14 server and got the same thing:
    [code]

    • Starting FOG Multicast Management Server…Failed!
      [root@fogwin bin]# uname -r
      2.6.35.14-106.fc14.x86_64
      [root@fogwin bin]# php -version
      PHP 5.3.8 (cli) (built: Sep 28 2011 17:34:42)
      Copyright © 1997-2011 The PHP Group
      Zend Engine v2.3.0, Copyright © 1998-2011 Zend Technologies
      [/code]

    I dont get a white screen, and am able to upgrade the database and it appears to work fine so far. Just thought I would share


  • Senior Developer

    What version of PHP do you have?

    [code][root@mastaweb ~]# php --version
    PHP 5.5.12 (cli) (built: May 2 2014 19:53:49)
    Copyright © 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright © 1998-2014 Zend Technologies[/code]



  • [quote=“Tom Elliott, post: 27381, member: 7271”]I think the issue is your php version neodawg.

    Replace your init.php with this:

    [code]mv /var/www/html/fog/commons/init.php /var/www/html/fog/commons/init.php_5.3_only
    wget -O /var/www/html/fog/commons/init.php http://sourceforge.net/p/freeghost/code/1654/tree/trunk/packages/web/commons/init.php?format=raw[/code]

    Hopefully that will help you out.[/quote]

    Hmm… tried and no luck.

    I get this when trying to restart the service:
    [CODE][root@fog bin]# service FOGMulticastManager restart
    Stopping FOGMulticastManager: [FAILED]
    Starting FOGMulticastManager: [ OK ]
    [root@fog bin]# PHP Notice: Undefined variable: missingExtensions in /var/www/html/fog/commons/init.php on line 26
    PHP Notice: Undefined index: FOGCore in /var/www/html/fog/lib/fog/FOGBase.class.php on line 53
    PHP Notice: Trying to get property of non-object in /var/www/html/fog/lib/fog/FOGBase.class.php on line 54
    PHP Notice: Undefined index: HookManager in /var/www/html/fog/lib/fog/FOGBase.class.php on line 55
    PHP Notice: Undefined index: currentUser in /var/www/html/fog/lib/fog/FOGBase.class.php on line 56
    PHP Notice: Undefined index: foglang in /var/www/html/fog/lib/fog/FOGBase.class.php on line 59
    PHP Notice: Trying to get property of non-object in /var/www/html/fog/lib/fog/FOGBase.class.php on line 61
    PHP Notice: Undefined index: conn in /var/www/html/fog/lib/fog/FOGBase.class.php on line 62
    PHP Parse error: syntax error, unexpected T_FUNCTION, expecting ‘)’ in /var/www/html/fog/lib/fog/HookManager.class.php on line 207
    [/CODE]
    I think part of it is that the FOG setup isnt actually completing, not sure what else it needs to do after this.
    [CODE] Configuring services.

    • Setting up fog user…Exists
    • Setting up and starting MySQL…OK
    • Backing up user reports…OK
    • Setting up and starting Apache Web Server…OK
    • Restoring user reports…OK
    • Configuring Fresh Clam…Skipped (See wiki for installation instructions)
    • Setting up storage…OK
    • Setting up and starting NFS Server…OK
    • Setting up and starting DHCP Server…Skipped
    • Setting up and starting TFTP and PXE Servers…OK
    • Setting up and starting VSFTP Server…OK
    • Setting up sudo settings…OK
    • Setting up FOG Snapins…OK
    • Setting up and building UDPCast…OK
    • Installing init scripts…OK
    • Setting up FOG Services…OK
    • Starting FOG Multicast Management Server…OK
    • Starting FOG Image Replicator Server…Failed!
      [/CODE]

  • Senior Developer

    I think the issue is your php version neodawg.

    Replace your init.php with this:

    [code]mv /var/www/html/fog/commons/init.php /var/www/html/fog/commons/init.php_5.3_only
    wget -O /var/www/html/fog/commons/init.php http://sourceforge.net/p/freeghost/code/1654/tree/trunk/packages/web/commons/init.php?format=raw[/code]

    Hopefully that will help you out.



  • Yea, its kinda a test server, but id like to find out the fix for this cause I maintain about 15 FOG servers all on different version of Fedora or CentOS and will probably run into it again.

    On this server:
    I came from .33RC to 1.0.1
    Fedora 10 32bit

    I see this error in the httpd log
    [CODE][Sat May 17 20:14:14 2014] [error] [client 10.22.100.2] PHP Parse error: syntax error, unexpected T_FUNCTION, expecting ‘)’ in /var/www/html/fog/commons/init.php on line 33, referer: http://fog/fog/management/index.php[/CODE]

    I did search around trying to find anything related, but I sure could have missed something.

    The reason my server is old is because it didnt really matter cause FOG hasn’t had an update for a couple of years.


  • Senior Developer

    [quote=“neodawg, post: 27360, member: 87”]Oh yea, I also tried that too, mine was at 32mb and I took it from 32 to 256 with no change. Just double checked it too.[/quote]

    Whats in the error logs?

    And you’re running Fedora 10 and another on CentOS 5.10? I too like to live dangerously.



  • [quote=“pmonstad, post: 27352, member: 17422”]I had the same issue. I solved it by editing php.ini. Increase the value of the variable memory_limit = 32M (I set it to 32M, default on my server was 16M). Then restart your apache server.[/quote]

    Oh yea, I also tried that too, mine was at 32mb and I took it from 32 to 256 with no change. Just double checked it too.



  • [quote=“ttricktt, post: 27031, member: 720”]Hi Fog Users,

    FOG is running on, CentOS release 5.10
    [FONT=arial][COLOR=#393939]Linux 2.6.18-371.6.1.el5 on i686[/COLOR][/FONT]

    After I upgraded to V 1.0.0 I have a blank screen when I browse to [url]http://<myhost>/fog/management/index.php[/url]

    Also I see an error in httpd logs,
    PHP Parse error: syntax error, unexpected T_FUNCTION, expecting ‘)’ in /var/www/html/fog/commons/init.php on line 33

    Anybody have any ideas how to fix this?
    Thanks,
    Rick[/quote]

    I had the same issue. I solved it by editing php.ini. Increase the value of the variable memory_limit = 32M (I set it to 32M, default on my server was 16M). Then restart your apache server.



  • I too am having this same issue.
    server is Fedora 10.

    In reading some posts about install issues with 1.0.x i have noticed that during install that it fails at:
    [CODE]* Starting FOG Multicast Management Server…Failed![/CODE]
    I have restarted the service FOGMulitcastManager and that generates the error listed by ttricktt.
    i looked at the log file at:
    [CODE]/opt/fog/log/multicast.log[/CODE]
    and it says that it fails to connect to mysql database
    [CODE][05-17-14 12:01:12 am] | [05-17-14 12:01:12 am] Failed to connect to database server, will try again in next iteration.[/CODE]
    check the common.php file to make sure that was correct, it was and was able to login to mysql as that user
    [CODE]/var/www/html/fog/commons/config.php[/CODE]

    Thoughts?


Log in to reply
 

373
Online

38982
Users

10712
Topics

101680
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.