TFTP PXE Error after install of 1.0.0



  • HEllo,
    I just upgraded to 1.0.0 and now when I try to go and image, it goes through pulliung DHCP goes to:

    TFTP.
    PXE-T01: File not found
    PXE-E3B: TFTP Error-File not found
    PXE-MOF: Exiting Intel PXE ROM

    I am sure I don’t have something configured correctly…just need to know where to look.



  • Thank you everyone for your help!!!


  • Developer

    if you upgraded from something prior to .33b, your images are in partimage format. any new images you create will be in partclone format. if you need to be able to change what your images are marked as in the database, enable FOG_LEGACY_FLAG_IN_GUI in the General section of fog settings



  • Thank you Tom, everything looks great. Is there a way to change the deploy method? one of my images is set as partclone then when I try to image a client it says its not a partclone client?


  • Senior Developer

    Image Management Page.



  • getting an invalid operating system id (0) on a client now…for the life of me, can find where to change that OS ID now since the upgrade.



  • Got it! the 067 option did the trick!


  • Developer

    [quote=“mlnancejr8808, post: 26988, member: 654”]It is on Ubuntu 12.04 LTS, yes I have access to DHCP. It is added in there. I can not reboot the DHCP server because it is our main Domain Controller. I have ran that command and it tells me:

    ‘tftp’ is not recognized as an internal or external command,
    operable program or batch file.[/quote]

    -.- Add the feature thru windows add remove programs and features. then run the command again.

    do as junkhacker has asked and verify that undionly.kpxe is entered as the bootfile name on your dhcp server. A reboot of the DHCP is preferred though not required, pleas be advised that some DHCP servers need time to push new dhcp ruling, this is where a reboot helps.


  • Developer

    the tftp client is not installed by default on windows 7, but can be added in the add windows features area


  • Developer

    also, with the upgrade to fog 1.0 we no longer use pxelinux.0
    your dhcp option 67 needs to be set to undionly.kpxe instead now



  • It is on Ubuntu 12.04 LTS, yes I have access to DHCP. It is added in there. I can not reboot the DHCP server because it is our main Domain Controller. I have ran that command and it tells me:

    ‘tftp’ is not recognized as an internal or external command,
    operable program or batch file.


  • Developer

    [quote=“mlnancejr8808, post: 26983, member: 654”]HEllo,
    I just upgraded to 1.0.0 and now when I try to go and image, it goes through pulliung DHCP goes to:

    TFTP.
    PXE-T01: File not found
    PXE-E3B: TFTP Error-File not found
    PXE-MOF: Exiting Intel PXE ROM

    I am sure I don’t have something configured correctly…just need to know where to look.[/quote]

    Which OS did you install FOG on?

    Do you have access to your DHCP server? did you add your FOG server as the next-server and the boot file name to the DHCP information? Did you reboot the DHCP server?

    You can start by running a simple command from a working computer (logged in an connected to the same network as the FOG server), you can supply the following command and please tell me the outcome.

    From Windows where x.x.x.x is the ip address of your FOG server:
    [code]
    tftp x.x.x.x get undionly.kpxe[/code]


Log in to reply
 

743
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.