Debian Tweaks to Fix Task Manager and NFS Volume Mount



  • I ran into a number of problems running Fog 0.32 under Debian Wheezy, but I finally got it to work. Here are the config tweaks I found that did the trick. The first three are definitely necessary, whereas some of the others might be part of my “shotgun approach” in which I took some shots in the dark. Hopefully, they’ll help anyone who’s also been banging their head against the wall running Fog under Debian Wheezy (or a recent version of Ubuntu for that matter). Note that I am not using the Fog server to provide DHCP service (see [URL=‘http://www.fogproject.org/wiki/index.php/Installation_on_Debian_Lenny’]the wiki for those tweaks[/URL]).
    [LIST]
    []Edit /etc/default/tftpd-hpa, replacing /srv/tftp with /tftpboot
    [
    ]Edit /var/www/fog/management/includes/tasks.confirm.include.php, replacing every occurrence of &$tmp with $tmp
    []Edit /var/www/fog/management/lib/Group.class.php, replacing &$ireason with $ireason
    [/LIST]
    [B]Unable to Mount NFS Volume[/B]
    These are all the things I tried while the target machine was continually rebooting and getting the mount error…
    [LIST]
    [
    ]Ensured that the fog user has ownership of the images directory: chown -R fog:root /images
    []Tried: touch /images/dev/.mntcheck
    [
    ]Restarted rpcbind: service rpcbind restart
    []Restarted the NFS kernel server: service nfs-kernel-server restart
    [
    ]Added subtree_check as an option to both the /images and /images/dev entries in /etc/exports
    []Restarted rpcbind again
    [
    ]Restarted the NFS kernel server again
    [*]Entered cp /images/dev/.mntcheck /images
    [/LIST]
    After that last command, I found that the target system was successfully being deployed; however, when it finished, it repeatedly returned an error that it was unable to connect to the FTP server. I went into the Fog Settings under Other Information, and under TFTP Server, I replaced the hashed FOG_TFTP_FTP_PASSWORD with the plain english password for the fog user. Following that, I found that the system got past the error and was rebooting.

    pax …and good luck!


  • Moderator

    Good post. I ran 0.32 under Debian 7.4 for a while. I did have to do the first three modifications, but I never ran into the ‘Unable to Mount NFS Volume’ issue.

    That being said, after I switched to Fog 1.0.0 and did a clean install, I did not have to make any modifications to get it to work. So good news for Debian users as we move forward.


Log in to reply
 

353
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.