FOGFTP:ftp_login failed at the end of imaging



  • Hello,

    Everything I try to upload an image at the end of the process I get

    FOGFTP:ftp_login failed ftp_login(): Please specify the password

    Its a fresh install on centos 6.5 and Fog 1.0.0 I downloaded it from SVN yesterday.

    Please help :(



  • For whatever reason fog needs to be connected to the internet or you will get that error. since I have sonicwall doing dchp it doesn’t support option 66 with IP address only hostname.

    Since I had to image using fog dhcp I removed the PC and server from the reset of the network… It didn’t like that.

    Once it began copying the image I connected it back to the rest of the network with internet access and it didn’t have issues anymore.



  • Yessir


  • Developer

    [quote=“Marcos Marti, post: 26721, member: 24067”]Yes could it be my Password is too simple? ‘marcos’[/quote]

    No Mysql will work even without a password. Mysql doesn’t care how benign your password is.

    Basically what everyone is trying to do is get your passwords correct. for reference on files where the passwords are stored and how to edit them

    [url]http://www.fogproject.org/wiki/index.php/Password_Central[/url]



  • And you have set password for the linux user “fog” as this: “passwd fog” ?



  • Yes could it be my Password is too simple? ‘marcos’


  • Developer

    and you’re sure you’ve checked the password here?[ATTACH]718[/ATTACH] and [ATTACH]719[/ATTACH]

    [url="/_imported_xf_attachments/0/718_ftp_settings.png?:"]ftp_settings.png[/url][url="/_imported_xf_attachments/0/719_storage.png?:"]storage.png[/url]



  • Can I just hard code it somewhere? This is driving me crazy

    [url="/_imported_xf_attachments/0/717_photo2.JPG?:"]photo2.JPG[/url]


  • Senior Developer

    [quote=“Marcos Marti, post: 26697, member: 24067”]YES

    Yes

    Yes

    Did it change since yesterday?[/quote]

    I make quite a few changes, as well as Chuck has made a few changes between yesterday and today. I don’t know if there’s been any direct changes to how FTP works, but I assure it does as I run CentOS 6.5 on my servers, and all works fine.

    [quote=“Marcos Marti, post: 26698, member: 24067”]Could it be because im using 64bit OS?[/quote]

    No.



  • Could it be because im using 64bit OS?



  • [QUOTE]Are you sure the password is set correctly in FOG Configuration->FOG Settings->TFTP Server->FOG_TFTP_FTP_PASSWORD? [/QUOTE]

    YES

    [QUOTE]Are you sure the password is set correctly in Storage Management-><YOURSTORAGENODE>->Management Password?[/QUOTE]

    Yes

    [QUOTE]Did you reset the fog user on the local server?[/QUOTE]

    Yes

    [QUOTE]Have you tried updating to the latest revision? [/QUOTE] Did it change since yesterday?


  • Senior Developer

    Okay
    So you’ve verified that ftp is actually running on the server. You’ve verified permissions are correct as well by having it create a test folder.

    Are you sure the password is set correctly in FOG Configuration->FOG Settings->TFTP Server->FOG_TFTP_FTP_PASSWORD?

    Are you sure the password is set correctly in Storage Management-><YOURSTORAGENODE>->Management Password?

    Did you reset the fog user on the local server?

    The /var/www/fog/commons/config.php edits are only used on the initial install of FOG, not after it’s already been installed.

    Have you tried updating to the latest revision?



  • fog ftp_login specify password



  • I followed your instructions be I still get an error.

    I check from another PC and I can connect via FTP and mkdir test



  • Even trying this too…

    Then open the file:
    /var/www/fog/commons/config.php - check the values of: TFTP_FTP_PASSWORD and STORAGE_FTP_PASSWORD
    These MUST match the password you set above, if not write them properly in here
    Finally reload of the service
    /etc/init.d/vsftpd reload



  • Okay I setup all that up and will try to image again.



  • Give this a try:

    1. Set the fog user password in GUI
    2. Change unix fog user password (passwd fog in linux terminal)
    3. Set password (same as point 2) in Storage Management
    4. Set ftp password (same as point 2 and 3) in FOG settings
    5. Restart server

Log in to reply
 

377
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.