Unable to move /images/dev - How to change the default folder creator?



  • I’ve scoured the internet and have tried many solutions to my “unable to move /images/dev/(macaddress) to /images/(image folder)” issue, to no avail.
    After poking and prodding, I stumbled across something. The new image folder in /images/dev has a different owner when the folder is created. These temporary folders are created by “root”. When I chowned -R the folder to the user “fog”, the “unable to move” issue went away.

    Yet, every time I upload a new image, “root” owns the file in in /images/dev, which causes the issue all over again.

    How do I assign the default creator to “fog”? I’m not sure if this is in one of the fog installation configs, or if its a general linux thing. Fog version 0.32 and Ubuntu 10.04 LTS.



  • yup tried that too, doesnt fix the issue. The problem is the workflow - client computer set to upload a new image - folder is created under /images/dev, then is transported to its final spot /images/(image name) . This normally works flawlessly. Yet, it seems that because “root” is the owner of the temporary folder, it wont allow “fog” to copy it and then remove it from its temporary spot. Since this process in fog is consecutive and unattended, there’s no time to pause and chmod or chown the folder.

    Basically I need to make “fog” be the users who creates the temporary image folder. Yet, right now, its “root” who has that honor. I need to figure out where I can assign “fog” for the folder creation process.


  • Developer

    You can try changing the read write values for the folder rather than the owner.

    I’ll probably catch flak for this but try sudo chmod 0777 /images/dev

    That way anyone can write to the dev folder.


Log in to reply
 

468
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.