Error connecting to sql server, in FOG



  • I have fog 0.32 installed on a laptop, and have fog running dhcp and use a 5 port switch to image my pc’s. it has been offline for a few weeks, I started it this am to pull an image from a new dell 7440 and I get to the splash screen and it tells me error connecting to server. I have logged in and changed the time from 3 to 30 secs and nothing, I have already changed my text cfg file and input my password for sql, so I’m not sure if sql is not starting or if dhcp is not starting, I have also ran the cmd for sudo service tftpd-hpa restart but no go. any help is appreciated!



  • [quote=“Jaymes Driver, post: 26305, member: 3582”]Mysql is working!

    You may want to check the following files and verify that the mysql password is correct:

    /var/www/fog/commons/config.php [COLOR=#ff0000]below[/COLOR]
    /opt/fog/service/etc/config.php [COLOR=#ff0000]comes up with blank doc[/COLOR]

    Can you post the contents of your /tftpboot/pxelinux.cfg/default ? [COLOR=#ff0000]below[/COLOR]

    You may perform this command from one of your windows machines connected to the hub to verify that it can grab the pxelinux file
    [code]
    tftp FOGIPADDRESS get pxelinux.0[/code][/quote]

    DISPLAY boot.txt
    DEFAULT fog.local
    LABEL fog.local
    localboot 0
    LABEL fog.memtest
    kernel fog/memtest/memtest
    LABEL fog.reg
    kernel fog/kernel/bzImage
    append initrd=fog/images/init.gz root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=127.0.0.1 mode=autoreg keymap= web=10.10.10.5/fog/ loglevel=4 consoleblank=0
    LABEL fog.reginput
    kernel fog/kernel/bzImage
    append initrd=fog/images/init.gz root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=127.0.0.1 mode=manreg keymap= web=10.10.10.5/fog/ loglevel=4 consoleblank=0
    PROMPT 1
    TIMEOUT 300

    define( “IS_INCLUDED”, true );
    define( “TFTP_HOST”, “10.10.10.5” );
    define( “TFTP_FTP_USERNAME”, “fog” );
    define( “TFTP_FTP_PASSWORD”, “882e1ec394a538f8425014b3eb7171e0” );
    define( “TFTP_PXE_CONFIG_DIR”, “/tftpboot/pxelinux.cfg/” );
    define( “TFTP_PXE_KERNEL_DIR”, “/tftpboot/fog/kernel/” );
    define( “PXE_KERNEL”, “fog/kernel/bzImage” );
    define( “PXE_KERNEL_RAMDISK”, 127000 );
    define( “USE_SLOPPY_NAME_LOOKUPS”, “1”);
    define( “MEMTEST_KERNEL”, “fog/memtest/memtest” );
    define( “PXE_IMAGE”, “fog/images/init.gz” );
    define( “PXE_IMAGE_DNSADDRESS”, “127.0.0.1” );
    define( “STORAGE_HOST”, “10.10.10.5” );
    define( “STORAGE_FTP_USERNAME”, “fog” );
    define( “STORAGE_FTP_PASSWORD”, “882e1ec394a538f8425014b3eb7171e0” );
    define( “STORAGE_DATADIR”, “/images/” );
    define( “STORAGE_DATADIR_UPLOAD”, “/images/dev/” );
    define( “STORAGE_BANDWIDTHPATH”, “/fog/status/bandwidth.php” );
    define( “CLONEMETHOD”, “ntfsclone” ); // valid values partimage, ntfsclone
    define( “UPLOADRESIZEPCT”, 5 );
    define( “WEB_HOST”, “10.10.10.5” );
    define( “WEB_ROOT”, “/fog/” );
    define( “WOL_HOST”, “10.10.10.5” );
    define( “WOL_PATH”, “/fog/wol/wol.php” );
    define( “WOL_INTERFACE”, “eth0” );
    define( “SNAPINDIR”, “/opt/fog/snapins/” );
    define( “QUEUESIZE”, “10” );
    define( “CHECKIN_TIMEOUT”, 600 );
    define( “MYSQL_HOST”, “localhost” );
    define( “MYSQL_DATABASE”, “fog” );
    define( “MYSQL_USERNAME”, “root” );
    define( “MYSQL_PASSWORD”, “********” );
    define( “DB_TYPE”, “mysql” );
    define( “DB_HOST”, MYSQL_HOST );
    define( “DB_NAME”, MYSQL_DATABASE );
    define( “DB_USERNAME”, MYSQL_USERNAME );
    define( “DB_PASSWORD”, MYSQL_PASSWORD );
    define( “DB_PORT”, null );
    define( “USER_MINPASSLENGTH”, 4 );
    define( “USER_VALIDPASSCHARS”, “1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklmnopqrstuvwxyz_hB()^!” );
    define( “NFS_ETH_MONITOR”, “eth0” );
    define(“UDPCAST_INTERFACE”,“eth0”);
    define(“UDPCAST_STARTINGPORT”, 63100 ); // Must be an even number! recommended between 49152 to 65535
    define(“FOG_MULTICAST_MAX_SESSIONS”, 64 );
    define( “FOG_JPGRAPH_VERSION”, “2.3” );
    define( “FOG_REPORT_DIR”, “./reports/” );
    define( “FOG_THEME”, “blackeye/blackeye.css” );
    define( “FOG_UPLOADIGNOREPAGEHIBER”, “1” );
    define( “FOG_VERSION”, “0.32” );
    define( “FOG_SCHEMA”, 23);
    DEFINE(‘BASEPATH’, rtrim($_SERVER[‘DOCUMENT_ROOT’], ‘/’) . rtrim(WEB_ROOT, ‘/’));
    ?>


  • Developer

    Mysql is working!

    You may want to check the following files and verify that the mysql password is correct:

    /var/www/fog/commons/config.php
    /opt/fog/service/etc/config.php

    Can you post the contents of your /tftpboot/pxelinux.cfg/default ?

    You may perform this command from one of your windows machines connected to the hub to verify that it can grab the pxelinux file
    [code]
    tftp FOGIPADDRESS get pxelinux.0[/code]



  • [ATTACH=full]691[/ATTACH]

    [url="/_imported_xf_attachments/0/691_2014-04-29_10-09-14.jpg?:"]2014-04-29_10-09-14.jpg[/url]


  • Developer

    Ah ha now we are getting some where, information is coming to light!

    What happens if you try to connect to the server with putty or a command line and log into mysql?

    use the following command if using putty
    [code]
    mysql -uUSERNAME -hHOST -pPASSWORD[/code]

    I believe you said you set up your own password for the fog user is that correct? if so use that password here.

    If you didn’t set your password for mysql manually, you can look on the fog settings page, there is a setting for storage nodes, there will be a user fogstorage and a password listed, you can use that for testing purposes.



  • Thanks! I added a few shots above, im closer than before, but not sure what the issue is, all worked great, I turned off laptop for about 3 weeks and came back to image more laptops and I have the issues, I assumed from logs it was a sql issue.

    [quote=“Jaymes Driver, post: 26301, member: 3582”]I missed your image above. That error that FOG is displaying to you at the web log in is saying that you don’t have an internet connection, it doesn’t affect the functionality of FOG, you would still be able to use your fog server and browse image stores, create more, add hosts, etc. That is only a check in to the main fog information it kind of gives you an idea of how many fog servers are active in the world and it will check for the latest fog version. This image is not an error. There may be problems with the dns settings, but the server will function without internet access. (I know it references to the mysql database which could be an underlying issue but at first glance it looks benign until we gather more information.)

    When you started your thread you claimed that MySql wasn’t connecting, or may not have been started, then you moved to saying it was DHCP.

    What is it you are trying to accomplish and where does it tell you it can not connect to MySQL? If you can’t explain it well, a screenshot will help immensely[SIZE=2].[/SIZE]

    Also the command to restart the dhcp server is
    [code]
    sudo service isc-dhcp-server restart[/code][/quote]


  • Developer

    I missed your image above. That error that FOG is displaying to you at the web log in is saying that you don’t have an internet connection, it doesn’t affect the functionality of FOG, you would still be able to use your fog server and browse image stores, create more, add hosts, etc. That is only a check in to the main fog information it kind of gives you an idea of how many fog servers are active in the world and it will check for the latest fog version. This image is not an error. There may be problems with the dns settings, but the server will function without internet access. (I know it references to the mysql database which could be an underlying issue but at first glance it looks benign until we gather more information.)

    When you started your thread you claimed that MySql wasn’t connecting, or may not have been started, then you moved to saying it was DHCP.

    What is it you are trying to accomplish and where does it tell you it can not connect to MySQL? If you can’t explain it well, a screenshot will help immensely[SIZE=2].[/SIZE]

    Also the command to restart the dhcp server is
    [code]
    sudo service isc-dhcp-server restart[/code]



  • Ok, here is where I’m now, services are started but still error contacting server, and I get a FOG boot screen I have never seen before.
    [ATTACH=full]688[/ATTACH][ATTACH=full]689[/ATTACH][ATTACH=full]690[/ATTACH]

    [quote=“Jaymes Driver, post: 26296, member: 3582”]No, that is the command to restart the tftp service.

    isc-dhcp-server is the dhcp service.[/quote]

    [url="/_imported_xf_attachments/0/688_2014-04-29_9-20-32.jpg?:"]2014-04-29_9-20-32.jpg[/url][url="/_imported_xf_attachments/0/689_2014-04-29_9-20-24.jpg?:"]2014-04-29_9-20-24.jpg[/url][url="/_imported_xf_attachments/0/690_2014-04-29_9-20-06.jpg?:"]2014-04-29_9-20-06.jpg[/url]


  • Developer

    No, that is the command to restart the tftp service.

    isc-dhcp-server is the dhcp service.



  • Thanks Jaymes, what are the commands?
    sudo service tftpd-hpa status
    sudo service tftpd-hpa restart

    status show’s it running

    [quote=“Jaymes Driver, post: 26282, member: 3582”]I would try to restart the service, or stop and start the service.[/quote]


  • Developer

    I would try to restart the service, or stop and start the service.



  • I had issues so went back to ubun 12.04 LTS, have imaged about 250 laptops with no issues, I turn off my FOG laptop for few weeks and try to pull a new image on 7440. I can see the splash screen and can log in and see my images but I cant get it to connect to the sql server.

    Update, I ran more test and I can log into MySQL so I have the correct password, it seemd that FOG is not giving out dhcp address, the client never can connect. I had set this up log ago on on ver 9 I think and had to run a start dhcp command but I assume that is not in the current ver?

    [url="/_imported_xf_attachments/0/685_2014-04-28_15-17-30.jpg?:"]2014-04-28_15-17-30.jpg[/url]


  • Developer

    [quote=“Dusty_S, post: 26219, member: 22832”]I have fog 0.32 installed on a laptop, and have fog running dhcp and use a 5 port switch to image my pc’s. it has been offline for a few weeks, I started it this am to pull an image from a new dell 7440 and I get to the splash screen and it tells me error connecting to server. I have logged in and changed the time from 3 to 30 secs and nothing, I have already changed my text cfg file and input my password for sql, so I’m not sure if sql is not starting or if dhcp is not starting, I have also ran the cmd for sudo service tftpd-hpa restart but no go. any help is appreciated![/quote]

    What Linux version did you use to install fog on?


Log in to reply
 

483
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.