Ftp error



  • I am stuck with this one even after spening a lot of time in the wiki. I have removed my old fog 0.32 installation on CentOS 5.1 and reinstalled a fresh 0.33B FOG. All is fine. I have imported a host list from my old installation, made a new image and starts upload (win7). All is fine until the end of the upload. Then the client returns error
    FOGFTP: Login failed. Host: 192.168.x.y, Username: fog, Password: xxx, Error: ftp_login(): Login incorrect.

    What i have done to try to figure this out is:

    changed the fog user passord in the GUI (change password)
    changed the unix user fog to a new password (passwd fog …)
    entered this unix fog user password under the FOG_TFTP_FTP_PASSWORD

    Even restarted the server. Still same error message. What have I missed??



  • [quote=“Tom Elliott, post: 26277, member: 7271”]This is correct. If you’re having issues with image uploads, the only place to worry about is the Storage Management Page->All Storage Nodes-><YOUR STORAGE NODE>->Management Username and Passowrd. These should be set to the fog user’s information on the FOG Server’s linux user data.[/quote]

    I know this is a very common source of frustration among FOG users. Could it be an idea to have this explained somewhere on screen after installation/upgrade?

    1. Set the fog user password in GUI
    2. Change unix fog user password (passwd fog in linux terminal)
    3. Set password (same as point 2) in Storage Management
    4. Set ftp password (same as point 2 and 3) in FOG settings

    I guess some frustration is solved with such a reminder.


  • Senior Developer

    [quote=“pmonstad, post: 26266, member: 17422”]I belive I found the solution: Change the password found under menu Storage Management. It seems to be the same unix fog password as used by the ftp server.[/quote]

    This is correct. If you’re having issues with image uploads, the only place to worry about is the Storage Management Page->All Storage Nodes-><YOUR STORAGE NODE>->Management Username and Passowrd. These should be set to the fog user’s information on the FOG Server’s linux user data.



  • I belive I found the solution: Change the password found under menu Storage Management. It seems to be the same unix fog password as used by the ftp server.



  • I’m getting the same error:
    [url]http://fogproject.org/forum/threads/ftp-issue-when-uploading-images-to-san-fog-0-33b.10370/[/url]
    I did try pulling down the revision suggested but the error persisted, I’ve not tried anything since though as I’ve been too busy wit other work.



  • Another thing: during installation I get a message telling "setting up and starting NFS Server… could not find information about service rpcbind: No such file or directory. Still no success.



  • Hi! I have already checked this. The file contains fog:x:709:709::/home/fog:/bin/bash
    Still same problem


  • Developer

    The fix is to edit the /etc/passwd file
    [code]
    sudo gedit /etc/passwd
    [/code]

    Edit the bottom line to look like the following
    [code]
    fog:x:1001:1001::/home/fog:/bin/bash
    [/code]

    Save and reboot, all should be well.


Log in to reply
 

471
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.