PXE Boot Issue with Fog 0.33b



  • I’m currently testing Fog 0.33b on Ubuntu Server 14.04.
    When PXE booting the machine seems to communicate with the Fog server, however once its got an address the next part fails. It happens too quick to see the actual error on a physical machine and with a virtual I had to record the session and slowdown the playback to see the error.

    The Fog PXE boot screen shows very very briefly (less than quarter of a second) and displays the error in the attached file.
    Then it displays a generic PXE error:

    On the VM: FATAL: Could not read from the boot medium! System halted
    On a physical Dell PC: Selected boot device failed. Press any key to reboot the system.

    Capture.png


  • Developer

    Personally I only use the menu for joining new machines to FOG, after that I do everything from the webUI unless I need the debug menu.

    And even now i’m not using that as much thanks to PDQ Invntory, I just export the machines from there into FOG.



  • Makes sense, that first machine displays the menu for about a second now, something must be hanging prior to it loading. Its not an issue at all really as I always adjust the timeout upwards.


  • Developer

    Sometimes a machine will hang when the menu is already loaded causing it to skip right through due to the timeout being met already.



  • It may have been a one off as on other machines its defaulting to 3 seconds as it should, on the other machine the menu was disappearing after less than a second.
    I always increase it to 60 seconds as we don’t PXE boot by default.


  • Developer

    It should be 3 seconds by default.

    Keep in mind most of us don’t want that menu hanging for a long period of time or users will ask us what it is or report the machines as not working just because a fog menu is there.



  • I downloaded the latest release but didn’t do a full re-install, I copied the revised file into my existing installation. The boot menu now displays but it appears to have a very very quick timeout. It started to boot from hard disk within a second of the menu displaying.
    I repeatedly pressed the arrow key while PXE booting to change the default option and the menu appears as it should, I know how to change the timeout so its not huge problem on my installation but I’m not sure if its something that needs addressed.

    Thank you for the quick response and fix.



  • Thank you very much, I’ll give it a test now. If successful, this has to be one of the quickest bug fixes ever!


  • Senior Developer

    r1482 released, should fix this issue for you.


  • Senior Developer

    Fixing as quickly as I can.


Log in to reply
 

469
Online

38914
Users

10684
Topics

101325
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.