How to change sentral DHCP server to work with FOG 0.33B

  • Hi! I am going to test FOG 0.33 in production now and need to know if there are changes in the way the pxe file is set up in DHCP. It has been a long time since I gave the information to the IT department and I need to know it they have to change something or if the old settings will work with the new FOG. Remember something about a filename…

    I ask the question as I am aware of the new PXE system used with FOG 0.33B.

  • Moderator

    I think the best option for you would be to make a backup of you Images folder and your database, and then scrub out 0.32 completely. Then install 0.33 from scratch, import your database and images folders, and then do the database modifications laid out in the wiki. Finally, run the installer one more time, then and only then, log in to the web gui. The only thing that I ran into after that is the TFTP settings that needed correction and for any clients that did not have an image associated I needed to open each host and select an image or the top dropdown option for none.

  • okay
    can you please read the wiki

  • I have renamed the file as you suggested. It starts booting, but I get an error

    [url][/url]… ok
    /fog/kernel/bzImage… No such file or directory ([url][/url])
    Could not boot: No such file or directory [url][/url])

  • Thakns, I will give it a try!

  • You shouldn’t have to register hosts again.

    You WILL have to set OSID’s for the images though as the OSID is not assigned to image, not to host as it was previously.

    Also, you’ll likely need to clear your tasks table.

    You can just rename the undionly.kpxe to pxelinux.0 instead of waiting for the IT office if you must.

  • Thanks. What I did on my production server (Centos) was to download latest release and install it . All went fine without error or warnings

    When logging in there were certain errors or warnings after upgrading the database scheme. I could log in and when browsing hosts there are three lines on top of the screen telling FOG DEBUG: Image: Database Load Failed: ID: 0, Error: Row not found

    I have not dona any testing yet as I have to get the PXE to work. The DHCP server is unchanged as it is located in the cetral IT department. It still contains the pxelinux.0 When booting a client now it still displays the old PXE menu. Is this correct? Will it change when I replace pxelinux.0 with undionly.kpxe?

    The “errors” shown: It this important or do you think things will work when I make a new image and starts deploying, or do I have to register all hosts again?

  • The only thing you’ll need to change for pxe booting to work is:

    Option 67 should be changed to undionly.kpxe instead of pxelinux.0

    You can upgrade from 0.32 to 0.33, though some changes will need to be addressed.


    That link should show you what you’ll need to do.

  • By the way: is it possible to upgrade 0.32 to 0.33?