Fog 0.33b doesn't begin uploading after task scheduled.



  • So I gave up on 14.04. I installed fresh w/ Ubuntu 12.04.4 server x64 - Updated the packages and whatnot. (Maybe that’s my problem.) Anyway setup with FOG 0.33b went smooth. Registered my first host with quick register, created new image in the web gui and assigned it to the host, ran fogprep, scheduled the upload through the task manager - It shows up in the list of scheduled tasks. However when I restart the machine it just boots Windows again after 3 seconds on the boot menu. Tried shutting it all the way down and scheduling it. Turn the machine on - same thing. Am I missing something obvious here?

    Thanks,

    John


  • Senior Developer

    [code]# DHCP Server Configuration file.

    see /usr/share/doc/dhcp*/dhcpd.conf.sample

    This file was created by FOG

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 10.233.219.152;

    subnet 10.233.219.0 netmask 255.255.255.0 {
    option subnet-mask 255.255.255.0;
    range dynamic-bootp 10.233.219.200 10.0.7.250;
    default-lease-time 21600;
    max-lease-time 43200;
    option domain-name-servers 10.233.219.5;
    option routers 10.233.219.152;
    filename “undionly.kpxe”;[/code]


  • Senior Developer

    John Hangouts

    We can all help (Jaymes, Junk, et moi) if that’s good with all of you?!?!)



  • yea i restarted dhcp and the server fog is installed on- this time it came up and didn’t even display the fog menu- there was some text about pxe i couldn’t quite catch it - then straight to windows


  • Developer

    66 is next-server which is your fog ip address which you have supplied with your script
    67 is the boot file which is unidonly.kpxe which you have supplied with your script :)

    Well as long as you change the pxelinux.0 to undionly.kpxe

    You will likely need to reboot your dhcp server in order for it to take effect.



  • and that’s it - nothing about this 66 and 67 should be in there as well?


  • Developer

    filename “pxelinux.0”;

    Should be

    filename “undionly.kpxe”;


  • Developer

    filename needs to be undionly.kpxe for 0.33b



  • tftp is running

    This is what I put in my dhcpd.conf

    if substring (option vendor-class-identifier, 0, 9) = “PXEClient” {
    next-server 10.233.219.152;
    filename “pxelinux.0”;
    }

    What should it say instead?


  • Developer

    have you verified that the tftp server service is running?


  • Developer

    Your DHCP server has options 66 and 67 set right?
    66: yourfogerverip
    67: undionly.kpxe


Log in to reply
 

363
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.