FOG kernel updater GUI will not install kernels



  • When I try to use the Kernel Update GUI I get the message “Error: Failed to install new kernel!”

    This is a user problem (as in we did it to ourselves). We are a long time FOG user on .32 but I have little php experience. It appears that a manual kernel update might of been done in the past. Trying to get back to being able to use the FOG Kernel Updater as designed. Appears to be failing on the ftp_put test at line 110 in Kernel-ftcher.php. “dnr” in the code is my troubleshooting and is the message executed.

    if ( ftp_put( $ftp, $bzImage, $_SESSION[“tmp-kernel-file”], FTP_BINARY ) )
    {
    @unlink($_SESSION[“tmp-kernel-file”]);
    echo “##OK##”;
    }
    else
    {
    echo ( _(“Error: Failed to install new kernel! dnr”) );
    }
    Any ideas what should I test or check to help resolve?

    This started because we are having issues with Dell 760 and E5400s pulling and deploying a workable image.



  • Tom,

    Thank you for your time. This request is finished and resolved. Corrected the information in the Fog Settings. If I had to guess the admin at the time forgot the FOG password and create another account. I just got the “Your new FOG kernel has been installed” message. I will still do some pulls and puts of known images for my comfort. For the issue that initiated this issue I will test kernels and open a new thread if needed.



  • Tom and BPSTravis,

    Thank you, reset the permissions for the ./fog/kernel directory only at this time.

    The ftp test was a good idea because yes I was able to ftp to the box but creating the directory failed. I will be correcting the ftp user information in FOG and test again on Monday. The existing ftp user was not FOG but a user with elevated rights.


  • Senior Developer

    Fog 0.32 /tftpboot permissions should be set as:
    [code]chown -R fog.root /tftpboot[/code]

    Also check that ftp ACTUALLY works for this directory

    login to an ftp session:
    [code]ftp <FOGIPADDRESS>
    User: fog
    Password: <FOG_USER_PASSWORD>
    230 Login successful.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    cd /tftpboot/fog/kernel
    ftp> mkdir testdir
    257 “/tftpboot/fog/kernel/testdir” created[/code]

    I don’t know what else to try, but I do know there were issues, sometimes, with loading one of the Published kernels in FOG. It depended from place to place though.


  • Developer

    Permissions and owners:
    [CODE]drwxr-xr-x 2 fog fog 4.0K Apr 23 15:27 backup
    -rw-r–r-- 1 fog root 11M Apr 18 16:32 bzImage
    -rw-r–r-- 1 fog fog 13M Apr 23 15:27 bzImage2
    [/CODE]



  • Thank you for the reply. I am not in the office now so exact data is limited. Basically my assumption is that it was my group that probably did the damage. My goal is to get the standard kernel upgrade service working. The existing kernel is two years old so it has been awhile since I have tried the magic button.

    ftp works. We pull images and they get ftp’d from tmp into the proper image directory.

    Tried permissions. If you have a fresh install will you provide the owner, group, and permissions for the /tftpboot/fog/kernel and the ./backup directories and the bzimage file. If not then I may try a new install and check permissions. Is there any other locations or files that I need to check like init.gz?

    I already tried Tom’s bzimage32 kernel, (I believe it was Tom). I was able to image the PCs but the image failed. I have not pulled an image yet so it is not a complete test. We were not able to boot the Macs gpxe to FOG with that Kernel. (We also image Macs from the FOG server.


  • Developer

    I have no idea what would’ve caused your kernel updates not to work, I just did a fresh install of .32 and was able to download a kernel.

    Maybe try changing the name.

    To manually download the latest kernel that Tom has made, use this(Will likely work with the machines you were having trouble with):

    Kernel Issues: [url]http://fogproject.org/wiki/index.php/FAQ[/url]


Log in to reply
 

430
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.